CATRom

CATRom este o aplicaţie complexă şi unitară care permite asistarea creării şi managementul subiectelor medicale de interes evaluate critic din domeniile tratament/terapie, diagnostic şi etiologie/prognostic. Aplicaţia de tipul client-server este găzduită de domeniul AcademicDirect şi se găseşte online. CATRom are două funcţii principale:
  1. Asistarea în crearea subiectelor medicale de interes evaluate critic: asistă personalul medical care dispune de abilităţi şi cunoştinţe specifice (cunoscători ai limbii engleze la nivel avansat, abilităţi în formularea întrebărilor medicale de interes, abilităţi în crearea şi realizarea strategiilor de căutare a celor mai recente evidenţe medicale, abilităţi în evaluarea validităţii şi relevanţei evidenţelor medicale, abilităţi de lucru cu calculatorul) în crearea subiectelor medicale de interes evaluate critic;
  2. Managementul subiectelor medicale de interes evaluate critic: asistă medicul practician în căutarea, găsirea, afişarea şi tipărirea subiectelor medicale de interes evaluate critic.
Calitatea subiectelor medicale de interes evaluate critic depinde doar de abilităţile persoanei care a creat subiectul dar cu cunoştinţe elementare de metodologie a cercetării medicale şi statistică medicală, CATRom devine un instrument util în activitatea medicală de zi cu zi.


Subiecte medicale evaluate critic

Subiecte medicale de interes evaluate critic

Subiectele medicale de interes evaluate critic sunt instrumente care ajută practicianul în luarea deciziei medicale. Conceptul de subiect medical evaluat critic a apărut odată cu conceptul de practică medicală bazată pe evidenţe. Conform definiţiei practica medicală bazată pe evidenţe presupune căutarea sistematică a celor mai bune evidenţe, evaluarea acestora şi integrarea evidenţelor rezultate din cercetările clinice valide şi relevante cu experienţa clinică pentru rezolvarea deciziilor medicale zilnice [1] . Primii trei paşi ai practicii medicale bazate pe evidenţe pot fi sumarizaţi în una sau două pagini realizând astfel pentru o problemă clinică de interes aşa numitul subiect medical evaluat critic [2] , [3] .

În diferite specialităţi medicale, subiectele medicale de interes evaluate critic au diferite acronime cum este de exemplu Best Evidence Topics (medicina de urgenţa) [4] sau Evidence-Based Journal Club Reviews (pediatrie) [5] .

Subiectele medicale de interes evaluate critic pun la dispoziţia practicianului metode de formulare a întrebărilor clinice actuale de interes şi de evaluare critică a literaturii de specialitate pentru a răspunde la întrebarea de interes [6] .

Odată cu folosirea resurselor Web în practica medicală şi cu deschiderea oferită de Internet în gestiunea şi managementul informaţiei medicale, unele universităţi şi organizaţii medicale au creat biblioteci on-line de subiecte medicale de interes evaluate critic.

Crearea subiectelor medicale de interes evaluate critic trebuie să permită practicienilor interesaţi de acelaşi subiect medical să evalueze rapid concluziile evidenţei pe baza căreia s-a creat rezumatul.

Avantajele subiectelor medicale de interes evaluate critic sunt:

· prezentarea clară şi explicită a evidenţei medicale clinice;

· reducerea timpului de documentare cu privire la o întrebare clinică specifică (se citesc doar 2 pagini şi nu un articol);

· sumarizarea numerică a mărimii efectelor cu includerea în analiză a intervalelor de confidenţă.

Calitatea ştiinţifică a subiectelor medicale de interes evaluate critic depinde de abilităţile (formularea întrebărilor clinice, stabilirea strategiei de căutare a celor mai recente evidenţe medicale, evaluarea critică a validităţii şi relevanţei evidenţei) şi cunoştinţele persoanei care a creat sumarizarea. În aceste condiţii, subiectele medicale de interes evaluate critic se pot baza pe evidenţe inferioare care prezintă erori sistematice, erori de calcul sau de interpretare. Trebuie să mai ţinem minte ca viaţa subiectelor medicale de interes evaluate critic este scurtă şi sunt valabile doar atâta timp cât nu apare o evidenţă mai bună în domeniul de interes.

Odată create subiectele medicale de interes evaluate critic trebuie păstrate într-o formă care să permită reutilizarea ori de câte ori este nevoie precum şi accesul altor practicieni interesaţi de aceeaşi întrebare clinică. Aceasta se poate realiza cel mai bine prin crearea unei baze de date care să permită atât asistarea medicului în crearea subiectului medical de interes evaluat critic cât şi în managementul acestuia.

Metodologia subiectelor medicale de interes evaluate critic

Din punct de vedere metodologic, sistemul informatic CATRom permite asistarea în crearea subiectele medicale de interes evaluate critic şi managementul acestora. Principalele funcţii ale sistemului sunt:

· asistare în creare;

· căutare;

· filtrare;

· ştergere;

· schimbare parolă utilizator.

Scheletul metodologic de bază al sistemului CATRom de asistare în crearea subiectelor medicale de interes evaluate critic cuprinde:

A. Titlul subiectului medical de interes evaluat critic;

B. Formularea întrebării clinice de interes;

C. Termenii cheie folosiţi în strategia de căutare a celei mai bune evidenţe;

D. Referinţa către articolul pe baza căruia s-a realizat subiectul medical de interes evaluat critic;

E. Caracteristicile studiului;

F. Caracteristicile pacienţilor din studiu;

G. Rezultatele studiului;

H. Comentarii;

I. Autorul subiectului medical evaluat critic;

J. Data la care subiectul medical de interes evaluat critic a fost creat.

A. Titlul subiectului medical de interes evaluat critic

Titlul subiectului medical de interes evaluat critic trebuie să exprime în 250 de caractere conţinutul acestuia. Un titlu bun prezintă concis şi precis problematica la care se adresează subiectul medical evaluat critic. Întrarea clinică de interes poate să reprezinte titlul subiectului medical de interes evaluat critic.

B. Formularea întrebării clinice de interes

În practica curentă, medicul are nevoie de două tipuri principale de cunoştinţe: de fond şi actuale (de perspectivă) 1. Proporţia dintre aceste tipuri de cunoştinţe depinde de experienţa personală în domeniul medical de activitate. În studenţie, când experienţa viitorului practician este foarte limitată acesta are nevoie de cunoştinţe de fond sau de bază. Odată cu acumularea experienţei şi cu apariţie responsabilităţilor clinice, creşte numărul întrebărilor curente, privind abordarea concretă a pacientului, întrebări care sunt punctul de plecare în realizarea subiectului medical de interes evaluat critic.

Întrebările actuale, adresate cunoştinţelor specifice necesare în managementul pacientului cu o anumită patologie au patru componente esenţiale 1, [7] , [8] , [9] :

· pacientul şi/sau problema clinică;

· intervenţia principală;

· intervenţia de comparat;

· rezultatul aşteptat sau consecinţele clinice ale intervenţiei.

Formularea clară şi precisă a întrebărilor clinice de interes este foarte utilă deoarece:

· Ne ajută să ne folosim timpul pe care îl putem dedica educaţiei medicale continue pentru a căuta evidenţele care ne sunt utile în practica clinică curentă;

· Ne ajută să ne dedicăm timpul puţin pe care îl avem la dispoziţie pentru documentare spre evidenţele care sunt adresate direct pacienţilor noştri;

· Ne pot sugera strategii de cercetare;

Există trei problem care împiedică punerea unor întrebări ale căror răspunsuri să ne fie de folos:

A. Când avem un pacient cu o patologie deosebită şi nu ştim de unde şi cum să începem abordarea acestuia. În momentul în care ne-am împiedicat şi nu ştim unde, facem o trecere în revistă a tuturor problemelor legate de pacient. Încercăm să răspundem la întrebările pe care le ridică cazul clinic iar întrebările pentru care nu avem răspuns le transformăm în întrebări la care căutăm răspuns.

B. Probleme în formularea unei întrebări. Când apar astfel de probleme încercăm să punem întrebarea cu voce tare sau să o scriem pe o coală de hârtie. Putem construi întrebarea în doi paşi: în primul rând specificăm problema clinică centrală pe care apoi să o descompunem în componente explicite. Pentru a ne fi mai uşor în formularea întrebărilor clinice putem împărţi coala de hârtie în 4 coloana, una pentru fiecare element al întrebării deoarece este mult mai uşor să scrie întrebarea în componente decât ca şi o frază completă.

C. Când avem mai multe întrebări iar timp disponibil documentării este scurt. Acesta va fi aproape tot timpul, de aceea vom avea nevoie de o strategie care să ne permită să ne decidem de unde anume să începem. Trebuie să ţinem minte însă că învăţarea medicală continuă înseamnă învăţarea pe partiţii mici de-a lungul timpului şi se realizează de câte ori este posibil. Pentru a decide la care întrebare să răspundem prima dată vom lua în considerare următoarele întrebări şi răspunsurile acestora:

· Care întrebare este mai importantă pentru îngrijirea pacientului?

· Care întrebare este mai relevantă pentru nevoile personale de învăţare?

· La care întrebare putem găsi răspuns în timpul pe care îl avem la dispoziţie?

· Care este întrebarea cea mai interesantă?

· Care întrebare are şansa mai mare să se repete în practica noastră medicală?

Formularea întrebărilor clinice de interes - Studii de caz

A. Terapie

O pacientă în vârstă de 40 ani cunoscută cu episoade frecvente de migrenă se prezintă cu exacerbarea migrenei. Doreşte să ştie dacă administrarea riboflavin-ului va determina în cazul dânsei prevenirea migrenelor deoarece a citit într-o revistă că o pacientă de vârstă apropiată cu vârsta dânsei a urmat tratament cu riboflavin şi a fost eficient.

Componentele întrebării clinice:

· pacientul şi/sau problema clinică: pacientă în vârstă de 40 ani cu episoade frecvente de migrenă

· intervenţia principală: tratament cu riboflavin

· intervenţia de comparaţie: fără tratament

· rezultatul/consecinţele clinice: prevenirea migrenelor

Întrebarea clinică de interes: "La o pacientă în vârstă de 40 ani cu episoade frecvente de migrenă, tratamentul cu riboflavin este eficient în scăderea frecvenţei migrenelor şi a severităţii episoadelor de migrenă?"

B. Diagnostic

Un pacient în vârstă de 50 de ani, cunoscut cu dureri lombare cronice se prezintă cu exacerbarea simptomatologiei dureroase însoţită de impotenţă funcţională la nivelul membrului inferior drept. Examenul clinic sugerează un sindrom de compresiune al nervului sciatic drept. Ca şi clinicieni ne întrebăm dacă examinarea cu cea mai înaltă acurateţe în diagnosticul sciatalgiei este rezonanţa magnetică nucleară.

Componentele întrebării clinice:

· pacientul şi/sau problema clinică: pacient în vârstă de 50 ani cu dureri lombare cronice

· intervenţia principală: diagnostic prin rezonanţă magnetică

· intervenţia de comparaţie: radiografie lombară

· rezultatul/consecinţele clinice: diagnostic corect

Întrebarea clinică de interes: "Care este acurateţea examinării prin rezonanţă magnetică pentru diagnosticul corect al unui pacient în vârstă de 50 de ani cu dureri lombare cronice care se prezintă cu simptomatologia sugestivă a unui sindrom de compresiune a nervului sciatic drept?"

C. Prognostic

Un pacient în vârstă de 58 ani a prezentat în urmă cu câteva săptămâni dureri intermitente lombare drepte cu iradiere în fosa iliacă dreaptă, fără hematurie microscopică sau modificări semnificative radiografice, la urografia intravenoasă sau la examinarea computer tomografică. Durerea este posibil să fi fost determinată de pasajul unui calcul de oxalat de calciu. Funcţia renală şi electroliţii sunt în limite normale iar microscopia din sedimentul urinar şi cultura din urină au fost negative. Dorim să prevenim o posibilă manifestare clinică de genul celei experimentate de pacient şi vrem să ştim care este şansa unei recurenţe.

Componentele întrebării clinice:

· pacientul şi/sau problema clinică: pacient în vârstă de 58 ani

· intervenţia principală: recurenţa unei colici ureterale

· intervenţia de comparaţie: -

· rezultatul/consecinţele clinice: prevenirea unei recurenţe după o singură colică ureterală

Întrebarea clinică de interes: "La un pacient în vârstă de 58 ani care este riscul recurenţei calculilor ureterali după un singur episod de colică ureterală?"

C. Termenii cheie folosiţi în strategia de căutare a celei mai bune evidenţe

Odată formulată întrebarea clinică de interes va trebuie să definim cuvintele cheie care ne vor ajuta în găsirea celei mai actuale evidenţe necesară pentru a răspunde la întrebare. În această etapă trebuie să conştientizăm că:

· stabilirea cuvintelor cheie de căutare este esenţială în găsirea celei mai bune evidenţe care să răspundă întrebării de interes;

· stabilirea corectă a cuvintelor cheie ne va orienta spre un anumit tip de evidenţă sau spre altul, dictând astfel nivelul şi gradarea evidenţei folosită în găsirea celui mai bun răspuns.

Este bine cunoscut la ora actuală faptul că cele mai bune resurse de evidenţe medicale sunt cele electronice (reviste electronice - JAMA, baze de date cu resurse medicale – EMBASE, Biblioteca Cochane, Medline etc.) deoarece pot fi aduse la zi cu informaţii curente foarte uşor.

Majoritatea resurselor de căutare sunt în limba engleză şi pun la îndemâna utilizatorului materiale în limba engleză, astfel încât practicianul care va crea subiectul medical de interes evaluat critic va trebui să cunoască această limbă la un nivel care să-i permită scrierea corectă şi înţelegerea conceptelor pe care le citeşte. Pentru a găsi răspuns la întrebarea de interes formularea cuvintelor cheie trebuie să fie corectă. Medline pune la dispoziţia utilizatorului un index al termenilor medicali care permite verificarea corectitudinii cuvintelor medicale folosite în strategiile de căutare.

Termenii cheie folosiţi în strategia de căutare a celei mai bune evidenţe vor fi astfel într-o limbă de circulaţie internaţională, fiind singura parte din CATRom care nu este în limba română.

Alegerea corectă a evidenţei

Putem împărţi cercetările în două categorii fundamentale: cercetări primare (se pune accent pe pacient şi/sau populaţie) şi cercetări secundare (se pune accent pe revizuirea cercetărilor primare). În funcţie de întrebarea clinică la care dorim răspuns vom căuta cea mai bună evidenţă ţinând cont de tipul de studiu care stă la baza cercetării respective (tabel 3, 4 [10] ).

Tabelul 3. Metode de cercetare pentru diferite tipuri de intervenţii medicale

Intervenţia | Studii calitative | Caz-martor | Cohortă | Trialuri clinice randomizate | Sinteze sistematic
Diagnostic |  |  | ☺ | ☺☺ | ☺☺☺
Tratament |  |  | ☺ | ☺☺ | ☺☺☺
Depistare |  |  |  | ☺☺ | ☺☺☺
Management de sănătate | ☺ | ☺ | ☺ | ☺☺ | ☺☺☺

Tabelul 4. Metode de cercetare pentru diferite tipuri arii de interes medical

 | Tip de studiu
Rezultat | Calitativ | Supravieţiore | Caz – martor | Cohortă | Trial clinic randomizat | Sinteză sistematic
Eficienţa unei Intervenţii |  |  |  |  | ☼☼ | ☼☼☼
Eficienţa unui serviciu de sănătate | ☼ | ☼ | ☼ | ☼ | ☼☼ | ☼☼☼
Siguranţa | ☼ | ☼ |  |  | ☼☼ | ☼☼☼
Acceptabilitatea | ☼ | ☼ |  |  | ☼☼ | ☼☼☼
Cost-eficienţa |  |  |  |  | ☼☼ | ☼☼☼
Oportunitatea | ☼ | ☼ |  |  |  | ☼☼☼
Calitatea | ☼ | ☼ | ☼ | ☼ |  | ☼☼☼

În funcţie de tipul de întrebare clinică la care dorim un răspuns vom crea o strategie sau alta de căutare a celui mai bun răspuns. Dacă întrebarea la care dorim răspuns este o întrebare de fond putem începe căutarea răspunsului prin consultarea unui tratat sau al unui compediu. Trebuie însă conştientizat faptul că, este greu de stabilit care componente ale tratatului sunt cu adevărat la zi. Nu este recomandabil ca aceste surse de documentare să fie folosite pentru probleme de etiologie, diagnostic, prognostic, profilaxie şi tratament. Pentru ca un tratat să poată fi acceptat ca sursă de informare curentă trebuie:

· să fie frecvent revizuită (cel puţin o dată pe an);

· afirmaţiile să fie însoţite de referinţe care să dea posibilitatea cititorului să le consulte pentru a le stabili validitatea şi relevanţa.

Dacă întrebarea la care dorim un răspuns este o întrebare actuală (de perspectivă) putem începe căutarea unui răspuns într-un tratat dar nu vom neglija resursele electronice şi/sau revistele de specialitate. Spre deosebire de revistele tipărite, resursele electronice (reviste electronice - JAMA, baze de date cu resurse medicale – EMBASE, Biblioteca Cochane, Medline etc.) sunt resurse care pot fi aduse la zi cu informaţii curente foarte uşor iar căutarea informaţiilor este mai rapidă şi mai uşoară. Dacă nu avem acces la revista pe care o dorim, ne interesăm dacă nu cumva unul din colegii noştri nu au acces sau dacă nu există un abonament al spitalului în care lucrăm sau la biblioteca celei mai apropiate Universităţi de Medicină.

Surse de evidenţe

Majoritatea surselor de documentare medicală sunt publicate într-o limbă de circulaţie internaţională şi sunt accesibile contra cost (tabel 5). Astfel, medicul din românia are de trecut două bariere, una fiind reprezentată de limba de publicare a evidenţelor medicale iar cea de-a doua de costul accesului la aceste publicaţii.

Tabelul 5. Portaluri de acces la evidenţe medicale primare şi/sau secundare

Denumire

Specificaţii

Surse de evidenţe primare

Annals of Internal Medicine

Adresa: http://www.annals.org/

Acces prin abonament anual individual sau instituţional

The New England Journal of Medicine

Adresa: http://content.nejm.org/

Acces gratuit

Canadian Medical Association Journal

Adresa: http://www.cmaj.ca/

Abonament anual:

- Canada: 161$(Individual) – 257$(Instituţional)

- Alte ţări: 241$(Individual) – 280$(Instituţional)

JAMA

(The Journal of American Medical Association)

Adresa: http://jama.ama-assn.org/

Abonament anual:

- America: 100$(Individual-online) – 575$(Instituţional)

- Alte ţări: 125€(Individual-online) – 500€(Instituţional)

The Lancet

Adresa: http://www.thelancet.com/

Abonament anual:

Europa: 146€(Individual-online) – 699€(Instituţional)

America: 152$(Individual-online) –747$(Instituţional)

British Medical Journal

Adresa: http://bmj.bmjjournals.com/index.dtl

Acces gratuit

Medline

Adresă: http://www.pubmed.com

- bază de date electronică cu acces gratuit creată şi menţinută de Centrul Naţional pentru Biotehnologie a Informaţiei al Bibliotecii Naţionale de Medicină a Statelor Unite ale Americii;

Surse de evidenţe secundare

Clinical Evidence

Adresa: http://www.clinicalevidence.com/

Acces gratuit

Bandolier

Adresa: http://www.evidence-based-medicine.co.uk/bandolier.html

Abonament lunar:

- Printat: Marea Britanie şi Irlanda 36£; restul lumii 72£

- Online gratuit: apare la 3 luni după publicarea revistei

Evidence Based Medicine Online

Adresa: http://ebm.bmjjournals.com/

Distribuţie gratuită

The Cochrane Library

Adresa: http://www.cochrane.org/reviews/clibintro.htm

Abonament anual: 265$(Individual) – 495$(Instituţional)

EMBASE

Adresa: http://www.embase.com/

- bază de date electronic europeană de literatură farmacologică si biomedicală, cuprinzând 5000 de titluri de publicaţii medicale, apărute în 70 de ţări;

- anul de acoperire - din 1974 până în prezent.

Evidence-Based Medicine Reviews

Adresa: http://lewis.hul.harvard.edu/

- este o resursă electronică realizată şi menţinută de Universitatea Harvard, de informare în domeniul practicii medicale bazate pe evidenţe;

- două publicaţii medicale: ACP Journal Club (cuprinde publicaţii din 1991 până în prezent) apărut sub îngrijirea American College of Physicians şi Evidence-Based Medicine (publicaţii din 1995 până în 1999), apărută sub coordonarea ACP şi The British Medical Journal Group;

DARE – Database of Abstracts of Reviews of Effectivenes

Adresa: http://www.york.ac.uk/inst/crd/darehp.htm

Acces gratuit

CINAHL (Cumulative Index to Nursing & Allied Health)

Adresa: http://www.library.ucsf.edu/db/cinahl.html

Specificaţii: - Access contra cost

ISI Web of Knowledge

Adresa: http://wos.mimas.ac.uk

Specificaţii:

- Conţine patru baze de date;

- Acoperă 5700 de publicaţii medicale (mai mult de 17 milioane de articole), apărute începând cu 1973

D. Referinţa către articolul pe baza căruia s-a realizat subiectul medical de interes evaluat critic

Referinţa către articolul pe baza căruia s-a realizat subiectul medical de interes evaluat critic se va scrie conform stilului Vancouver de citare a unui articol original, cuprinzând:

· numele autorului (autorilor) urmat de iniţiala prenumelui;

· titlul articolului;

· titlul revistei medicale în care articolul a fost publicat sau abrevierea acestuia (nu se folosesc semne de punctuaţie în abrevierea titlului jurnalului);

· anul publicaţiei;

· volumul;

· specificarea paginii de început şi sfârşit a articolului.

Modalitatea în care trebuie inclusă o referinţă în modulul de asistare a creării subiectului medical de interes evaluat critic este următoare:

Valls C, Cos M, Figueras J, Andía E, Ramos E, Sánchez A, Serrano T and Torras J. Pretransplantation Diagnosis and Staging of Hepatocellular Carcinoma in Patients with Cirrhosis: Value of Dual-Phase Helical CT. AJR 2004 182:1011-1017.

E. Caracteristicile studiului

F. Caracteristicile pacienţilor din studiu

G. Rezultatele studiului

Caracteristicile studiului, caracteristicile pacienţilor şi respectiv rezultatele studiului sunt distincte pentru cele 3 domenii medicale impuse reprezentate de tratament/terapie, diagnostic, etiologie/prognostic. Indiferent de domeniul medical, pentru a ne baza decizia medicală pe un subiect medical de interes evaluat critic trebuie să fim în stare să evaluăm validitatea şi relevanţa evidenţei pe baza căruia a fost creat. Pentru aceasta va trebui să citim cu atenţie studiu pentru a înţelege metodologia de realizare a acestuia.

Evaluarea unui articol medical se face mai uşor cu ajutorul unor fişe de evaluare:

· Studii diagnostice

· Tcr

· Sinteze

· Studii calitative

· Studii caz-martor

· Studii de cohortă

Evaluarea studiilor medicale

Evaluare studii terapeutice

Evaluarea relevanţei. Evaluarea relevanţei poate fi considerată prima etapă a evaluării critice a unei evidenţe medicale. Ne interesează astfel dacă tratamentul este disponibil. Dacă nu avem acces la tratamentul respectiv, tratamentul este neînsemnat pentru practica noastră medicală iar evidenţa găsită poate fi ignorată.

Dacă tratamentul este disponibil trebuie să vedem dacă pacientul nostru nu este diferit de pacienţii incluşi în studiul pe care îl citim, astfel încât rezultatele studiului să poată fi aplicate pacientului de interes.

Evaluarea validităţii. În momentul în care dorim informaţii cu privire la o intervenţie terapeutică construcţia studiului care ne va aduce cele mai valide rezultate va fi reprezentată de trialul clinic randomizat.

Pentru evaluarea validităţii unui studiu diagnostic, metodologia sistemul informatic impune răspunsul închis (selectarea unei singure opţiuni din listă) sau deschis (răspuns liber) la următoarele întrebări:

1. Tipul studiului (Trial clinic, Studiu caz-martor, Studiu de cohortă);

2. Studiul orb (Simplu, Dublu, Nu ştiu);

3. Numărul de pacienţi incluşi în studiu;

4. Criteriile de includere în studiu;

5. Criteriile de excludere din studiu;

6. Pierduţi din vedere în grupul caz;

7. Pierduţi din vedere în grupul martor;

8. Tratamentul urmat de grupul caz;

9. Tratamentul urmat de grupul martor;

10. Pacienţii din grupul caz au fost similari cu cei din grupul martor? (Da, Nu, Nu ştiu);

11. Completarea tabelului de contingenţă.

Rezultatele studiului. În realizarea subiectului medical de interes evaluat critic este necesar doar specificarea valorilor tabelului de contingenţă 2´2, CATRom punând la dispoziţia celui care creează subiectul totalitatea indicatorilor medicali care se pot calcula pe baza acestuia împreună cu intervalele de confidenţă de 95% asociate.

Interpretarea rezultatelor revine însă utilizatorului care trebuie să ştie cum şi ce să interpreteze. Studiile terapeutice pot fi experimentale (trialul clinic) sau observaţionale (caz-martor, cohortă). În funcţie construcţia studiului au valoare clinică doar anumiţi indicatori medicali (tabelul 1).

Tabelul 1. Tipul de studiu, modalitatea de culegere a datelor, indicatorii medicali

Tip studiu | Eşantionul (metoda de culegere a datelor) | Culegerea datelor | Indicatori medicali
Trial clinic | eşantion reprezentativ | prospectiv | Toţi indicatorii Excepţie rata şansei
Caz-martor | caz-martor | retrospectiv | Rata şansei
Cohortă | expus-nonexpus eşantion reprezentativ | prospectiv | Toţi indicatorii Excepţie rata şansei

Indicatorii pentru evaluarea rezultatelor unui studiu terapeutic se calculează pe baza tabelului de contingenţă al cărui model este prezentat în tabelul 2, unde:

· a = adevărat pozitivi (numărul de pacienţi care au primit tratamentul studiat şi la care tratamentul a avut efect);

· b = falşi pozitivi (numărul de pacienţi care au primit tratamentul studiat şi la care tratamentul nu a avut efect);

· c = falşi negativi (numărul de pacienţi care au primit tratamentul de control şi la care tratamentul administrat a avut efect);

· d = adevărat pozitivi (numărul de pacienţi care au primit tratamentul de control şi la care tratamentul administrat nu a avut efect);

· T+ = tratament de studiat; Test+ = test diagnostic pozitiv; FR(P)+ = factor de risc (prognostic) prezent;

· T- = tratament standard sau palcebo; Test- = test diagnostic negativ; FR(P)- = factor de risc (prognostic) absent;

· R+ = răspuns terapeutic pozitiv; B+ = boală prezentă;

· R- = fără răspuns terapeutic; B- = indemn de boală.

Tabelul 2. Notaţii în tabelul de contingenţă 2´2

 | R+(B+) | R‑(B-) | Total
T+( Test+; FR(P)+) | a | b | a+b
T-( Test-; FR(P)‑) | c | d | c+d
Total | a+c | b+d | a+b+c+d

Se pot calcula următorii indicatori medicali:

1. Rata evenimentului experimental (REE) = proporţia pacienţilor din grupul caz care prezintă evenimentul de interes.

2. Rata evenimentului de control (REC) = proporţia pacienţilor din grupul de control care prezintă evenimentul de interes.

3. Reducerea relativă a riscului (RRR) = reducerea procentuală a evenimentelor din grupul caz faţă de evenimentele din grupul martor raportat la evenimentele din grupul martor

Când un tratament experimental creşte probabilitatea de apariţie a evenimentului dorit, pe baza formulei RRR se calculează creşterea relativă a beneficiului (creşterea proporţională a ratei evenimentului dorit la grupul caz faţă de grupul martor).

Dacă tratamentul experimental creşte probabilitatea unui eveniment nedorit, pe baza formulei RRR se calculează creşterea relativă a riscului (proporţia creşterii ratei de apariţie a unui eveniment nedorit la grupul caz faţă de grupul martor).

4. Reducerea absolută a riscului (RAR) = diferenţa absolută dintre rata evenimentului la grupul experimental şi rata evenimentului la grupul de control

RAR = |REE-REC|

Când un tratament experimental creşte probabilitatea de apariţie a evenimentului dorit, pe baza formulei RAR se calculează creşterea absolută a beneficiului (diferenţa absolută între rata evenimentului dorit la cazuri şi martori).

Dacă tratamentul experimental creşte probabilitatea unui eveniment nedorit, pe baza formulei RAR se calculează creşterea absolută a riscului (diferenţa matematică absolută între rata evenimentului nedorit la cazuri şi martori).

5. Numărul necesar a fi tratat (NNT) = numărul de pacienţi care trebuie să beneficieze de terapia luată în studiu pentru a preveni un eveniment nefavorabil. Este o modalitate numerică de a exprima probabilitatea beneficiului unui tratament, definit ca reciproca reducerii absolute a riscului.

Interpretare! NNT = 3 → 3 persoane cu simptomatologia de interes trebuie să primească tratament pentru ca una să nu mai prezinte simptomatologia!

Când un tratament experimental creşte probabilitatea de apariţie a evenimentului dorit, pe baza formulei NNT se poate calcula numărul necesar a fi tratat.

Dacă tratamentul experimental creşte probabilitatea unui eveniment nedorit, pe baza formulei NNT se calculează numărul necesar a dăuna (numărul de pacienţi care primind tratamentul va determina apariţia unui eveniment nefavorabil).

6. Riscul relativ sau rata riscului (RR) = raportul dintre riscul absolut pentru grupul caz şi riscul relativ pentru grupul martor

Interpretare! Pentru trialuri clinice randomizate, care sunt studii lipsite de erori sistematice o valoare a lui RR > 1 —› luat în serios.

7. Rata şansei (RS) = şansa unui răspuns terapeutic pozitiv în grupul celor care primesc tratamentul de interes raportat la şansa unui răspuns terapeutic pozitiv în grupul celor care primesc tratamentul standard sau placebo

Interpretare! RS ~ 1 → nu există nici o legătură dintre răspunsul terapeutic pozitiv şi tratamentul de interes; RS < 1→ asociere inversă între răspunsul terapeutic şi tratamentul de interes.

Când un tratament experimental creşte probabilitatea de apariţie a evenimentului dorit

1. Creşterea relativă a beneficiului (CRB) = creşterea proporţională a ratei evenimentului dorit la grupul caz faţă de grupul martor

2. Creşterea absolută a beneficiului (CAB) = diferenţa absolută între rata evenimentului dorit la cazuri şi martori

3. Numărul necesar a fi tratat (NNT) = este o modalitate numerică de a exprima probabilitatea beneficiului unui tratament, definit ca reciproca reducerii absolute a riscului.

Când un tratament experimental creşte probabilitatea de apariţie a unui eveniment nedorit

1. Creşterea relativă a riscului (CRR) = proporţia creşterii ratei de apariţie a unui eveniment nedorit la grupul caz faţă de grupul martor

2. Creşterea absolută a riscului (CAR) = diferenţa matematică absolută între rata evenimentului nedorit la cazuri şi martori

CAR = |REE-REC|

3. Numărul necesar pentru a dăuna (NND) = numărul de pacienţi care primind tratamentul va determina apariţia unui eveniment nefavorabil.

Fiecare din indicatorii medicali prezentaţi mai sus se calculează pe baza formulelor prezentate iar valoarea punctuală a acestora este însoţită de intervalul de confidenţă 95% asociat. Denumirea indicatorului medical, denumirea indicatorului folosită în program, denumirea funcţiei de calcul a intervalului de confidenţă şi referinţa către lucrarea care prezintă performanţele metodei de calcul a intervalului de confidenţă sunt prezentate în tabelul 3.

Tabelul 3. Denumirea indicatorului medical, a funcţiei de calcul a intervalului de confidenţă şi

referinţa carte lucrarea care prezintă performanţele metodei de calcul pentru studiile terapeutice

Nr. | Parametrul medical (abreviere) | Denumire folosită în program | Denumire funcţie interval de confidenţă | Ref.
1 | Rata evenimentului experimental (REE) | RataEvenimentExperimental | Binomial | [11]
2 | Rata evenimentului de control (REC) | RataEvenimentControl | Binomial | 11
3 | Reducerea absolută a riscului(RRA) Creşterea absolută a riscului (CAR) | ReducereRiscAbsolut | ADAC | [12]
4 | Numărul necesar a fi tratat (NNT) Numărul necesar a dăuna (NND) | NumarNecesarTratat | IADAC | [13]
5 | Reducerea relativă a riscului (RRR) Creşterea relativă a riscului (CRR) | ReducereRiscRelativ | ARPAC | [14]
6 | Riscul relativ (RR) | RiscRelativ | RPAC2 | [15]
7 | Rata şansei (RS) | RataSansei | R2AC | [16]

Evaluare studii de diagnostic

Evaluarea relevanţei studiilor diagnostice este identică cu cea a celor terapeutice, motiv pentru care nu intră în discuţie.

Evaluarea validităţii unui articol medical care tratează o problemă de diagnostic se realizează prin răspunsul deschis (narativ) sau închis (alegerea răspunsului corect dintr-o listă sau bifarea unui buton de tip radio corespunzător răspunsului corect) la următoarele întrebări:

1. Tipul studiului (caz-martor, cohortă, încrucişat, experimental simplu orb, experimental dublu orb);

2. Comparaţie independentă a noului test diagnostic cu un ‚standard de aur’ (Da, Nu, Nu ştiu);

3. Testul diagnostic standard a fost aplicat fără a se cunoaşte rezultatul noului test diagnostic (Da, Nu, Nu ştiu);

4. Noul test diagnostic este reproductibil? (Da, Nu, Nu ştiu);

5. Numărul total de pacienţi incluşi în studiu;

6. Criteriile de includere în studiu;

7. Criteriile de excludere din studiu;

8. Caracteristicile grupului caz;

9. Caracteristicile grupului martor;

10. Descrierea testului diagnostic;

11. Descrierea testului standard;

12. Pacienţii din grupul caz sunt similari cu cei din grupul martor? (Da, Nu, Nu ştiu);

13. Completarea tabelului de contingenţă.

Rezultatele studiului şi evaluarea acestora. Studiile de evaluare a unui procedeu diagnostic sau de depistare pot fi observaţionale (cros-secţionale, caz-martor, cohortă) sau experimentale. În funcţie construcţia studiului au valoare anumiţi indicatori medicali calculaţi pe baza tabelului de contingenţă (vezi tabelul 4).

Tabelul 4. Tip de studiu, modalitate de culegere a datelor, indicatori medicali pentru studiile diagnostice

Tip studiu | Eşantionul (metoda de culegere a datelor) | Culegerea datelor | Indicatori medicali
Cros-secţional | Selectarea unui eşantion fără clasificarea participanţilor în bolnav şi indemn la boala de interes (eşantion reprezentativ) | prezent | Toţi indicatorii
Caz-martor | Două eşantioane, unul cu pacienţi care prezintă patologia de interes şi al doilea cu pacienţi care nu prezintă patologia de interes (caz-martor) | retrospectiv | Sensibilitate; Specificitate Rata falşilor pozitivi Rata falşilor negativi Probabilitatea unui test pozitiv Probabilitatea unui test negativ Rata şansei
Cohortă | Două eşantioane unul la care se aplică testul diagnostic de interes şi altul la care nu se aplica testul diagnostic (expus-nonexpus) | prospectiv | Valoare predictivă pozitivă Valoare predictivă negativă Probabilitate test pozitiv greşit Probabilitate test negativ greşit Probabilitatea unui test negativ Probabilitatea unui test pozitiv Risc relativ Diferenţa de proporţii
Experimental | Selectarea unui eşantion al cărui statut de bolnav sau indemn la patologia de interes nu este cunoscut, căruia i se aplică testul de interes şi respectiv testul standard (eşantion reprezentativ) | prospectiv | Toţi indicatorii

Indicatori medicali calculaţi pe baza tabelului de contingenţă sunt:

1. Sensibilitatea (capacitatea testului de a identifica indivizii purtători ai bolii) = proporţia de subiecţi cu test pozitiv din totalitatea celor bolnavi

2. Specificitatea (capacitatea testului de a identifica subiecţii indemni de boală) = proporţia de subiecţi negativi din totalitatea celor indemni de boală

3. Raţia de probabilitate = probabilitatea cu care un anumit rezultate al testului diagnostic (pozitiv sau negativ) apare la un pacient cu boala de interes în comparaţie cu probabilitatea cu care acelaşi rezultat apare la un pacient indemn la boala de interes.

Raţia de probabilitate pozitivă (RPP) = raţia de probabilitate pentru un test diagnostic pozitiv.

Raţia de probabilitate negativă (RPN) = raţia de probabilitate pentru un test diagnostic negativ

Interpretare!

Raţia de probabilitate = 0: exclude boala;

Raţia de probabilitate = ¥: exclude normalitatea;

Raţia de probabilitate > 10 sau < 0.10: şansă mare de boală;

Raţia de probabilitate = 5 - 10 sau 0.10 – 0.2: şansă medie de boală;

Raţia de probabilitate = 2 – 5 sau 0.20 – 0.50: şansă mică de boală;

Raţia de probabilitate = 1: nici o şansă de boală.

4. Rata falşilor pozitivi (False Pozitive Rate) şi Rata falşilor negativi (False Negative Rate) = indicatori utilizaţi pentru aprecierea valorii diagnostice a unui test derivaţi din sensibilitate şi specificitate.

Rata falşilor pozitivi:

Rata falşilor negativi:

5. Valoarea predictivă pozitivă (capacitatea de a prezice unui subiect cu test pozitiv riscul de a fi bolnav) = proporţia de subiecţi cu adevărat bolnavi din totalitatea celor cu test pozitiv.

6. Valoarea predictivă negativă (capacitatea de a prezice unui subiect cu test negativ riscul de a fi indem la boală) = proporţia celor cu adevărat indemni de boală din totalitatea celor cu test negativ

7. Prevalenţa bolii = măsoară frecvenţa tuturor cazurilor de boală la un moment dat

8. Şansa pre-test = şansa de a avea o anumită patologie

9. Şansa post-test = produsul dintre şansa pre-test şi raţia de probabilitate

SPostT = SansaPre-Test · Raţia de Probabilitate

10. Probabilitatea post-test = şansa post-test raportată la diferenţa dintre şansa post-test şi 1

Interpretare! Aprecierea modului în care probabilitatea post-test va afecta managementul pacientului se realizează prin încadrarea probabilităţii post-test în diagrama pragurilor test-tratament (figura 1).

Figura 1. Diagrama pragurilor test-tratament

Există două praguri ale testului diagnostic, pragul A sau pragul testului şi pragul B sau pragul tratamentului. În primul caz (pragul A, pragul testului), dacă testul diagnostic a fost negativ sau generează o raţie mică de probabilitate (în jur de 0.1), probabilitatea pot-test va fi aşa de mică încât putem abandona diagnosticul şi să ne orientăm spre un alt diagnostic. În al doilea caz (pragul B, pragul tratamentului), un test diagnostic pozitiv care generează o raţie înaltă de probabilitate poate genera o probabilitatea post-test atât de mare, încât devine inutilă orice altă testare, diagnosticul fiind evident. Dacă rezultatele testului diagnostic se regăsesc între cele două praguri se va căuta în continuare confirmarea diagnosticului, prin aplicarea altor teste

11. Probabilitatea unui test pozitiv (PTP) = probabilitatea de a obţine un test pozitiv (adevărat şi fals pozitiv)

12. Probabilitatea unui test negativ (PTN) = probabilitatea de a obţine un test negativ (adevărat şi fals negativ)

13. Acurateţea testului diagnostic (A) = proporţia de rezultate pozitive şi negative care sunt în concordanţă cu diagnosticul final raportat la totalul rezultatelor

14. Probabilitatea unui test pozitiv greşit (PTPG) = probabilitatea de a obţine un test fals pozitiv raportă la totalul testelor pozitive

15. Probabilitatea unui test negativ greşit (PTNG) = probabilitatea de a obţine un test negativ greşit raportat la totalul testelor negative

16. Diferenţa de proporţii = diferenţa dintre raportul dintre probabilitatea patologiei de interes în grupul celor testaţi raportat la totalul celor testaţi şi probabilitatea patologiei de interes în grupul celor netestaţi raportat la totalul pacienţilor netestaţi.

16. Riscul relativ = măsoară forţa asocierii dintre patologia de interes şi un rezultat pozitiv al testului diagnostic

Interpretare! Cu cât valoarea riscului relativ este mai mare cu atât asocierea dintre testul diagnostic şi patologia de interes este mai puternică;

RR = 1: nu există legătură dintre expunerea la testul diagnostic şi patologia de interes;

RR < 1: asociere negativă;

Studii de cohortă: RR = 3: interes;

Studii caz-martor: RR = 4: interes.

17. Rata şansei = şansa unui test real pozitiv în grupul celor cu test pozitiv raportat la şansa unui rezultat fals negativ în grupul celor cu test negativ

Interpretare! Cu cât rata şansei este mai mare cu atât riscul patologiei de interes în grupul celor cu test este mai mare.

RS ~ 1: nu există nici o legătură dintre rezultatul testului diagnostic şi patologia de interes;

RS < 1: asociere inversă între rezultatul testului diagnostic şi patologia de interes.

Ca şi în cazul studiilor terapeutice şi aici valoarea punctuală a fiecărui indicator medical este însoţită de intervalul de confidenţă 95% asociat. Denumirea indicatorului medical, denumirea acestuia folosită în program, denumirea funcţiei de calcul a intervalului de confidenţă şi referinţa către lucrarea care prezintă performanţele metodei de calcul a intervalului de confidenţă sunt prezentate în tabelul 5.

Tabelul 5. Denumirea indicatorului medical, a funcţiei de calcul a intervalului de confidenţă şi

referinţa carte lucrarea care prezintă performanţele metodei de calcul pentru studiile diagnostice

Nr. | Parametrul medical (abreviere) | Denumire folosită în program | Denumire funcţie interval de confidenţă | Ref.
1 | Diferenţa de proporţii (DifProp) | ExcesRisc | DAC | [17]
2 | Rata falşilor pozitivi (RFP) | RataFalsiPozitivi | Binomial | 11
3 | Rata falşilor negativi (RFN) | RataFalsiNegativi | Binomial | 11
4 | Raţia de probabilitate negativă (RPN) | RatieProbabilitateNegativa | RPAC2 | 15
5 | Valoarea predictivă negativă (VPN) | ValoarePredictivaNegativa | Binomial | 11
6 | Rata şansei (RS) | RataSansei | R2AC | [18]
7 | Acurateţea testului diagnostic (A) | Acuratete | Binomial | 11
8 | Raţia de probabilitate pozitivă (RPP) | RatieProbabilitatePozitiva | RPAC2 | 15
9 | Valoarea predictivă pozitivă (VPP) | ValoarePredictivaPozitiva | Binomial | 11
10 | Şansa post-test (SPostT) | SansaPostTest | Binomial | 11
11 | Probabilitatea post-test (PPT) | ProbabilitatePostTest | Binomial | 11
12 | Şansa pre-test (SPT) | SansaPreTest | Binomial | 11
13 | Prevalenţa (p) | Prevalenta | Binomial | 11
14 | Probabilitatea unui test negativ (PTN) | ProbabilitateTestNegativ | Binomial | 11
15 | Probabilitatea unui test negativ greşit (PTNG) | TestNegativGresit | Binomial | 11
16 | Probabilitatea unui test pozitiv (PTP) | ProbabilitateTestPozitiv | Binomial | 11
17 | Probabilitatea unui test pozitiv greşit (PTPG) | TestPozitivGresit | Binomial | 11
18 | Riscul relativ (RR) | RiscRelativ | RPAC2 | 15
19 | Sensibilitate (Se) | Sensibilitate | Binomial | 11
20 | Specificitate (Sp) | Specificitate | Binomial | 11

Evaluare studii de prognostic

Evaluarea validităţii. Evaluarea validităţii unui studiu de etiologie sau prognostic se face prin verificarea metodologiei studiului care stă la baza evidenţei. Metodologia sistemul informatic impune răspunsul închis (selectarea unei singure opţiuni din listă) sau deschis (răspuns liber) la următoarele întrebări:

1. Care a fost modalitatea de culegere a datelor (Eşantion reprezentativ, Expus-nonexpus, Caz-martor);

2. Eşantionul de studiu a fost omogen? (Da, Nu, Nu ştiu);

3. Urmărirea pacienţilor a fost completă? (Da, Nu, Nu ştiu);

4. Aprecierea rezultatelor a fost realizată după un criteriu obiectiv? (Da, Nu, Nu ştiu);

5. Au fost ajustaţi alţi factori de risc/prognostici posibili? (Da, Nu, Nu ştiu);

6. Dacă au existat subgrupe de factori de risc/prognostici acestea au fost identificate şi studiate independent?

7. Care a fost numărul de pacienţi incluşi în studiu?

8. Care au fost criteriile de includere în studiu?

9. Care au fost criteriile de excludere din studiu?

10. Care a fost situaţia pacienţilor pierduţi din vedere?

11. Care a fost rezultatul urmărit?

12. Completarea tabelului de contingenţă.

Rezultatele studiului şi evaluarea acestora. Rezultatele evidenţei se introduc în tabelul de contingenţa corespunzător, tabel pe baza căruia se calculează indicatorii medicali. Semnificaţia şi interpretarea indicatorilor medicali calculaţi se face în funcţie de tipul de studiu (observaţional - studii transversale, caz-martor, cohortă - sau experimental) şi metoda de culegere a datelor aşa cum este rezultă din tabelul 6.

Tabelul 6. Tipul de studiu, modalitatea de culegere a datelor, indicatorii medicali pentru studiile de

etiologie sau prognostic

Tip studiu | Eşantionul (metoda de culegere a datelor) | Culegerea datelor | Indicatori medicali
Studiu transversal | Evaluare simultană a expunerii şi efectelor acesteia la nivelul unei populaţii | prezent | Toţi indicatorii
Caz-martor | Două eşantioane, unul cu pacienţi bolnavi şi altul cu pacienţi indemni (caz-martor) | retrospectiv | Rata şansei Frecvenţa factorului de risc în lotul caz Frecvenţa factorului de risc în lotul martor
Cohortă | Două eşantioane unul expus factorului de risc sau prognostic de interes şi altul care nu este expus factorului de risc sau prognostic (expus-non-expus) | prospectiv retrospectiv | Riscul individual al celor expuşi Riscul individual al celor ne-expuşi Riscul atribuabil Riscul relativ Fracţia etiologică a riscului la expuşi

Indicatori punctuali medicali care se pot calcula pe baza tabelului de continenţă sunt:

1. Riscul individual al celor expuşi (RIE) (probabilitatea ca un subiect să fie bolnav dacă este expus factorului de risc) = proporţia de bolnavi din subiecţii expuşi factorului de risc.

2. Riscul individual al celor ne-expuşi (RIN) (probabilitatea ca un subiect să fie bolnav fără să fie expus factorului de risc) = proporţia de bolnavi din totalul subiecţilor ne-expuşi factorului de risc.

3. Riscul atribuabil (RA) (excesul de risc) (măsoară specificitatea legăturii între factorul prognostic şi îmbolnăvire) = partea din riscul absolut care este imputabilă expunerii la factorul de risc studiat.

RA = RIE - RIN

4. Riscul relative (RR) (măsoară forţa asocierii – subiectul expus la factorul studiat are de x ori mai multe şanse de a face boala definită prin criteriul principal de evaluare faţă de subiectul neexpus).

5. Fracţia etiologică a riscului la expuşi (FERE) - măsoară specificitatea legăturii dintre factorul de risc şi patologia luată în studiu.

6. Rata şansei (RS) (riscul de a dezvolta boala în funcţie de expunere) = probabilitate bolii la cei expuşi factorului de risc.

7. Frecvenţa factorului de risc în lotul cazurilor (FRC): proporţia pacienţilor expuşi factorului de risc din totalul celor bolnavi

8. Frecvenţa factorului de risc în lotul martor (FRM): proporţia pacienţilor ne-expuşi factorului de risc din totalul celor indemni de patologia de interes

Ca şi în cazul celorlalte două domenii de cercetare, şi în cazul studiilor de etiologie sau prognostic indicatorii medicali punctuali sunt însoţiţi de intervalul de confidenţă de 95% asociat. Denumirea indicatorului medical, denumirea acestuia folosită în program, denumirea funcţiei de calcul a intervalului de confidenţă şi referinţa către lucrarea care prezintă performanţele metodei de calcul a intervalului de confidenţă sunt prezentate în tabelul 7.

Tabelul 7. Denumirea indicatorului medical, a funcţiei de calcul a intervalului de confidenţă şi

referinţa pentru studiile de etiologie sau prognostic

Nr. | Parametrul medical (abreviere) | Denumire folosită în program | Denumire funcţie interval de confidenţă | Ref.
1 | Risc atribuabil (exces de risc) (RA) | ExcesRisc | DAC | 12
2 | Riscul individual al celor expuşi (RIE) | RiscIndividualExpusi | Binomial | 11
3 | Riscul individual al celor ne-expuşi (RIN) | RiscIndividualNeexpusi | Binomial | 11
4 | Rata şansei (RS) | RataSansei | R2AC | 16
5 | Riscul relativ (RR) | RiscRelativ | RPAC2 | 15
6 | Fracţia etiologică a riscului la expuşi (FERE) | FractiaEtiologicaRiscExpusi | RPAC | 15
7 | Frecvenţa factorului de risc în lotul caz (FRC) | FactorRiscCaz | Binomial | 11
8 | Frecvenţa factorului de risc în lotul martor (FRM) | FactorRiscMartor | Binomial | 11

H. Comentarii

Comentariile pot să fie dirijate către validitatea şi relevanţa articolului pe baza căruia subiectul medial evaluat critic a fost realizat sau să cuprindă concluzii ale persoanei care a creat subiectul.

I. Autorul subiectului medical evaluat critic

J. Data la care subiectul medical de interes evaluat critic a fost creat

Este foarte util să ştim cine şi când a creat subiectul medical de interes evaluat critic deoarece ne permite să evaluăm utilitatea (se ştie că viaţa subiectelor medicale de interes evaluate critic se stinge în momentul în care apare o evidenţă mai bună) acestuia şi respectiv să contactăm persoana care l-a creat în momentul în care avem nelămuriri.

Referinţe

[1] Sackett DL, Straus SE, Richardson S, Rosenberg WMC, Haynes BR. Evidence based medicine: how to practice and teach EBM 2nd ed. Edinburgh, Scotland: Churchill Livingstone, 2000.

[2] Sauve S, Lee HN, Meade MO, Lang JD, Farkouh M, Cook DJ, Sackett DL. The critically appraised topic: a practical approach to learning critical appraisal. Ann Roy Soc Phys Surg Canada 1995,28:396-398.

[3] Phillips B. Towards evidence based medicine for paediatricians. Arch Dis Child 2001;85:252-255.

[4] BestBETS Best Evidence Topics page on the Internet. cited 2004 August 3. Available from: http://bestbets.org/ .

[5] PedsCCM Evidence-Based Journal Club page on the Internet. The Pediatric Critical Care Website Evidence-Based Journal Club; © 1997-2005 cited 2004 August 3. Available from: http://pedsccm.wustl.edu/EBJournal_club.html

[6] Dong P, Wong L L, Ng S, Loh M, Mondry A. Quantitative evaluation of recall and precision of CAT Crawler, a search engine specialized on retrieval of Critically Appraised Topics. BMC Medical Informatics and Decision Making 2004;4:1-7, cited 2005 August 1. Available from: http://www.biomedcentral.com/1472-6947/4/21

[7] Rosenberg W, Anna D. Evidence-based medicine: an approach to clinical problem-solving. British Medical Journal 1995;310:1122-1126.

[8] Antes G, Galandi D, Bouillon B. What is evidence-based medicine? Langenbeck’s Arch Surg 1999;384:409-16.

[9] Pwee KH. What is this thing called EBM? Singapore Med J 2004;45(9):413-417.

[10] Muir Gray JA. Evidence-based HEALTHCARE – How to make Health Policy and Management Decisions. Second edition, Churchill Livingston 2001.

[11] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 2. Proportion-like Medical Parameters. Leonardo Electronic Journal of Practices and Technologies. 2003; 3: 75-110.

[12] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 7. Absolute Risk Reduction and ARR-like Expressions. Leonardo Electronic Journal of Practices and Technologies 2004;5:1-25.

[13] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 8. Number Needed to Treat/Harm. Leonardo Journbal of Sciences 2004;5:1-17.

[14] Bolboacă S. Binomial Distribution Sample Confidence Intervals Estimation 10. Relative Risk Reduction and RRR-like Expressions. Leonardo Electronic Journal of Practices and Technologies 2005;6:60-75.

[15] Bolboacă S, Jäntschi L. Binomial Distribution Sample Confidence Interval Estimation

for Positive and Negative Likelihood Ratio Medical Key Parameters. American Medical Informatics Association Annual Symposium, Washington DC 2005 October 22-26, AMIA Proceeding 2005.

[16] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 5. Odds Ratio. Leonardo Journal of Sciences 2004; 4: 26-43.

[17] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 6. Excess Risk. Leonardo Electronic Journal of Practices and Technologies 2004;4:1-20.

[18] Sorana Bolboaca, Andrei Achimas Cadariu. Binomial Distribution Sample Confidence Intervals Estimation 5. Odds Ratio. Leonardo Journal of Sciences 2004;4:26-43.


Descrierea aplicaţiei CATRom

Aplicaţia CATRom este o aplicaţie originală bazată pe o analiză comprehensivă a literaturii de specialitate în ceea ce priveşte crearea subiectelor medicale de interes evaluate critic.

Aplicaţia este găzduită de domeniul AcademicDirect şi se găseşte la adresa

http://vl.academicdirect.ro/medical_informatics/mesh/cat/

Aplicaţia CATRom se compune din două module principale:

· Asistarea creării subiectelor medicale de interes evaluate critic (modulele 'Crează', 'Şterge' şi 'Parola'): asistă personalul medical calificat (cunoscători ai limbii engleze la nivel avansat, abilităţi în formularea întrebărilor medicale de interes, abilităţi în crearea şi realizarea strategiilor de căutare a celor mai recente evidenţe medicale, abilităţi în evaluarea validităţii şi relevanţei evidenţelor medicale, abilităţi de lucru cu calculatorul) în crearea subiectelor medicale de interes evaluate critic;

· Managementul subiectelor medicale de interes evaluate critic (modulele 'Afişează' şi 'Filtrează'): asistă medicul practician în căutarea, găsirea, afişarea şi tipărirea subiectelor medicale de interes evaluate critic.

Accesul la aplicaţia CATRom se face pe bază de nume de utilizator şi parolă şi se poate obţine prin completarea formularului de înregistrare şi trimiterea acestuia la adresa specificată (butonul 'Înregistrare', figura 2).

Prima fereastră a aplicaţiei (figura 2) prezintă obiectivele aplicaţiei şi permite accesul la CATRom prin logare (butonul 'Start'), înregistrarea ca utilizator nou (butonul 'Înregistrare') şi accesul la ajutor (butonul 'Ajutor').

Figura 2. Fereastra de acces a aplicaţiei CATRom

Utilizatorul nou va trebui să completeze formularul de înregistrare cu datele personale şi să-l trimită managerului bazei de date. Acesta creează pe baza datelor din formular un cont pentru fiecare utilizator, numele de utilizator pentru acest cont fiind reprezentat de prenumele şi numele medicului. S-a ales această variantă pentru numele utilizatorului deoarece aplicaţia înregistrează automat numele autorului subiectului medical de interes când acesta este creat. Parola fiecărui utilizator este înregistrată în baza de date codat.

Accesul la aplicaţia CATRom se face după alegerea numelui şi prenumelui utilizatorului din lista de utilizatori şi introducerea parolei (figura 3), confirmate prin clic pe butonul 'Acces'.

Figura 3. Fereastra de logare

Odată deschisă aplicaţia CATRom, meniul acesteia permite crearea unui nou subiect medical de interes evaluat critic ('Crează'), căutarea ('Afişează'), filtrarea ('Filtrează'), ştergerea ('Şterge') şi schimbarea parolei ('Parola') utilizatorului.

La prima utilizare a aplicaţiei utilizatorul are obligaţia să-şi schimbe parola de utilizator pentru a asigura protecţia datelor (opţiunea 'Parola'). Programul afişează automat numele şi prenumele utilizatorului care va trebui să introducă în căsuţă destinată parola veche şi respectiv parola nouă (figura 4). Are loc verificarea corespondenţei dintre parola veche a utilizatorului înregistrată în baza de date şi cea introdusă de către utilizator. În cazul în care informaţia este concordantă are loc schimbarea parolei şi afişarea mesajului 'Parola s-a schimbat!'. Dacă informaţia este discordantă mesajul afişat va fi 'Parola veche incorectă!'. În ambele cazuri aplicaţia reîntoarce utilizatorul la pagina de logare.

Figura 4. Fereastra de schimbare a parolei utilizatorului

Alegerea opţiunii de creare a unui subiect medical de interes evaluat critic va afişa automat în prima fereastră data creării (an, lună, zi) şi autorul acesteia (figura 5). Data de creare este preluată din datele serverului de date iar autorul este implicit utilizatorul care s-a logat la aplicaţie. Specificarea domeniului subiectului medical de interes (Tratament/Terapie, Diagnostic, Etiologie/Prognostic) se face prin alegerea acestuia dintr-o listă. Primă fereastră a creării subiectelor medicale de interes evaluate critic este comună tuturor domeniilor şi cuprinde informaţiile din capitolele A – D ale schemei metodologice. Toate informaţiile din această fereastră sunt obligatorii şi sunt incluse în următoarea fereastră; odată apăsat butonul 'Continuă' nu se mai pot modifica.

Figura 5. Fereastra comună domeniilor subiectelor medicale de interes evaluate critic

În funcţie de domeniul ales, următoarea fereastră a aplicaţiei CATRom este diferită şi este construită conforma capitolelor E – H ale schemei metodologice (figura 6, 7 şi 8).

Figura 6. Interfaţa de creare pentru domeniul Tratament/Terapie

Figura 7. Interfaţa de creare pentru domeniul Diagnostic

Figura 8. Interfaţa de creare pentru domeniul Etiologie/Prognostic

Indiferent de domeniul subiectului medical, informaţiile completate în prima fereastră sunt afişate dar nu pot fi modificate.

Aplicaţia are predefinite câmpuri obligatorii şi nu permite salvarea unui nou subiect medical de interes evaluat critic care nu are introduse date în aceste câmpuri (vezi descrierea metodologiei). Dacă lipsesc datele din câmpuri predefinite aplicaţia afişează o fereastră de avertizare specificând câmpul care trebuie completat (figura 9).

Figura 9. Fereastra de avertizare a unui câmp obligatoriu necompletat

Odată ce toate datele au fost introduse şi nu au rămas câmpuri obligatorii necompletate, prin clic pe butonul 'Finalizeaza' se va deschide o fereastră cu toate datele introduse de autor în formulare. În acest moment ni se permite modificarea doar a datele corespunzătoare capitolelor E– H din schema metodologică. Înregistrarea datelor în baza de date este însoţită de un mesaj scris ('Datele au fost salvate!'). Aplicaţia nu permite salvarea de două ori a aceluiaşi subiect medical de interes evaluat critic iar când se încearcă o a doua salvare următorul mesaj apare pe monitorul calculatorului 'Au fost deja introduse datele.'. Dacă datele nu au fost salvate, aplicaţia dă un mesaj de eroare 'Eroare de salvare date.'

Căutarea subiectelor medicale de interes evaluate critic este facilă şi se realizează foarte uşor. Opţiunea 'Afişează' va interoga baza de date şi va afişa identificatorul unic ('id'), data creării ('data'), domeniul ('tip'), autorul ('autor') şi titlul ('titlu') tuturor subiectele medicale de interes evaluate critic existente în baza de date (figura 10). Navigarea în pagini este posibilă prin clic de mouse pe opţiunea 'Anterioarele' sau 'Următoarele'. Sortarea subiectelor se poate face pentru oricare din criteriile din capul de tabel ('id', 'data', 'tip', 'autor', 'titlu'). Odată selectat criteriul de sortare datele vor fi sortate ascendent după criteriul ales. Sortarea se poate face şi după oricare din criteriile tabelului afişat. De exemplu dacă dorim să vedem doar subiectele medicale de interes create de un anumit autor, la clic de mouse pe numele autorului dorit se vor afişa doar subiectele create de acesta.

Figura 10. Fereastra de căutare

Fereastra de filtrare (opţiunea 'Filtrează') spre deosebire de cea precedentă nu permite sortarea subiectelor medicale de interes evaluate critic ci numai selectarea subiectului de interes pentru vizualizare (figura 11). Subiectele medicale de interes evaluate critic sunt afişate conform aceloraşi caracteristici ca şi căutarea (numărul de înregistrare în baza de date, data la care subiectul a fost creat, autorul şi titlul). Vizualizarea subiectului se realizează prin selectarea numărului ('id') subiectului de interes.

Figura 11. Fereastra de filtrare

Subiectul medical de interes evaluat critic ales va fi afişat pe ecranul calculatorului şi va cuprinde toate datele introduse de autor şi în plus de acestea va mai cuprinde toţi indicatorii medicali care se pot calcula pe baza tabelului de contingenţă, fiecare indicator fiind însoţit de intervalul de confidenţă corespunzător după modelul:

Subiectul medical de interes evaluat critic poate să fie citit de pe ecranul calculatorului, poate fi salvat pentru a putea fi citit pe un alt calculator care nu are conexiune la Internet (File – Save As...) sau poate fi tipărit (File - Print). O imagine a unui exemplu de subiect medical de interes evaluat critic este prezentată în figura 12 prin folosirea opţiunii Print Preview... din meniul File al Internet Explorer-ului.

Figura 12. Imagine de Print Preview a unui subiect medical de interes evaluat critic

Calitatea subiectelor medicale de interes evaluate critic depinde doar de abilităţile persoanei care a creat subiectul. Dar cu cunoştinţe de bază de metodologie a cercetării medicale şi biostatistică medicală, CATRom devine un instrument util orientat către pacient în activitatea medicală de zi cu zi.

Aplicaţia CATRom folosită judicios şi în cunoştinţă de cauză dă posibilitatea practicienilor Români să aibă acces la informaţii şi cunoştinţe medicale recente şi prin folosirea acestor cunoştinţe în deciziile medicale de zi cu zi va determina ridicarea standardelor îngrijirilor medicale la cele impuse de Uniunea Europeană.


Evaluarea evidenţelor şi intervale de confidenţă

Estimarea punctuală a unui parametru teoretic furnizează o valoare pentru parametrul teoretic estimat. Această valoare este tributară fluctuaţiilor de eşantionare şi poate fi la o mare distanţă de valoarea reală a parametrului estimat. Astfel că este recomandabil să se estimeze un parametru teoretic nu printr-o singură valoare ci printr-un interval, numit interval de confidenţă, în care să se poată afirma că parametrul estimat se găseşte cu o probabilitate ridicată.

Definiţia intervalului de confidenţă: ″un şir de valori pentru o variabilă de interes calculat în aşa fel încât pentru o probabilitate de eroare aleasă să includă valorile adevărate ale variabilei″. Intervalul de confidenţă conţine valori ale variabilei studiate care sunt compatibile cu datele studiate. Dacă intervalul de încredere pentru diferenţa dintre o medie observată şi una teoretică cuprinde valoarea 0, datele sunt compatibile cu o diferenţă a mediei populaţiei egală cu 0. Dacă diferenţa este egală cu 0 atunci media populaţiei este egală cu zero. Dacă intervalul de încredere pentru diferenţa dintre o medie observată şi una teoretică nu cuprinde valoarea 0, datele nu sunt compatibile cu egalitatea mediilor populaţiei.

Intervalul de confidenţă se calculează în funcţie de: talia eşantionului sau a populaţiei şi variabila de studiat (cantitative sau calitative).


Studiul intervalelor de încredere pentru indicatorii medicali

Distribuţia datelor medicale

În general distribuţiile variabilelor folosite în studiile medicale definite pe o populaţie, nu se cunosc. Din punct de vedere practic se încearcă încadrarea acestor distribuţii în unele legi teoretice care constituie modele pentru aceste variabile statistice. Astfel pentru cazul variabilelor aleatoare continue principala lege de probabilitate este legea normală sau legea Laplace - Gauss. Pentru variabilele aleatoare discrete se foloseşte legea Binomială pentru cazul variabilelor aleatoare finite sau legea Poisson pentru cazul variabilelor aleatoare discrete infinite.

Distribuţia normală

Această lege de probabilitate a cărei funcţie de probabilitate are o alură tipică de clopot numită curba lui Gauss este un model pentru variabile aleatoare continue şi depinde de medie (M(X)) şi de variaţie (Var(X)). Densitatea de probabilitate este:

Dacă X satisface o lege normală de medie M(X) şi variaţia Var(X) atunci se spune că X este de tipul N(M(X), Var(X)).

Distribuţia Binomială sau distribuţia lui Bernoulli

Modelul distribuţiei binomiale este un experiment este alcătuit din repetarea unei încercări elementare de n ori, n fiind un număr natural dat, rezultatele posibile ale fiecărei încercări elementare sunt doar două evenimente numite de obicei: succes (S) şi eşec (E), probabilităţile p de succes şi q = 1 - p de eşec sunt constante de la o încercare la alta şi cele n încercări repetate sunt independente una de cealaltă.

Numărul de succese obţinute din cele n încercări repetate este o variabilă aleatoare de tip binomial care depinde de parametrii n şi p şi este de obicei notată prin Bin(n,p). Această variabilă aleatoare X poate să ia valorile 0, 1, 2, ..., n şi are următoarea lege de distribuţie:

X: adică Pr( X = k ) = [image].

Se poate arăta uşor că pentru variabila binomială X:

· media M(X) = n·p

· dispersia sau variaţia Var2(X) = n·p·q

· deviaţia standard Var(X) =

Comparaţia distribuţiei binomiale cu aproximaţia sa la normalitate

Considerând o variabilă ce urmează o distribuţie binomială dintr-o mulţime de n cazuri, pentru care valoarea cunoscută a mediei este X (0 ≤ X ≤ n), probabilitatea de apariţie a valorilor Y (0 ≤ Y ≤ n) este dată de relaţia:

Se poate demonstra că valoarea mediei şi dispersiei pentru distribuţia binomială sunt date de relaţiile:

,

Probabilitatea de apariţie a valorilor Y (0 ≤ Y ≤ n) pentru o variabilă ce urmează o distribuţie normală de medie M(n,X) şi varianţă Var(n,X) este dată de relaţia:

Aproximaţia de normalitate a unei variabile ce urmează o distribuţie binomială foloseşte valoarea mediei şi a dispersiei variabilei ce urmează distribuţia binomială [1]. Înlocuind valorile mediei şi dispersiei din formulele pentru distribuţia binomială, pentru 0 < X < n se obţine:

Eroarea de aproximare a distribuţiei binomiale a variabilei Y (0 ≤ Y ≤ n) cu distribuţia normală a sa de aceeaşi medie şi dispersie se poate exprima prin diferenţa probabilităţilor de apariţie:

Ţinând seama că valorile probabilităţilor de apariţie ale lui Y scad foarte rapid cu depărtarea de valoarea aşteptată X, pentru a pune mai clar în evidenţă această abatere în cazurile reale, se poate ajusta această expresie la 0 pentru valorile probabilităţii PB(n,X,Y) mai mici decât 1/n, adică pentru acele cazuri pentru care oricum diferenţa nu ar fi detectată de extragerea unei valori diferite din eşantionul binomial.

Pentru a pune în evidenţă această eroare de aproximare, au fost reprezentate graficele următoare (figura 3, 4), pentru diferiţi n şi X:

Figura 3. Eroarea de aproximare a distribuţiei binomiale cu o distribuţie normală

în estimarea erorilor fracţiei X/n = 1/2 exprimată prin intermediul funcţiei Errc(n,n/2,Y)

pentru n = 10, n = 30, n = 100 şi n = 300

Figura 4. Eroarea de aproximare a distribuţiei binomiale cu o distribuţie normală

în estimarea erorilor fracţiei X/n = 1/10 exprimată prin intermediul funcţiei Errc(n,n/10,Y)

pentru n = 10, n = 30, n = 100 şi n = 300

Discuţie

Estimarea erorilor fracţiei 5/10 (X = 5, n = 10) prin aproximaţia normalităţii induce o subestimare a apariţiilor lui X = 3 şi X = 7 în sumă de 7.8‰ şi o supraestimare a apariţiilor lui X = 4, X = 5 şi X = 6 în sumă de 8.3‰ care faţă de pragul de eroare acceptat α = 5% reprezintă mai puţin de 10%. Totuşi, variaţia erorii arată că aproximaţia normalităţii induce o micşorare a intervalului de confidenţă a proporţiei, fiind considerate mai frecvente apariţiile vecinilor lui 5 decât extremelor probabile.

Reprezentând grafic variaţia sumei erorilor de estimare pozitive (pentru apariţiile valorilor depărtate de valoarea măsurată) şi variaţia sumei erorilor de estimare negative (pentru apariţiile valorilor apropiate de valoarea măsurată) în scară logaritmică atât pentru n cât şi pentru sume, se obţine graficul de mai jos (figura 5):

Figura 5. Variaţia logaritmului sumei erorilor de estimare

pozitive (log(sp)) şi negative (log(sm)) în funcţie de log(n) pentru fracţia X/n = 1/2

Din grafic se observă că variaţia sumei erorilor este aproape liniară şi invers proporţională cu n. De aici rezultă că, pentru proporţia X/n = 1/2 şi în general pentru proporţiile medii, aproximaţia normalităţii funcţionează relativ bine şi calitatea creşte odată cu n. Mai mult, în vecinătatea lui 1/2 ipoteza simetriei intervalului de confidenţă indusă de aproximaţia normalităţii funcţionează bine, fapt care se poate dovedi prin calcularea sumelor erorilor de calcul în estimarea probabilităţilor pentru valorile mai mici şi respectiv mai mari decât X, sau pur şi simplu observând simetria graficelor pentru estimarea erorilor fracţiei X/n = 1/2 faţă de n/2.

Urmărind acum variaţia erorilor pozitive indusă de aproximaţia normalităţii pentru fracţiile de forma X/n = 1/10 în funcţie de n, se remarcă că abscisa punctului de maxim al abaterii faţă de distribuţia binomială se regăseşte la n mic în vecinătatea valorilor extreme (pentru n = 10, X = 1, eroarea atinge valoarea maximă de 0.108 la 0) şi se deplasează către valoarea lui X cu creşterea lui n (pentru n = 300, X = 30, eroarea atinge valoarea maximă de 0.0283 la 25). Pentru variaţia erorilor negative indusă de aproximaţia normalităţii pentru fracţiile de forma X/n = 1/10 în funcţie de n, se remarcă că abscisa punctului de maxim al abaterii faţă de distribuţia binomială se regăseşte la n mic în vecinătatea valorilor extreme (pentru n = 10, X = 3, eroarea atinge valoarea maximă de 0.05 la 0) şi se deplasează către valoarea lui X cu creşterea lui n (pentru n = 300, X = 30, eroarea atinge valoarea maximă de 0.0260 la 34).

Figura 6. Variaţia logaritmului sumei erorilor de estimare

pentru valori mai mici decât X (log(si)) şi mai mari decât X (log(ss))

în funcţie de log(n) pentru fracţia X/n = 1/10

Mai mult, eroarea de aproximare faţă de X este asimetrică, şi nu tinde spre o simetrie pentru n mare (figura 6).

Din figura 6, deoarece sumele erorilor pentru valori mai mici decât X sunt totdeauna mai mari decât sumele erorilor pentru valori mai mari decât X totdeauna intervalul de confidenţă obţinut din aproximaţia normalităţii va fi deplasat spre dreapta (se produc mai multe erori de aproximare în partea stângă).

Eroarea are o valoare maximă de 10.8% pentru n = 10 şi X = 1 în punctul 0, valoare care este de 2 ori mai mare decât pragul de eroare acceptat α = 5% (!), o valoare maximă de 2.6% de 2 ori consecutiv pentru n = 30, X = 3 în punctele 1 şi 2 şi o valoare de 2.5% în punctul 4, adică jumătate din pragul de eroare acceptat α = 5% (!), ceea ce reprezintă o abatere serioasă. Pentru n mare suma erorilor de aproximare tinde spre liniaritate invers proporţională cu n.

Figura 7. Eroarea de aproximare a distribuţiei binomiale cu o distribuţie normală în estimarea erorilor fracţiei X/n = 1/n

exprimată prin intermediul funcţiei Errc(n,1,Y) pentru n = 10, n = 30, n = 100 şi n = 300

Figura 8. Variaţia sumei erorilor de estimare pentru fracţia X/n = 1/n

Ultimul caz, cel al proporţiilor foarte mici (X/n = 1/n) relevă (vezi figurile 7 şi 8) că suma erorilor de aproximare este deja crescătoare cu n şi pentru n > 50 depăşeşte totdeauna valoarea pragului de eroare acceptat α = 5% (!), ceea ce înseamnă că pragul real de eroare folosind ipoteza normalităţii totdeauna va depăşi 10%, eroarea fiind făcută în favoarea valorilor mai mari ale lui X.

Implementarea calcului matematic în MathCad

Calculul ecuaţiilor din secţiunea anterioară a fost efectuat cu ajutorul programului MathCad, iar apoi graficele au fost obţinute prin exportarea datelor în Excel.

Au fost implementate în MathCad următoarele funcţii (în ordinea în care acestea au fost definite pe foaia de calcul MathCad):

Calculul combinărilor de n elemente luate câte k: a necesitat o formulă logaritmică întrucât s-a lucrat cu numere mari şi pentru n = 300 nu s-a putut calcula această valoare folosind formula clasică C(n,k) = n!/((n-k)!k!)

· Calculul probabilităţii apariţiei lui Y/n în distribuţia binomială de volum n şi proporţie X/n:

· Calculul probabilităţii apariţiei lui Y/n în distribuţia normală de volum n, medie X/n şi varianţă X(n-X)/n:

· Calculul diferenţei celor două distribuţii de probabilitate:

· Iniţializări (necesare pentru definirea şirurilor de valori):

n := 30 X :=3 (valori care au fost schimbate consecutiv cu 10,1; 10,5; 30,1; 30,3; 30,15; 100,1; 100,10; 100,50; 300,1; 300,30; 300,150)

Y :=0, 1..n

· Calculul şirului de valori ale diferenţei corectate (reprezentat în fig. 3, 4, 7):

· Construirea şirului de sume pozitive ale diferenţei probabilităţilor până la X (reprezentat în fig. 5):

i :=1, 2..X

spdBNc0 :=if(dBNc0 > 0, dBNc0,0)

spdBNc1 :=spdBNci-1 + if(dBNc1 > 0, dBNci,0)

sndBNc0 :=if(dBNc0 < 0, dBNc0,0)

sndBNc1 :=sndBNci-1 + if(dBNc1 < 0, dBNci,0)

· Construirea şirului de sume ale diferenţei probabilităţilor pentru termenii mai mici decât X/n şi respectiv mai mari decât X/n (reprezentat în fig. 6):

i :=1, 2..X – 1 j :=n-1, n-2..X-1

si0 :=dBNc0 ssn :=dBNcn

sii :=sii-1 + dBNci ssj :=ssj+1 + dBNcj

six-1 = six+1 = - afişează valorile sumelor pentru fiecare pereche de date

· Calculul sumei diferenţelor probabilităţilor pentru toţi termenii:

afişează valoarea sumei pentru fiecare pereche de date

S-a folosit şi o componentă de tip File Read/Write pentru exportarea datelor într-un fişier text care apoi a fost importat în Excel unde s-au realizat graficele 3, 4 şi 7, componentă care a fost legată de şirul dBNCY.

Concepţia şi implementarea funcţiilor de generare a eşantioanelor de distribuţie binomială în limbajul PHP

Funcţiile de generare a eşantioanelor de distribuţie binomială s-au implementat într-un fişier denumit BinomialDistribution.php. S-au implementat pe rând funcţiile pentru calculul combinărilor de n elemente luate câte k (funcţia bino0), calculul probabilităţii binomiale pentru n, X şi Y (funcţiile bino1, bino2 şi bino3), extragerea unui eşantion binomial de volum n_es (funcţia bino4), reaşezarea în tabloul de valori a eşantionului binomial începând cu poziţia 0 şi până la penultimul element al şirului, şi memorarea în ultimul element al şirului a deplasării prin reaşezare (funcţia bino5, folosită pentru optimizarea vitezei de calcul).

Aceste funcţii au fost folosite ca sursă de numere ce urmează distribuţia binomială pentru evaluarea metodelor de calcul a intervalului de confidenţă în secţiunile următoare:

function bino0($n,$k){ $rz = 1;

if($k<$n-$k) $k=$n-$k;

for ($j=1;$j<=$n-$k;$j++)

$rz *= ($k+$j)/$j;

return $rz; }

function bino1($n,$y,$x){ return pow($x/$n,$y)*pow(1-$x/$n,$n-$y)*bino0($n,$y); }

function bino2($n,$y,$x){

if(!$x) if($y) return 0; else return 1;

$nx=$n-$x; $ny=$n-$y;

if(!$nx) if($ny) return 0; else return 1;

$ret=0;

if($y){

$ret += log($x)*$y;

if($ny){

$ret += log($nx)*$ny;

if($ny>$y) $y=$ny;

for($k=$y+1;$k<=$n;$ret+=log($k++));

for($k=2;$k<=$n-$y;$ret-=log($k++));

}

} else $ret += log($nx)*$ny;

return exp($ret-log($n)*$n); }

function bino3($n,$y,$x){

if(!$x) if($y) return 0; else return 1;

$x/=$n; $nx=1-$x; $ny=$n-$y;

if(!$nx) if($ny) return 0; else return 1;

$ret=0;

if($y){

$ret += log($x)*$y;

if($ny){

$ret += log($nx)*$ny;

if($ny>$y) $y=$ny;

for($k=$y+1;$k<=$n;$ret+=log($k++));

for($k=2;$k<=$n-$y;$ret-=log($k++));

}

} else $ret += log($nx)*$ny;

return exp($ret); }

function bino4($n,$k,$n_es){

for($j=0;$j<=$n;$j++){

if($j>15) $c$j=bino1($n,$j,$k); else $c$j=bino3($n,$j,$k);

$c$j=round($c$j*$n_es);

if(!$c$j)unset($c$j);

}

return $c; }

function bino5($N,$k,$f_N){

$d=bino4($N,$k,$f_N);

$j=0;

foreach($d as $v) $r$j++=$v;

foreach($d as $i => $v) break;

$rcount($r)=$i;

return $r; }

Calculele fiind laborioase (aşa cum se va vedea în secţiunile următoare) o problemă esenţială a constituit-o optimizarea vitezei de calcul. În ceea ce priveşte funcţiile de calcul a probabilităţii binomiale bino1, bino2 şi bino3, s-a studiat comparativ viteza de calcul a acestora.

Pentru aceasta s-a implementat un modul de colectare şi afişare a timpilor de execuţie, care foloseşte ceasul sistem al maşinii de calcul:

$af="N\tBino1\tBino2\tBino3\r\n";

for($n=$st;$n<$st+1;$n++){

$t1=microtime(TRUE);

for($x=0;$x<=$n;$x++)

for($y=0;$y<=$n;$y++)

$b=bino1($n,$y,$x);

$t2=microtime(TRUE);

for($x=0;$x<=$n;$x++)

for($y=0;$y<=$n;$y++)

$b=bino2($n,$y,$x);

$t3=microtime(TRUE);

for($x=0;$x<=$n;$x++)

for($y=0;$y<=$n;$y++)

$b=bino3($n,$y,$x);

$t4=microtime(TRUE);

$af.=$n."\t";

$af.=sprintf("%5.3f",log((10000*($t2-$t1))))."\t";

$af.=sprintf("%5.3f",log((10000*($t3-$t2))))."\t";

$af.=sprintf("%5.3f",log((10000*($t4-$t3))))."\r\n";

}

echo($af);

Rezultatele obţinute pentru execuţia modulului pentru valorile lui n: 3, 10, 30, 50, 100, 150, şi 300 exprimate prin logaritmul timpului de execuţie (exprimat în sutimi de secundă) sunt redate în tabelul 11.

Tabelul 11. Logaritmii timpilor de execuţie experimentali (exprimaţi în sutimi de secundă)

pentru fiecare metodă de calcul a probabilităţii binomiale implementată

n | Bino1 | Bino2 | Bino3
3 | 1.92 | 1.573 | 1.406
10 | 3.975 | 4.021 | 3.956
30 | 6.441 | 6.763 | 6.74
50 | 7.731 | 8.149 | 8.137
100 | 9.576 | 10.108 | 10.101
150 | 10.706 | 11.28 | 11.278
300 | 12.691 | 13.314 | 13.314

Figura 9. Rapoarte între timpii de calcul ai probabilităţii binomiale

folosind trei metode (bino1, bino2, bino3)

Exprimând diferenţele între logaritmii timpilor de execuţie ai metodelor bino1 şi bino3 şi respectiv bino2 şi bino3 se obţin rezultatele din figura 9. Urmărind evoluţia raportului timpilor de execuţie ai metodelor bino2 şi bino3 (curba Bino2-Bino3 în figura 9) se observă că optimizarea codului metodei prin folosirea raportului X/n în locul valorii X şi respectiv (n-X)/n în locul valorii (n-X) aduce o creştere de performanţă dar care repede este anulată odată cu creşterea lui n (diferenţa logaritmilor este aproape 0 pentru n > 50).

Raportul timpilor de execuţie ai metodelor bino1 şi bino3 (curba Bino1-Bino3 în figura 9) arată că metoda bino3 devine net superioară metodelor bino1 şi bino2 odată cu creşterea lui n (diferenţa logaritmilor timpilor de execuţie este negativă începând cu n ≈ 15). În conformitate cu această concluzie a fost implementată funcţia bino4 (vezi codul sursă).

Tabela de contingenţă 2´2 şi indicatorii medicali

În studiile medicale, în funcţie de tipul de studiu efectuat (descrierea unui fenomen de sănătate, evaluarea unui procedeu diagnostic, punerea în evidenţă a unor factori de risc sau prognostic, evaluarea unei atitudini terapeutice) şi respectiv de tipul de culegere a datelor (eşantion reprezentativ, expus-nonexpus, caz-martor), construind un tabel de contingenţă de 2×2 (tabelul 12) se pot calcula o serie de indicatori care ne dau relaţii cu privire la rezultatele obţinute în urma studiului.

Tabelul 12. Tabela de contingenţă 2´2

 |  | Rezultat/Patologie
 |  | Pozitiv | Negativ | Total
Tratament / Factor de risc / Diagnostic | Pozitiv | a | b | a+b
 | Negativ | c | d | c+d
 | Total | a+c | b+d | a+b+c+d

Indicatorii folosiţi în studiile medicale, se pot clasifica acum în funcţie de tipul de funcţie matematică pe care aceştia o folosesc în raport cu variabilele. Formulele matematice ale indicilor, împreună cu denumirile pe care aceştia le au în studiile medicale sunt prezentaţi în tabelul 13.

În tabelul de mai jos indicatorii medicali au fost exprimaţi în funcţie de formula matematică de bază. Am alea această fromă de exprimare a indicatorilor medicali pentru a simplifica discuţia intervalelor de confidenţă ale fiecărui indicator. Odată reduşi la formule matematice, indicatorii care se pot calcula pe baza tabelului de contingenţă 2×2 au fost transpuşi şi implementaţi în limbajul PHP.

Tabelul 13. Indicatorii medicali după funcţiile matematice corespunzătoare

Nr. | Funcţie | Indicator | Denumire |  | Tip studiu
1 |  |  | Şansa post test | Post Test Odds | Evaluarea unui procedeu diagnostic [2], [3], [4], [5]
 |  |  | Şansa pre-test | Pre Test Odds | Evaluarea unui procedeu diagnostic [3], [6], [6]
2 |  |  | Probabilitatea post test | Post Test Probability | Evaluarea unui procedeu diagnostic [3], [4], [6]
3 |  |  | Rata şansei | Odds ratio | Punerea în evidenţă a unor factori de risc sau prognostici [7], [8], [9]
4 |  |  | Riscul relativ | Relative Risk | Punerea în evidenţă a unor factori de risc sau prognostici [5], [8], [9]
 |  |  | Raţia de probabilitate pozitivă | Positive Likelihood Ratio | Evaluarea unei atitudini terapeutice [3], [4], [10]
 |  |  | Raţia de probabilitate negativă | Negative Likelihood Ratio
5 |  |  | Excesul de risc | Excess risc | Punerea în evidenţă a unor factori de risc sau prognostici [8]
6 |  |  | Variaţia absolută a riscului | Absolute Risk Variation | Evaluarea unei atitudini terapeutice [3], [11]
7 |  |  | Numărul necesar a fi tratat / pentru a dăuna | Number Needed to Treat / Harm | Evaluarea unei atitudini terapeutice [3], [12]
8 |  |  | Variaţia relativă a riscului | Relative Risk Variation | Evaluarea unei atitudini terapeutice [3], [13]
 |  |  | Fracţia etiologică a riscului la expuşi |  | Punerea în evidenţă a unor factori de risc sau prognostici [8]

Nr. | Funcţie | Indicator | Denumire |  | Tip studiu
9 |  |  | Rata evenimentului experimental | Experimental Event Rate | Evaluarea unei atitudini terapeutice [3], [13]
 |  |  | Riscul absolut pentru grupul caz | Absolute Risk in Treatment Group
 |  |  | Valoarea predictivă pozitivă | Predictive Pozitive Value | Evaluarea unui procedeu diagnostic [4], [14]
 |  |  | Riscul individual al celor expuşi | Individual Risk on Exposure Group | Punerea în evidenţă a unor factori de risc sau prognostici [8]
 |  |  | Sensibilitate | Sensitivity | Evaluarea unui procedeu diagnostic [4], [15]
 |  |  | p(pos test wrong) | p(pos test wrong) | Evaluarea unui procedeu diagnostic [4], [15]
 |  |  | Rata falşilor pozitivi | False Positive Odds | Evaluarea unui procedeu diagnostic [4], [15]
 |  |  | Rata falşilor negativi | Negative Positive Odds | Evaluarea unui procedeu diagnostic [16]
 |  |  | Rata evenimentului de control | Control Event Rate | Evaluarea unei atitudini terapeutice [3], [14]
 |  |  | Riscul absolut pentru grupul martor | Absolute Risk on Control Group
 |  |  | p(neg test wrong) | p(neg test wrong) | Evaluarea unui procedeu diagnostic [4], [16]
 |  |  | Riscul individual al celor neexpuşi | Individual Risk on NonExposure Group | Punerea în evidenţă a unor factori de risc sau prognostici [3]
 |  |  | Specificitate | Specificity | Evaluarea unui procedeu diagnostic [4], [15]
 |  |  | Valoarea predictivă negativă | Negative Predictive Value | Evaluarea unui procedeu diagnostic [4], [15]
 |  |  | Probabilitatea unui test pozitiv | Probability of a Positive Test | Evaluarea unui procedeu diagnostic [3], [16]
 |  |  | Acurateţea testului diagnostic | Overall Accuracy
 |  |  | Probabilitatea unui test negativ | Probability of a Negative Test | Evaluarea unui procedeu diagnostic [4], [16]
 |  |  | Prevalenţa | Prevalence | Evaluarea unui procedeu diagnostic [3], [16]

Implementarea funcţiilor matematice ale indicatorilor medicali în limbajul PHP

Folosind expresiile de definire ale funcţiilor matematice din tabelul 13 este acum uşor să implementăm câte o funcţie PHP pentru fiecare dintre acestea:

function f0($x1,$x2,$x3,$x4){return $x1/($x1+$x2);} //functia nr. 9

function f1($x1,$x2,$x3,$x4){return $x1/$x2;} //functia nr. 1

function f2($x1,$x2,$x3,$x4){return f0(0,0,$x3,$x4)-f0($x1,$x2,0,0);} //foloseste pe f0

function f3($x1,$x2,$x3,$x4){return f1($x1,$x2,0,0)*$f1(0,0,$x4,$x3);} //foloseste pe f1

function f4($x1,$x2,$x3,$x4){return f1($x1,$x1-$x2,0,0);} //foloseste pe f1

function f5($x1,$x2,$x3,$x4){return f0($x1,$x2,0,0)/f0(0,0,$x3,$x4);} //foloseste pe f0

function f6($x1,$x2,$x3,$x4){return abs(f2($x1,$x2,$x3,$x4));} //foloseste pe f2

function f7($x1,$x2,$x3,$x4){return 1/abs(f2($x1,$x2,$x3,$x4));} //foloseste pe f2

function f8($x1,$x2,$x3,$x4){return abs(f2($x1,$x2,$x3,$x4))/f0(0,0,$x3,$x4);} //foloseste f0,f2

Odată implementate aceste funcţii, ele pot fi folosite pentru a calcula indicatorii medicali. Funcţiile care calculează indicatorii medicali sunt redate mai jos:

· Şansa post test este calculată de funcţia SPostT:

function SPostT($a,$b,$c,$d){ return f1($a,$b,0,0); }

· Şansa pre test este calculată de funcţia SPreT:

function SPreT($a,$b,$c,$d){ return f1($a+$c,$b+$d,0,0); }

· Excesul de risc este calculat de funcţia ExRisc:

function ExRisc($a,$b,$c,$d){ return f2($a,$b,$c,$d); }

· Rata şansei este calculată de funcţia RS:

function RS($a,$b,$c,$d){ return f3($a,$b,$c,$d); }

· Probabilitatea post test este calculată de funcţia PPostT:

function PPostT($a,$b,$c,$d){ return f4($a,$b,$c,$d); }

· Riscul relativ este calculat de funcţia RiscR:

function RiscR($a,$b,$c,$d){ return f5($a,$b,$c,$d); }

· Raţia de probabilitate pozitivă este calculată de funcţia RPp:

function RPp($a,$b,$c,$d){ return f5($a,$c,$b,$d); }

· Raţia de probabilitate negativă este calculată de funcţia RPn:

function RPn($a,$b,$c,$d){ return f5($c,$a,$d,$b); }

· Variaţia absolută a riscului este calculată de funcţia vRiscA:

function vRiscA($a,$b,$c,$d){ return f6($a,$b,$c,$d); }

· Numărul necesar a fi tratat sau a dăuna este calculat de funcţia NNtd:

function NNtd($a,$b,$c,$d){ return f7($a,$b,$c,$d); }

· Variaţia relativă a riscului este calculată de funcţia vRiscR:

function vRiscR($a,$b,$c,$d){ return f8($a,$b,$c,$d); }

· Fracţia etiologică a riscului la expuşi este calculată de funcţia fERiscE:

function fERiscE($a,$b,$c,$d){ return f8($c,$d,$a,$b); }

· Rata evenimentului experimental este calculată de funcţia REE:

function REE($a,$b,$c,$d){ return f0($a,$b,0,0); }

· Riscul absolut pentru grupul caz este calculat de funcţia RAGC:

function RAGC($a,$b,$c,$d){ return f0($a,$b,0,0); }

· Valoarea predictivă pozitivă este calculată de funcţia VPP:

function VPP($a,$b,$c,$d){ return f0($a,$b,0,0); }

· Riscul individual al celor expuşi este calculat de funcţia RIE:

function RIE($a,$b,$c,$d){ return f0($a,$b,0,0); }

· Sensibilitatea este calculată de funcţia Se:

function Se($a,$b,$c,$d){ return f0($a,$c,0,0); }

· Probabilitatea unui test pozitiv greşit este calculată de funcţia PTestPg:

function PTestPg($a,$b,$c,$d){ return f0($b,$a,0,0); }

· Rata falşilor pozitivi este calculată de funcţia RFp:

function RFp($a,$b,$c,$d){ return f0($b,$d,0,0); }

· Rata falşilor negativi este calculată de funcţia RFn:

function RFn($a,$b,$c,$d){ return f0($c,$a,0,0); }

· Rata evenimentului de control este calculată de funcţia REC:

function REC($a,$b,$c,$d){ return f0($c,$d,0,0); }

· Riscul absolut pentru grupul martor este calculat de funcţia RAGM:

function RAGM($a,$b,$c,$d){ return f0($c,$d,0,0); }

· Probabilitatea unui test negativ greşit este calculată de funcţia PTestNg:

function PTestNg($a,$b,$c,$d){ return f0($c,$d,0,0); }

· Riscul individual al celor neexpuşi este calculat de funcţia RIN:

function RIN($a,$b,$c,$d){ return f0($c,$d,0,0); }

· Specificitatea este calculată de funcţia Sp:

function Sp($a,$b,$c,$d){ return f0($d,$b,0,0); }

· Valoarea predictivă negativă este calculată de funcţia VPN:

function VPN($a,$b,$c,$d){ return f0($d,$c,0,0); }

Implementarea calculului intervalului de confidenţă în limbajul PHP

Implementarea intervalelor de confidenţă pentru cele 9 expresii matematice descrise în tabelul 13 a necesitat implementarea unor funcţii elementare PHP. Construcţia acestor funcţii şi expresiile de definire sunt redate în tabelul 14.

Tabelul 14. Funcţii folosite în evaluarea intervalelor de confidenţă

Nr. | Funcţia din tabelul 13 | Funcţia de substituţie | Funcţia PHP | Ipoteze de lucru
1 |  |  | ci1 | x1 = X; x1 + x2 = n
2 |  |  | ci2
3 |  |  | ci3
4 |  |  | ci4 | x1 = X; x1 + x2 = m x3 = Y; x3 + x4 = n
5 |  |  | ci5
6 |  |  | ci6
7 |  |  | ci7
8 |  |  | ci8
9 |  |  | ci9

Funcţiile ci1..ci9 din tabelul 14 au următoarele expresii:

function ci1($X,$n){

return $X/$n;

}

function ci2($X,$n){

if($X==$n) return (float)"INF";

return $X/($n-$X);

}

function ci3($X,$n){

if(2*$X==$n) return (float)"INF";

return $X/(2*$X-$n);

}

function ci4($X,$m,$Y,$n){

if(($X==$m)||($Y==0)) return (float)"INF";

return $X*($n-$Y)/$Y/($m-$X);

}

function ci5($X,$m,$Y,$n){

return $Y/$n-$X/$m;

}

function ci6($X,$m,$Y,$n){

return abs(ci5($X,$m,$Y,$n));

}

function ci7($X,$m,$Y,$n){

$val=ci6($X,$m,$Y,$n);

if(!$val) return (float)"INF";

return 1/$val;

}

function ci8($X,$m,$Y,$n){

if($Y==0) return (float)"INF";

return ci1($X,$m)/ci1($Y,$n);

}

function ci9($X,$m,$Y,$n){

if($Y==0) return (float)"INF";

return abs(1-ci1($X,$m)/ci1($Y,$n));

}

Pentru funcţiile de o singură variabilă (X) verificarea apartenenţei la intervalul de confidenţă se face cu funcţia out_ci_X iar pentru funcţiile de două variabile (X şi Y) de funcţia out_ci_XY:

function out_ci_X(&$cif,$XX,$X,$n,$z,$a,$f,$g){

$ci_v=ci($cif,$g,$X,$n,$z,$a);

if(!is_finite($ci_v1)) return 0;

if(!is_finite($ci_v0)) return 0;

$ci_v=ci($cif,$g,$XX,$n,$z,$a);

if(!is_finite($ci_v1)) return 0;

if(!is_finite($ci_v0)) return 0;

$fx=$f($X,$n);

if(!is_finite($fx)) return 0;

return (($fx<$ci_v0)||($fx>$ci_v1));

}

function out_ci_XY(&$cif,$XX,$X,$YY,$Y,$m,$n,$z,$a,$f){

$ci_v=$cif($XX,$m,$YY,$n,$z,$a);

if(!is_finite($ci_v0)) return 0;

if(!is_finite($ci_v1)) return 0;

$fxy=$f($X,$m,$Y,$n);

if(!is_finite($fxy)) return 0;

return (($fxy<$ci_v0)||($fxy>$ci_v1));

}

Calculul intervalelor de confidenţă, erorilor de estimare, mediilor şi deviaţiilor standard ale mediilor erorilor experiemntale sunt efectuate pentru funcţiile de o variabilă (X) de funcţia est_ci_er iar pentru funcţiile de două variabile (X, Y) de funcţia est_ci2_er:

function est_ci_er($z,$a,$c_i,$g,$f,$ce){

if($ce=="ci") est_X(z,a,$c_i,$f,$g);

if($ce=="er") est_N(z,a,$c_i,$f,$g,1);

if($ce=="me") est_N(z,a,$c_i,$f,$g,2);

if($ce=="va") est_N(z,a,$c_i,$f,$g,3);

if($ce=="mv") est_N(z,a,$c_i,$f,$g,6);

}

function est_ci2_er($z,$a,$c_i,$f,$ce){

if($ce=="ci") est_X2(z,a,$c_i,$f);

if($ce=="er") est_N2(z,a,$c_i,$f);

if($ce=="me") est_MN(z,a,$c_i,$f,2);

if($ce=="va") est_MN(z,a,$c_i,$f,3);

if($ce=="mv") est_MN(z,a,$c_i,$f,6);

}

Funcţia est_X calculează toate intervalele de confidenţă pentru funcţiile de o variabilă (X) în timp ce funcţie est_X2 calculează intervalele de confidenţă pentru funcţiile de două variabile (X, Y):

function est_X($z,$a,$c_i,$f,$g){

echo("N\tX\tf(X)");

for($i=0;$i<count($c_i);$i++){

echo("\t".$c_i$i."L");

echo("\t".$c_i$i."U");

}

for($n=N_min;$n<N_max;$n++){

for($X=0;$X<=$n;$X++){

for($i=0;$i<count($c_i);$i++)

$ci$i = ci($c_i$i,$g,$X,$n,$z,$a);

$fX = $f($X,$n);

echo("\r\n".$n."\t".$X."\t".trim(sprintf("%6.3f",$fX)));

for($k=0;$k<count($c_i);$k++){

echo("\t".trim(sprintf("%6.3f",$ci$k0)));

echo("\t".trim(sprintf("%6.3f",$ci$k1)));

}

}

}

}

function est_X2($z,$a,$c_i,$f){

echo("X\tY\tf(X,Y)");

for($i=0;$i<count($c_i);$i++){

echo("\t".$c_i$i."L");

echo("\t".$c_i$i."U");

}

for($n=N_min;$n<N_max;$n++){

$m = $n;

for($X=0;$X<=$m;$X++){

for($Y=0;$Y<=$n;$Y++){

for($i=0;$i<count($c_i);$i++){

$g = $c_i$i;

$ci$i = $g($X,$m,$Y,$n,$z,$a);

}

$fXY = $f($X,$m,$Y,$n);

echo("\r\n".$X."\t".$Y."\t".trim(sprintf("%6.3f",$fXY)));

for($k=0;$k<count($c_i);$k++){

echo("\t".trim(sprintf("%6.3f",$ci$k0)));

echo("\t".trim(sprintf("%6.3f",$ci$k1)));

}

}

}

}

}

Funcţia est_N calculează erorile de estimare sau mediile şi/sau deviaţiile standard ale acestora pentru funcţiile de o variabilă (X); funcţie est_N2 calculează erorile de estimare pentru funcţiile de două variabile (X, Y):

function est_N($z,$a,&$c_i,$cif,$g,$ce){

if($ce==1)echo("N\tX\tf(x)");else echo("N");

for($i=0;$i<count($c_i);$i++)

echo("\t".$c_i$i);

for($n=N_min;$n<N_max;$n++){

for($X=1;$X<p*$n;$X++){//pt fiecare proportie

$d=bino4($n,$X,10000);

if($ce==1) echo("\r\n".$n."\t".$X."\t".trim(sprintf("%6.3f",$cif($X,$n))));

for($i=0;$i<count($c_i);$i++){//pt fiecare ci

$ttt$X$i=0;//esecuri

$conv=0;

foreach ($d as $XX => $nXX){//pt fiecare valoare posibila de esantion

if(out_ci_X($c_i$i,$XX,$X,$n,$z,$a,$cif,$g)) $ttt$X$i += $nXX;

$conv += $nXX;

}

$ttt$X$i *= 100/$conv;

if($ce==1)echo("\t".trim(sprintf("%3.3f",$ttt$X$i)));

}

}

if ($ce > 1) est_MV($ttt,count($c_i),$n,p,0,$ce,$a);

}

}

function est_N2($z,$a,&$c_i,$f){

echo("X\tY\tf(X,Y)");

for($i=0;$i<count($c_i);$i++)

echo("\t".$c_i$i);

for($n=N_min;$n<N_max;$n++){

$m = $n;

for($X=1;$X<p*$m;$X++){//pt fiecare proportie

$dX=bino4($m,$X,1000);

for($Y=1;$Y<p*$n;$Y++){//pt fiecare proportie

$dY=bino4($n,$Y,1000);

echo("\r\n".$X."\t".$Y."\t".trim(sprintf("%3.3f",$f($X,$m,$Y,$n))));

for($i=0;$i<count($c_i);$i++){//pt fiecare ci

$ttt$X$Y$i=0;//esecuri

$conv=0;

foreach ($dX as $XX => $nXX){//pt fiecare valoare posibila de esantion

foreach ($dY as $YY => $nYY){//pt fiecare valoare posibila de esantion

if(out_ci_XY($c_i$i,$XX,$X,$YY,$Y,$m,$n,$z,$a,$f))

$ttt$X$Y$i += $nXX*$nYY;

$conv += $nXX*$nYY;

}

}

echo("\t".trim(sprintf("%3.3f",100*$ttt$X$Y$i/$conv)));

}

}

}

}

}

Funcţia est_MN calculează mediile şi/sau dispersia erorile de estimare pentru expresiile de două variabile (X, Y):

function est_MN($z,$a,&$c_i,$f,$ce){

echo("M\tN");

for($i=0;$i<count($c_i);$i++)

echo("\t".$c_i$i);

for($m=N_min;$m<N_max;$m++){

for($n=N_min;$n<N_max;$n++){

for($i=0;$i<count($c_i);$i++){//pt fiecare ci

if($ce % 2 == 0) $md$i = 0;

if($ce % 3 == 0) $va$i = 0;

}

for($X=1;$X<p*$m;$X++){//pt fiecare proportie

$dX=bino4($m,$X,10000);

for($Y=1;$Y<p*$n;$Y++){//pt fiecare proportie

$dY=bino4($n,$Y,10000);

for($i=0;$i<count($c_i);$i++){//pt fiecare ci

$ttt$X$Y$i=0;//esecuri

$conv=0;

foreach ($dX as $XX => $nXX){//pt fiecare valoare posibila de esantion

foreach ($dY as $YY => $nYY){//pt fiecare valoare posibila de esantion

if(out_ci_XY($c_i$i,$XX,$X,$YY,$Y,$m,$n,$z,$a,$f))

$ttt$X$Y$i += $nXX*$nYY;

$conv += $nXX*$nYY;

}

}

if($ce % 2 == 0) $md$i += 100*$ttt$X$Y$i/$conv;

if($ce % 3 == 0) $va$i += pow(100*$ttt$X$Y$i/$conv-5,2);

}

}

}

echo("\r\n".$m."\t".$n);

for($i=0;$i<count($c_i);$i++){

if($ce % 2 == 0)

echo("\t".trim(sprintf("%3.3f",$md$i/($m-1)/($n-1))));

if($ce % 3 == 0)

echo("\t".trim(sprintf("%3.3f",sqrt($va$i/(($m-1)*($n-1)-1)))));

}

}

}

}

Funcţia est_MV calculează mediile şi/sau dispersia erorilor de estimare:

function est_MV(&$ttt,$n_c_i,$n,$p,$v,$ce,$a){

for($i=0;$i<$n_c_i;$i++){//pt fiecare ci

$md$i=$v;

if($v)continue;

if($p==0.5){

for($X=1;$X<$p*$n;$X++) $md$i+=2*$ttt$X$i;

if(is_int($p*$n)) $md$i+=$ttt$p*$n$i;

$md$i/=($n-1);

} else {

for($X=1;$X<$p*$n;$X++) $md$i+=$ttt$X$i;

$md$i/=($n-1);

}

}

if($ce % 3 == 0)

for($i=0;$i<$n_c_i;$i++){//pt fiecare ci

$ds$i=0;

if($p==0.5){

for($X=1;$X<$p*$n;$X++){//pt fiecare proportie

$ds$i+=2*pow($ttt$X$i-$md$i,2);

}

if(is_int($p*$n)) $ds$i+=pow($ttt$X$i-100*$a,2);//$md$i,2);

$ds$i/=($n-2);//s

$ds$i=pow($ds$i,0.5);

} else {

for($X=1;$X<$p*$n;$X++){//pt fiecare proportie

$ds$i+=pow($ttt$X$i-100*$a,2);//$md$i,2);

}

$ds$i/=($n-2);//s

$ds$i=pow($ds$i,0.5);

}

}

if($ce % 2 == 0){

echo("\r\n".$n);

for($i=0;$i<$n_c_i;$i++)//pt fiecare ci

echo("\t".trim(sprintf("%3.3f",$md$i)));

}

if($ce % 3 == 0){

echo("\r\n".$n);

for($i=0;$i<$n_c_i;$i++)//pt fiecare ci

echo("\t".trim(sprintf("%3.3f",$ds$i)));

}

}

Funcţia ci folosită în funcţiile est_N, est_N2, est_X şi est_X2 calculează intervalul de confidenţă al funcţiei şi expresiei date ca parametru şi este folosită pentru 9 expresii de funcţii (funcţia I pentru expresia X/n, funcţia R pentru expresia X/(n-X) şi funcţia RD pentru expresia X/(2X-n) pentru cazul de o singură variabilă şi funcţia R2 pentru expresia X(n-Y)/Y/(m-X), funcţia D pentru expresia Y/n-X/m, funcţia AD pentru expresia |Y/n-X/m|, funcţia IAD pentru expresia 1/|Y/n-X/m|, funcţia RP pentru expresia Xn/Y/m şi funcţia ARP pentru expresia |1- Xn/Y/m|) pentru cazul bidimensional. Formulele corespunzătoare funcţiilor descrise anterior sunt redate în cele ce urmează diferenţiat pentru cazul unidimensional (f(X)) şi respectiv bidimensional (f(X,Y)).

Formulele corespunzătoare calculării intervalului de confidenţă al funcţiilor de o singură variabilă (X) sunt date de următoarele expresii, în care CIL(X) şi respectiv CIU(X) reprezintă capetele intervalului de confidenţă pentru proporţia X/n, calculate printr-o metodă oarecare din cele expuse:

· ci1 prezintă următoarea formulă de calcul a intervalului de confidenţă:

şi lasă neschimbate valorile calculate ale capetelor intervalului de confidenţă pentru proporţia X/n iar implementarea formulei de calcul în PHP este:

function I($f,$X,$n,$z,$a){

return $f($X,$n,$z,$a);}

· ci2 prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function R($f,$X,$n,$z,$a){

$L = $f($X,$n,$z,$a);

if ($L1)

if ($L1-1) $Xs = 1/(1/$L1-1); else $Xs = (float) "INF";

else $Xs = 0;

if ($L0-1)

if ($L0) $Xi = 1/(1/$L0-1); else $Xi = 0;

else $Xi = 0;

return array ( $Xi , $Xs );

}

· ci3 este exprimată prin intermediul intervalelor de confidenţă pentru proporţia X/n de:

iar implementarea formulei de calcul în PHP este:

function RD($f,$X,$n,$z,$a){

if($X==$n-$X) return array( -(float)"INF" , (float)"INF" );

$q=$f($X,$n,$z,$a);

if($X==$n) return array ( 1/$q1 , 1/$q0 );

if($q0==0) $tXs = 0; else $tXs = 1/(2-1/$q0);

if($q1==0.5)

$tXi=-(float)"INF";

else if(!$q1)

$tXi=0;

else

$tXi = 1/(2-1/$q1);

if($X){

$tX= 1/(2-$n/$X);

if(($tXi>$tX)||($tXs<$tX)) {

$tnX=1/(2-$n/($n-$X));

if(abs($tnX)<abs($tX))$tX=$tnX;

$tXi = $tX * exp(exp(abs($tX)));

$tXs = -$tX * exp(exp(abs($tX)));

}

}

return array( $tXi , $tXs );

}

Formulele corespunzătoare calculării intervalului de confidenţă al funcţiilor de două variabile (X,Y) se pot exprima de asemenea în funcţie de intervalele de confidenţă pentru proporţii:

· ci4 (X(n-Y)/Y/(m-X)) prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function R2($f,$X,$m,$Y,$n,$z,$am,$an){

$ciX = R($f,$X,$m,$z,$am);

$cinY = R($f,$n-$Y,$n,$z,$an);

return array ( $ciX0*$cinY0 , $ciX1*$cinY1 );

}

· ci5 (Y/n-X/m) prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function D($f,$X,$m,$Y,$n,$z,$am,$an){

$ciX = $f($X,$m,$z,$am);

$ciY = $f($Y,$n,$z,$an);

return array ( $ciY0-$ciX1 , $ciY1-$ciX0 );

}

· ci6 ( |Y/n-X/m|) prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function AD($ci){

if($ci0*$ci1<=0){

$max =abs($ci0);

if($max<abs($ci1)) $max = abs($ci1);

return array ( 0 , $max );

}else{

if($ci0<0) {

$ci0 = abs($ci0);

$ci1 = abs($ci1);

}

if($ci0<$ci1) return array( $ci0 , $ci1 );

else return array( $ci1 , $ci0 );

}

}

· expresia (1/(X/m-Y/n)) prezintă următoarea formulă de calcul a intervalului de confidenţă:

· ci7 (1/|Y/n-X/m|) prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function IAD($CI){

if($CI0) $Xs = 1/$CI0; else $Xs = (float)"INF";

if($CI0) $Xi = 1/$CI1; else $Xi = (float)"INF";

return array( $Xi , $Xs );

}

· ci8 (Xn/Y/m) prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function RP($f,$X,$m,$Y,$n,$z,$am,$an){

$ciX = $f($X,$m,$z,$am);

$ciY = $f($Y,$n,$z,$an);

$XYi = $ciX0/$ciY1;

if($ciY0) $XYs = $ciX1/$ciY0; else $XYs = (float)"INF";

return array ( abs($XYi), $XYs );

}

· ci9 ( |1- Xn/Y/m|) prezintă următoarea formulă de calcul a intervalului de confidenţă:

iar implementarea formulei de calcul în PHP este:

function ARP($f,$X,$m,$Y,$n,$z,$a){

$ci = $f($X,$m,$Y,$n,$z,$a);

if(!is_finite($ci1)) return array ( abs(1-$ci0) , (float)"INF" );

$t1 = 1-$ci0;

$t2 = 1-$ci1;

if($t1*$t2<=0){

$Xi = 0;

if(abs($t2)>abs($t1))

return array( 0 , abs($t2) );

else

return array( 0 , abs($t1) );

}else{

if(abs($t2)>abs($t1))

return array ( abs($t1) , abs($t2) );

else

return array ( abs($t2) , abs($t1) );

}

}

S-a definit percetila distribuţiei normale (z), pragul de semnificaţie (a), valoarea proporţiei maxime pentru care se evaluează intervalele de confidenţă sau erorile acestora (p), valoarea de pornire (N_min) şi valoarea de oprire (N_max) pentru volumul eşantionului:

define('z',1.96);

define('a',0.05);

define('p',1);

define('N_min',10);

define('N_max',11);

Un program PHP apelează fiecare dintre aceste funcţii pentru un n dat şi afişează eşecurile pentru pagul de semnificaţie fixat (fie prin intermediul lui a fie al lui z), folosind funcţia est_ci_er. De exemplu pentru calcularea intervalelor de confidenţă la proporţii s-a apelat funcţia est_ci_er cu următoarea linie de parametrii actuali:

est_ci_er(z,a,$c_i, 'I', 'ci1', 'ci');

unde $c_i este o variabilă tablou care păstrează numele metodelor folosite, variabilă necesară în apelarea funcţiilor corespunzătoare metodelor de calcul iar I este funcţia definită mai sus.

Cazul Bidimensional

Metodele care exprimă intervalul de confidenţă în cazul bidimensional în funcţie de intervalele de confidenţă din cazul unidimensional necesită o corecţie de probabilitate.

Am considerat limita intervalului de confidenţă din cazul bidimensional ca fiind dată de produsul limitelor pentru cazul unidimensional al cărui prag de semnificaţie a fost corectat pentru a ţine seama de produsul de convoluţie al erorilor.

Experimental s-a dedus că expresia pentru pragul de semnificaţie din cazul unidimensional (X,m) care să fie aplicat în formula de calcul pentru cazul bidimensional trebuie să fie dat de relaţia:

sau, cu corecţie după m,

unde a este pragul impus în cazul bidimensional (deci al expresiei de estimat) iar aU şi aU(m) reprezintă pragul ce va fi impus atunci pentru variabila unidimensională (X) de volum m. Analog rezultă expresia pentru pragul variabilei unidimensionale (Y) de volum n, aU(n).

Eşantioane aleatoare

S-au considerat 100 de valori aleatoare ale lui m (şi respectiv n) în domeniul 4..1000 şi X în domeniul 1..m-1 (şi respectiv Y în domeniul 1..n-1).

Rezultatele estimărilor au fost prelucrate şi reprezentate grafic folosind programul MathCad. Pentru aceasta a fost creat un program care să permită reprezentarea grafică a erorilor de estimare, folosind:

· frecvenţa de apariţie a erorilor experimentale;

· dispersiile experimentale faţă de valoarea impusă (α = 5%) a erorilor;

· mediile şi deviaţiile standard experimentale ale erorilor;

· curba de distribuţie teoretică a erorilor după o distribuţie Gauss de medie 5 şi deviaţie standard egală cu a unui eşantion binomial de volum 10.

Ecuaţiile corespunzătoare sunt:

Grafica

Pentru reprezentarea bi-variată în funcţie de X şi m s-a realizat un modul grafic care preia fişierele de rezultate calculate de programul descris anterior în formatul (m , X, Z), unde Z poate fi valoarea intervalului de confidenţă sau eroarea de estimare exprimată în procente, şi reprezintă grafic folosind un gradient de culori valorile Z pe suprafaţa unui triunghi ale cărui capete sunt valorile X (abscisa) şi m (ordonata).

Programul de reprezentare grafică este:

<?

define("pct",3); //numar de puncte pentru o valoare data a lui X si m

define("fmin",0); //val min a fct de reprezentat

define("fmax",10); //val max a fct de reprezentat

define("ncol",21); //numar impar de culori

define("tip",1); //tip gradient de culoare

$file="BayesF";

g_d($file,$v);

i_p($file,$v);

function i_p(&$file,&$v){

$in=pct*($vcount($v)-10+1);

$image = @imagecreate($in, $in);// create image

$alb = imagecolorallocate($image,255,255,255);

$negru = imagecolorallocate($image,0,0,0);

$t_l = $in-imagefontwidth(2)*strlen($file)-10;

imagestring($image, 2, $t_l,10, $file, $negru);

$cl = s_c_t($image,tip);

for($k=0;$k<count($v);$k++)

for($i=0;$i<pct;$i++){

for($j=0;$j<pct;$j++){

imagesetpixel($image,pct*$v$k1+$i,pct*$v$k0+$j,$clc($v$k2));

}

}

imagepng($image);//genereaza fisier tip png

//imagegif($image);//genereaza fisier tip gif

//imageinterlace($image,1);imagejpeg($image);//genereaza fisier tip jpg

}

function c($z){

if($z<=fmin) return 1;

if($z>=fmax) return ncol-1;

$cu = ($z-fmin)*(ncol-3)/(fmax-fmin);

$cu = (int)$cu;

return $cu + 1;

}

function g_d($file,&$v){

$data=file_get_contents($file.".txt");

$r=explode("\r\n",$data);

for($i=0;$i<count($r);$i++) $v$i=explode("\t",$r$i);

}

function s_c_t(&$image,$tip){

if($tip==0){//negru-alb

for ($i=0;$i<ncol;$i++){

$cb=round($i * 255/(ncol-1));

$tc$i=array( $cb , $cb , $cb );

}

}

if($tip==1){//rosu-albastru

$tc0 = array( 255 , 0 , 0 );

$yl = (ncol-1)/2; $yl = (int) $yl;

if($yl>1)

for($i=1;$i<$yl;$i++){

$cb = round($i * 255/$yl);

$tc$i = array( 255 , $cb , 0 );

}

$tc$yl = array( 255 , 255 , 0 );

if($yl>1)

for($i=1;$i<$yl;$i++){

$cb = round($i * 255/$yl);

$tc$yl+$i = array( 255-$cb , 255-$cb , $cb );

}

$tcncol-1 = array( 0 , 0 , 255 );

}

if($tip==2){//rosu-verde

$tc0 = array( 255 , 0 , 0 );

$yl = (ncol-1)/2; $yl = (int) $yl;

if($yl>1)

for($i=1;$i<$yl;$i++){

$cb = round($i * 255/$yl);

$tc$i = array( 255 , $cb , 0 );

}

$tc$yl = array( 255 , 255 , 0 );

if($yl>1)

for($i=1;$i<$yl;$i++){

$cb = round($i * 255/$yl);

$tc$yl+$i = array( 255-$cb , 255 , 0 );

}

$tcncol-1 = array( 0 , 255 , 0 );

}

for ($k=0;$k<ncol;$k++)

$cl$k=imagecolorallocate($image,$tc$k0,$tc$k1,$tc$k2);

return $cl;

}

?>

Programul de mai sus foloseşte constanta pct (= 3) pentru reprezentarea unui pătrat de 3×3 pixeli pentru fiecare cuplet (m, X, culoare(Z)). Constantele fmin pentru valoarea minimă care va fi reprezentată cu gradient de culoare între culoarea limită inferioară (roşu) şi culoarea medie (galben) şi fmax pentru valoarea maximă care va fi reprezentată cu gradient de culoare între culoarea limită superioară (albastru) şi culoarea medie (galben) cuprind domeniul de spectru colorat al graficului. Toate valorile care nu se încadrează în domeniul fmin , fmax sunt reprezentate cu culoarea limită inferioară (dacă Z < fmin) sau culoarea limită superioară (dacă Z > fmax).

Constanta n_col (s-a ales 21) defineşte numărul de nuanţe (plus cele 3 culori de bază) care construiesc nivelele de reprezentare în grafic.

Constanta tip (s-a ales 1) defineşte cupletul de culori limită (şi gradiente corespunzătoare) folosit, dintr-un set de 3 cuplete realizate: (Alb, Gri, Negru), (Roşu, Galben, Albastru) şi (Roşu, Galben, Verde).

Reprezentarea 3-variată în funcţie de X, Y şi er s-a realizat cu ajutorul programului SlideWrite Plus.

Concluzii

Aproximarea la normalizate a distribuţiei binomiale prezintă dezavantaje majore mai cu seamă în vecinătatea valorilor extreme ale proporţiei.

Studiul comparativ al diferitelor funcţii de calcul a funcţiei de probabilitate a distribuţiei binomiale a pus în evidenţă diferenţe semnificative între performanţele acestora odată cu creşterea lui n. În aceeaşi ordine de idei, cele mai eficiente metode se dovedesc cele care aplică întâi direct şi apoi invers logaritmul expresiei clasice a probabilităţii de distribuţie.

Definirea indicatorilor medicali în funcţie de expresia matematică pe care aceştia o calculează în funcţie de variabila aleatoare şi volumul eşantionului permite restrângerea majoră a numărului de investigaţii asupra intervalelor de confidenţă (de la ... la 9 expresii matematice distincte).

Implementarea în limbajul PHP oferă o maximă flexibilitate în ceea ce priveşte definirea şi utilizarea indicatorilor medicali, implementarea şi utilizarea funcţiilor de generare a funcţiilor de generare a eşantioanelor de distribuţie binomială, efectuarea experimentului de calcul a intervalelor de confidenţă şi determinarea erorii experimentale de apreciere a acestuia pentru fiecare metodă considerată în parte. Pentru indicatorii medicali care depind de două variabile aleatoare de distribuţie binomială şi două volume de eşantioane e posibil a exprima intervalul de confidenţă al acestora din expresiile intervalelor de confidenţă de la proporţia simplă schimbând însă valoarea impusă a probabilităţii.

Utilizarea programului MathCad e eficineţă atunci când avem de efectuat şi reprezentat grafic integrale complexe, cum este cazul celor bazate funcţia Gausiană (f(x)=a∙exp((x-b)2/c2) [16].

Reprezentarea tridimensională a funcţiilor de doi parametrii (cum este cazul indicatorilor medicali) unde de exemplu studiul expresiei funcţiei intervalului de confidenţă (f(X,n)) implică un grid triunghiular (0 ≤ X ≤ n; cu n şi X variind pe un domeniu specificat 4..103). Există extrem de puţine produse software capabile să realizeze suprafeţe de nivel folosind funcţii de interpolare, dar din păcate aproape toate ştiu să opereze doar cu griduri pătratice (0 ≤ X ≤ 103, 4 ≤ n ≤ 103) fără a ţine seama de faptul că nu există X > n. Astfel, a fost necesară implementarea unui program în PHP care să ne permită acest lucru, implementare care s-a dovedit foarte utilă.

Referinţe

[1] Drugan T, Bolboaca Sorana, Jäntschi L, Achimas Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 1. Sampling and Medical Key Parameters Calculation. Leonardo Electronic Journal of Practices and Technologies 2003;3:47-74.

[2] Achimaş Cadariu A. Gastroenterologia bazată pe evidenţe. În: Grigorescu M. Tratat de Gastroenterologie. Editura Medicală Naţională. 2001. p: 629-659.

[3] Robert M Hamm. Clinical Decision Making Spreadesheet Calculator. University of Oklahoma Health Sciences Center. [online] [cited 2004August, 18] Available from: www.emory.edu/WHSC/MED/EMAC/curriculum/diagnosis/oklahomaLRs.xls

[4] Knowleadge Library. Bandolier. Evidence Based Thinking about health care. [online] [cited 2004 August]. Available from: http://www.jr2.ox.ac.uk/bandolier/booth/glossary/ppto.html

[5] Diagnosis and screening. In: Sackett DL, Straus S, Richardson WS, Rosenberg W, Haynes RB. Evidence-based medicine. How to practise and teach EBM. 2nd ed. Edinburgh: Churchill Livingstone, 2000; p.: 67-93.

[6] Pre and post test odds. Knowledge Library. Bandolier "Evidence based thinking about health care". [Internet Page]. Centre for Statistics in Medicine Oxford; © 1994 - 2005 [cited 2005 August, 13] Available from: http://www.jr2.ox.ac.uk/bandolier/booth/glossary/ppto.html

[7] Drugan T, Bolboacă S, Colosi H, Achimaş Cadariu A, Ţigan Ş. Punerea în evidenţă a unor factori de risc sau progostici. In: Inferenţa statistică a datelor medicale. Casa de Editură ALMA MATER. 2003; p:66-71.

[8] Prognosis. In: Sackett DL, Straus S, Richardson WS, Rosenberg W, Haynes RB. Evidence-based medicine. How to practise and teach EBM. 2nd ed. Edinburgh: Churchill Livingstone, 2000; p.: 95-103.

[9]. Deeks Jon. Swots Corner: What is an odds ratio? [online]. Centre for Statistics in Medicine Oxford; © 1994 - 2005 [cited 2005 August, 13] Available from: http://www.jr2.ox.ac.uk/bandolier/band25/b25-6.html

[10] Therapy. In: Sackett D, Straus ES, Richardson WS, Rosenberg W, Haynes RB. Evidence-based Medicine: How to Practise and Teach EBM. 2nd ed. Edinburgh: Churchill Livingstone, 2000; p.: 105-154.

[11] Absolute risk reduction/increase. Knowledge Library. Bandolier "Evidence based thinking about health care". [online] [cited 2004 September, 3]. Available from: http://www.jr2.ox.ac.uk/bandolier/booth/glossary/ARR.html

[12] Peter Szatmari MD. Some useful concepts and terms used in articles about treatment. Evidence-Based Mental Health. 1998;1:39-40.

[13] Knowleadge Library. Bandolier. Evidence Based Thinking about health care. Describing results of trials and reviews. [online] [cited 2004 August, 13] Available from: http://www.jr2.ox.ac.uk/bandolier/booth/glossary/outputs.html

[14] Achimaş Cadariu A. Evaluarea unui procedeu diagnostic. În: Achimaş Cadariu A. Metodologia cercetării ştiinţifice medicale. Editura Medicală Universitară “Iuliu Haţieganu”. Cluj-Napoca. 1999. p.: 29-38.

[15] EpiMax Table Calculator. Epidemiology&Lab Statistics from Study Counts. Princeton, New Jersey. USA. [online] [cited 2005 August, 13]. Available from: http://www.healthstrategy.com/epiperl/epiperl.htm

[16] Gaussian function. TheFreeDictionary.com. [online] [cited 2005 August, 10] Available from: http://encyclopedia.thefreedictionary.com/Gaussian%20function


Intervale de confidenţă pentru funcţia ci1

Funcţia ci1 are următoarea expresie:

Deoarece variabilele din tabelul de contingenţă pot lua doar valori întregi cuprinse între 0 şi n (volumul eşantionului) legea de distribuţie pe care o urmează acestea este legea de distribuţie binomială.

Foarte mulţi autori aproximează legea de distribuţie binomială cu o lege de distribuţie normală cu aceeaşi medie şi dispersie cu cea binomială asociată [1] . Discuţia comparativă a acestor distribuţii şi limitele aproximaţiei la normalitate a distribuţiei binomiale a fost prezentată pe larg în capitolul anterior. În continuare se prezintă o serie de moduri de calcul a intervalului de contingenţă pentru proporţii, atât în aproximaţia normalităţii cât şi în ipoteza distribuţiei binomiale [2] .

O remarcă este necesară încă de la început: evitarea folosirii intervalelor de confidenţă calculate din distribuţia binomială are o explicaţie simplă: calculul necesar pentru a evalua intervalele de confidenţă din distribuţia binomială este foarte laborios.

Pentru a putea efectua un studiu comparativ atât sub aspect calitativ cât şi cantitativ al performanţelor obţinute de fiecare metodă de calcul a intervalului de confidenţă s-a construit un program PHP. Programul rulează experimentul de calculare a intervalului de confidenţă pentru un X şi un n dat, construieşte un eşantion de distribuţie binomială (notat XX) în jurul valorii X (presupusa valoare adevărată) şi calculează câte eşecuri de cuprindere a valorii X în intervalul de confidenţă a valorii xxÎXX sunt înregistrate pentru fiecare metodă în parte. Experimentul s-a rulat pentru pragul de eroare α = 0.05 (5%, notat a în program) şi respectiv z1-α/2 = 1.96 (percentila distribuţiei normale standard), pentru metodele care folosesc această valoare (cele bazate pe ipoteza normalităţii). Valorile lui n pentru care s-au testat metodele de calcul a intervalului de confidenţă s-au ales astfel încât să cuprindă plaja de situaţii reale întâlnite în studiile medicale şi anume în intervalul 4 ≤ n ≤ 1000. Valorile lui X pentru care s-au evaluat eşecurile în aprecierea corectă a intervalului de confidenţă au fost 0 < X < n. Metodele alese în studiu, împreună cu sursa bibliografică de unde acestea au fost raportate sunt prezentate în tabelul 15.

Metodele prezentate în tabelul 15 sunt departe de a fi epuizat întreaga literatură de specialitate în domeniul intervalelor de confidenţă pentru proporţii. S-a urmărit şi s-au ales pentru studiul de faţă metodele de calcul a intervalului de confidenţă cele mai frecvent folosite şi raportate în literatură.

Tabelul 15. Metode de calcul a intervalului de confidenţă pentru proporţii

Nr | Denumire | Limite de confidenţă inferioare şi superioare
1 | Wald [3] , [4], [5], [6] | ; c = 0 (standard); c = 0.5 (corectat în continuitate)
2 | Wilson 4, 5, 6 | ; Corectat în continuitate:
3 | ArcSine 4, 5 | sau 0 (X = 0) sau 1 (X = n); (ArcS) Alte formule corectate: (ArcSC1) (ArcSC2) (ArcSC3)
4 | Agresti-Coull 6 |
5 | Logit 6 | pentru 0<X<n; Corectat în continuitate:
6 | Binomiale [7] Clopper-Pearson 4, 6, [8] Jeffreys 4, 6 Bayesian 4, 6 BayesianF Blyth-Still-Casella [9] , [10] | Pentru 0 < X < n se definesc funcţiile: BinI(c1,c2,a) = BinS(c1,c2,a) = Clopper-Pearson: BinI(0,1,α/2), BinS(0,1,α/2) sau 0 (X=0), 1(X=n) Jeffreys: BinI(0.5,0.5,α/2), BinS(0.5,0.5,α/2) BayesianF: BinI(1,1,α/2), BinS(1,1,α/2) sau 0 (X=0), 1(X=n) Bayesian: BinI(1,1,α/2) sau 0 (X=0) , α1/(n+1) (X=n), BinS(1,1,α/2) sau 1- α1/(n+1) (X=0) , 1 (X=n) Blyth-Still-Casella: BinI(0,1,α1) sau 0 (X=0), BinS(0,1,α2) sau 1(X=n) unde α1 + α2 = α şi BinS(0,1,α2)-BinI(0,1,α1) = min.

Notă: invCFD este inversa funcţiei de repartiţie Fisher

Funcţiile PHP de calcul a intervalelor de confidenţă pentru proporţii

Pentru a pune în evidenţă diferenţele, s-a simulat un experiment de calcul pentru o distribuţie binomială a valorilor lui X, socotind eşecurile raportate la pragul de semnificaţie fixat.

Descrierea experimentului:

S-a construit tabloul care memorează numele funcţiilor:

$c_i=array( "Wald" , "WaldC" , "Wilson" , "WilsonC" , "ArcS" , "ArcSC1" , "ArcSC2" , "ArcSC3",

"AC" , "Logit" , "LogitC" , "BS" , "Bayes" , "BayesF" , "Jeffreys" , "CP" );

Pentru a putea calcula formulele prezentate în tabelul 3.9 a fost necesară implementarea funcţiilor, implementare care s-a realizat în limbajul PHP. După cum se observă din tabelul 3.9, unele dintre aceste funcţii (mai ales cele bazate pe distribuţia binomială) folosesc un calcul laborios bazat pe distribuţia Fisher (preluat de la sourceforge.net), de evaluare a inversei funcţiilor de repartiţie a acestei funcţii.

Limitele intervalului de confidenţă Wald sunt calculate de funcţia Wald (foloseşte ipoteza normalităţii):

function Wald($X,$n,$z,$a){

$t0 = $z * pow($X*($n-$X)/$n,0.5);

$tXi = ($X-$t0)/$n; if($tXi<0) $tXi=0;

$tXs = ($X+$t0)/$n; if($tXs>1) $tXs=1;

return array( $tXi , $tXs ); }

Limitele intervalului de confidenţă Wald corectat la continuitate sunt calculate de funcţia WaldC (foloseşte ipoteza normalităţii):

function WaldC($X,$n,$z,$a){

$t0 = $z * pow($X*($n-$X)/$n,0.5) + 0.5;

$tXi = ($X-$t0)/$n; if($tXi<0) $tXi=0;

$tXs = ($X+$t0)/$n; if($tXs>1) $tXs=1;

return array( $tXi , $tXs ); }

Limitele intervalului de confidenţă Wilson sunt calculate de funcţia Wilson (foloseşte ipoteza normalităţii):

function Wilson($X,$n,$z,$a){

$tX = $X + pow($z,2)/2; $tn = $n + pow($z,2);

$t0 = $z * pow($X*($n-$X)/$n+pow($z,2)/4,0.5);

return array( ($tX-$t0)/$tn , ($tX+$t0)/$tn ); }

Limitele intervalului de confidenţă Wilson corectat în continuitate sunt calculate de funcţia WilsonC (foloseşte ipoteza normalităţii):

function WilsonC($X,$n,$z,$a){

$t0 = 2*$X+pow($z,2);

$t1 = 2*($n+pow($z,2));

$t2=pow($z,2)-1/$n;

if($X==0) $Xi=0; else $Xi = ($t0-$z * pow($t2+4*$X*(1-($X-1)/$n)-2,0.5)-1)/$t1;

if($X==$n) $Xs=1; else $Xs = ($t0+$z * pow($t2+4*$X*(1-($X+1)/$n)+2,0.5)+1)/$t1;

return array( $Xi , $Xs ); }

Limitele intervalului de confidenţă prin metoda ArcSine sunt calculate de funcţia ArcS (foloseşte ipoteza normalităţii):

function ArcS($X,$n,$z,$a){

$tX = asin(pow($X/$n,0.5));

$t0 = $z/pow(4*$n,0.5);

if ($X==0) $tXi=0; else $tXi=pow(sin($tX-$t0),2);

if ($X==$n) $tXs=1; else $tXs=pow(sin($tX+$t0),2);

return array( $tXi , $tXs ); }

Limitele intervalului de confidenţă prin metoda ArcSine, prima variantă de corecţie la continuitate sunt calculate de funcţia ArcSC1 (foloseşte ipoteza normalităţii):

function ArcSC1($X,$n,$z,$a){

$tX = asin(pow(($X+3/8)/($n+3/4),0.5));

$t0 = $z/pow(4*$n,0.5);

if($X==0) $Xi=0; else $Xi = pow(sin($tX-$t0),2);

if($X==$n) $Xs=1; else $Xs = pow(sin($tX+$t0),2);

return array( $Xi , $Xs ); }

Limitele intervalului de confidenţă prin metoda ArcSine, a doua variantă de corecţie la continuitate sunt calculate de funcţia ArcSC2 (foloseşte ipoteza normalităţii):

function ArcSC2($X,$n,$z,$a){

$t0 = $z/pow(4*$n,0.5);

$tXi = asin(pow(($X-0.5)/$n,0.5));

$tXs = asin(pow(($X+0.5)/$n,0.5));

if($X==0) $Xi = 0; else $Xi = pow(sin($tXi-$t0),2);

if($X==$n) $Xs = 1; else $Xs = pow(sin($tXs+$t0),2);

return array( $Xi , $Xs ); }

Limitele intervalului de confidenţă prin metoda ArcSine, a treia variantă de corecţie la continuitate sunt calculate de funcţia ArcSC3 (foloseşte ipoteza normalităţii):

function ArcSC3($X,$n,$z,$a){

$t0 = $z/pow(4*$n+2,0.5);

$tXi = asin(pow(($X+3/8-0.5)/($n+3/4),0.5));

$tXs = asin(pow(($X+3/8+0.5)/($n+3/4),0.5));

if($X==0) $Xi = 0; else $Xi = pow(sin($tXi-$t0),2);

if($X==$n) $Xs = 1; else $Xs = pow(sin($tXs+$t0),2);

return array( $Xi , $Xs ); }

Limitele intervalului de confidenţă Agresti-Coull sunt calculate de funcţia AC (foloseşte ipoteza normalităţii):

function AC($X,$n,$z,$a){ return Wald($X+pow($z,2)/2,$n+pow($z,2),$z,$a); }

Limitele intervalului de confidenţă prin metoda Logit sunt calculate de funcţia Logit (foloseşte ipoteza normalităţii):

function Logit($X,$n,$z,$a){

if(($X==0)||($X==$n)) return CP($X,$n,$z,$a);

$t0 = log(($X)/($n-$X));

$t1 = $z*pow($n/$X/($n-$X),0.5);

$Xt1 = $t0-$t1;

$Xt2 = $t0+$t1;

$Xi = exp($Xt1)/(1+exp($Xt1));

$Xs = exp($Xt2)/(1+exp($Xt2));

return array ( $Xi , $Xs ); }

Limitele intervalului de confidenţă prin metode Logit corectată la continuitate sunt calculate de funcţia LogitC (foloseşte ipoteza normalităţii):

function LogitC($X,$n,$z,$a){

$t0 = log(($X+0.5)/($n-$X+0.5));

$t1 = $z*pow(($n+1)*($n+2)/$n/($X+1)/($n-$X+1),0.5);

$Xt1 = $t0-$t1;

$Xt2 = $t0+$t1;

$Xi = exp($Xt1)/(1+exp($Xt1));

$Xs = exp($Xt2)/(1+exp($Xt2));

if($X==0) $Xi = 0; if($X==$n) $Xs = 1;

return array ( $Xi , $Xs ); }

Limitele intervalului de confidenţă prin metoda Blyth-Still (preluate din literatura de specialitate [11] ) sunt obţinute doar pentru α = 0.05 şi 1 ≤ n ≤ 30 de funcţia BS:

function BS($X,$n,$z,$a){ if($a-0.05) exit(0); return Blyth_Still($X,$n); }

Funcţiile BinI şi BinS ce intervin în toate expresiile metodelor binomiale sunt calculate de funcţia BinomialC:

function BinomialC($X,$n,$z,$a,$c1,$c2){

if($X==0) $Xi = 0; else {

$binXi = new FDistribution(2*($n-$X+$c2),2*($X+$c1));

$Xi = 1/(1+($n-$X+$c2)*$binXi->inverseCDF(1-$a/2)/($X+$c1));

}

if($X==$n) $Xs = 1; else {

$binXs = new FDistribution(2*($X+$c2),2*($n-$X+$c1));

$Xs = 1/(1+($n-$X+$c1)/($X+$c2)/$binXs->inverseCDF(1-$a/2));

} return array ( $Xi , $Xs ); }

Limitele intervalului de confidenţă prin metoda Jeffreys, sunt calculate de funcţia Jeffreys:

function Jeffreys($X,$n,$z,$a){ return BinomialC($X,$n,$z,$a,0.5,0.5); }

Limitele intervalului de confidenţă prin metoda Clopper-Pearson, sunt calculate de funcţia CP:

function CP($X,$n,$z,$a){ return BinomialC($X,$n,$z,$a,0,1); }

Limitele intervalului de confidenţă prin metoda BayesF, sunt calculate de funcţia BayesF:

function BayesF($X,$n,$z,$a){ return BinomialC($X,$n,$z,$a,1,1); }

Limitele intervalului de confidenţă prin metoda Bayes, sunt calculate de funcţia Bayes:

function Bayes($X,$n,$z,$a){

if($X==0) return array ( 0 , 1-pow($a,1/($n+1)) );

if($X==$n) return array ( pow($a,1/($n+1)) , 1 );

return BayesF($X,$n,$z,$a); }

Calcularea intervalelor de confidenţă pentru metodele implementate

În figura 10 sunt reprezentate valorile intervalelor de confidenţă pentru X aşa cum rezultă din formulele de calcul prezentate în tabelul 14 pentru n = 10.

Liniile de program corespunzătoare acestei alegeri sunt:

$c_i=array( "Wald" , "WaldC" , "Wilson" , "WilsonC" , "ArcS" , "ArcSC1" , "ArcSC2" , "ArcSC3" ,

"AC" , "Logit" , "LogitC" , "BS" , "Bayes" , "BayesF" , "Jeffreys" , "CP" );

define("p",1); define("N_min",10);define("N_max",11);

est_ci_er(z,a,$c_i,"I","ci1","ci");

Figura 10. Intervalele de confidenţă pentru ci1 la n = 10 în funcţie de X (0 ≤ X ≤ n)

Dacă se variază n în domeniul 4 – 103 se obţin suprafeţe de nivel a valorii proporţiei şi respectiv intervalelor sale de confidenţă. În figura 11 sunt redate suprafeţele de nivel pentru valoarea proporţiei şi a intervalelor de confidenţă calculate folosind o metodă binomială expusă la sfârşitul secţiunii. În figură, cu culoarea roşu este reprezentată valoarea 0, cu galben valoarea 0.5 şi cu albastru valoarea 1. Valorile intermediare dintre acestea au fost reprezentate folosind 18 nuanţe intermediare (câte 9 pentru fiecare combinaţie de culori).

Figura 11. Suprafeţe de nivel pentru funcţia ci1 şi intervalelor sale de confidenţă

După cum se observă din reprezentările grafice din figura 10 şi 11, valorile superioare ale intervalului de confidenţă sunt imaginea în oglindă faţă de funcţia ci1(X) = X ale valorilor inferioare ale sale pe domeniul de valori 0..n. Aşa cum se observă, cele mai semnificative diferenţe în calculul valorilor intervalului de confidenţă sunt prin metoda Wald. O altă observaţie este importantă: exceptând Wald şi forma sa corectată WaldC, toate celelalte metode par să nu prezinte diferenţe semnificative în calcularea intervalului de confidenţă, sau, mai exact spus, simpla reprezentare a valorilor capetelor intervalelor de confidenţă nu pune în evidenţă diferenţele dintre acestea.

Pentru a putea alege dintre aceste metode una sau mai multe metode capabile de estimări cât mai performante, în continuare se vor analiza erorile de estimare a intervalului de confidenţă pentru fiecare metodă considerată, folosind ipoteza distribuţiei binomiale, ca metodă de apreciere atât sub aspect calitativ cât şi sub aspect cantitativ a metodelor.

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru un prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define('z',1.96); define('a',0.05); în codul sursă al programului implementat).

Primul set de experimente a constat în compararea metodelor în ceea ce priveşte erorile experimentale produse de acestea pentru valori reprezentative ale lui n din intervalul 4..1000 şi anume n = 10, 30, 100, 300 şi 1000. Rezultatele execuţiei experimentului au fost importate în Excel, unde s-au realizat diagrame de dependenţă a procentului de erori în funcţie de valoarea lui X pentru diferite valori ale lui n. Bazat pe aceste diagrame şi pe valorile medii obţinute, în urma rulării fiecărui experiment s-au comparat rezultatele obţinute de fiecare metodă şi metodele care s-au abătut cel mai mult de la pragul impus α = 5% au fost scoase din experimentele ulterioare.

Pentru n = 10, eşecurile procentuale în funcţie de valoarea lui X ( 0 < X < n) pentru fiecare metodă sunt reprezentate în figura 12.

Secvenţa de program care calculează erorile pentru n = 10 este:

$c_i=array( "Wald" , "WaldC" , "Wilson" , "WilsonC" , "ArcS" , "ArcSC1" , "ArcSC2" , "ArcSC3" ,

"AC" , "Logit" , "LogitC" , "BS" , "Bayes" , "BayesF" , "Jeffreys" , "CP" );

define("N_min",10);define("N_max",11);

est_ci_er(z,a,$c_i,"I","ci1","er");

Figura 12. Procentul erorilor experimentale pentru ci1 la n = 10 în funcţie de X (0 < X < n)

După cum se poate remarca şi din figura 12, pentru n = 10, 5 metode de calcul a intervalului de confidenţă sunt sistematic sub pragul impus de α = 5%: WilsonC (cu o medie a erorilor de 1.89), ArcSC2 şi ArcSC3 (cu medii a erorilor de 1.93 şi respectiv 1.31), Logit (cu o medie a erorilor de 1.89), BS (cu o medie a erorilor de 2.52) şi CP (media erorilor de 1.31). Un alt lucru care se poate remarca pentru acest volum al eşantionului este faptul că metodele Wilson, LogitC, Bayes şi BayesF sunt identice, prezentând aceleaşi erori de estimare şi o medie a erorilor de estimare de 4.61.

O concluzie este imediată: nu sunt acceptabile erorile produse de Wald, WaldC, ArcS (prea mari erorile în conformitate cu pragul impus de α = 5%, respectiv mediile erorilor experimentale de 17.33%, 13.69% şi respectiv 15.53%), ArcSC3 şi CP (prea mici erorile în conformitate cu pragul impus α = 5%, respectiv valori ale erorilor estimate de 1.31%).

Se vor discuta în continuare doar metodele rămase după această excludere.

Secvenţa de program pentru calculul erorilor la n = 30 devine:

$c_i=array( "Wilson" , "WilsonC" , "ArcSC1" , "ArcSC2" ,

"AC" , "Logit" , "LogitC" , "BS" , "Bayes" , "BayesF" , "Jeffreys" );

define("N_min",30);define("N_max",31);

est_ci_er(z,a,$c_i,"I","ci1","er");

iar rezultatele sunt redate în figura 13.

Figura 13. Procentul erorilor experimentale pentru ci1 la n = 30 în funcţie de X (0 < X < n)

În graficele reprezentate în figura 3.19 se observă că procentele de erori produse de metodele WilsonC, ArcSC2 şi BS sunt sistematic situate sub valoarea pragului impus α = 5%. Calcularea mediilor erorilor de estimare a relevat faptul că, mediile erorilor sunt de 2.77% (pentru Wilson), 3.27% (pentru ArcSC2) şi 3.61% (pentru BS). Chiar şi metoda Logit produce valori foarte mici (cu o medie de 3.57%), însă aceasta spre deosebire de BS are şi valori superioare lui α = 5% (5.23% la X = 4 şi X = 26).

Pe baza celor expuse anterior consider inacceptabilă comportarea metodelor WilsonC, ArcSC2 şi BS, metode care se vor elimina din experimentele şi discuţiile următoare.

Erorile produse la n = 100 sunt calculate cu secvenţa de program:

$c_i=array( "Wilson" , "ArcSC1" , "AC" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" );

define("N_min",100); define("N_max",101);

est_ci_er(z,a,$c_i,"I","ci1","er");

şi sunt redate în figura 14.

În graficele reprezentate în figura 20 se observă variaţiile erorilor de estimare la n = 100. Ca şi în cazul erorilor calculate pe eşantion de 30, şi în cazul eşantionului de 100 metoda Logit depăşeşte valoarea de 5% (5.07% la X = 2, 6.43% la X = 4, 5.12% la X = 9, 5.44% la X = 19, 5.96% la X = 20, 5.17% la X = 26, 5.47% la X = 27, 5.74% la X = 28, 6.03% la X = 29, etc), chiar dacă media este situată sub 5% (4.71%) nefiind deci un motiv să fie eliminată.

Analizând acum valorile mediilor şi deviaţiilor standard, cum de altfel este vizibil şi pe reprezentările grafice, cele mai bune medii sunt obţinute de metodele Jeffreys (5.03), ArcSC1 (4.96), Wilson (5.07) şi BayesF (5.08), iar cele mai bune deviaţii standard de metodele LogitC (0.83), BayesF (0.91), Logit (0.94) şi Bayes (0.95).

Figura 14. Procentul erorilor experimentale pentru ci1 la n = 100 în funcţie de X ( 0 < X < n)

Procedând la calculul erorilor de estimare la n = 300 secvenţa de program devine:

$c_i=array( "Wilson" , "ArcSC1" , "AC" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" );

define("N_min",300);define("N_max",301);

est_ci_er(z,a,$c_i,"I","ci1","er");

şi rezultatele sunt redate în figura 15.

Figura 15. Procentul erorilor experimentale pentru ci1 la n = 300 în funcţie de X ( 0 < X < n)

Analiza mediilor şi deviaţiilor standard pentru valorile prezentate în figura 15 conduce la concluzia că pentru n = 300 cele mai bune valori medii ale erorilor sunt atinse de metodele Wilson (5.03), BayesF (5.04) şi ArcSC1 (5.06) iar cele mai bune valori ale variaţiilor faţă de media erorilor sunt atinse de Logit, LogitC şi BayesF (cu 0.63%).

Pentru n = 1000 secvenţa de program este:

$c_i=array( "Wilson" , "ArcSC1" , "AC" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" );

define("N_min",1000);define("N_max",1001);

est_ci_er(z,a,$c_i,"I","ci1","er");

şi rezultatele sunt prezentate în figura 16.

Figura 16. Procentul erorilor experimentale pentru ci1 la n = 1000 în funcţie de X (0 < X < n)

Analiza mediilor şi deviaţiilor standard pentru metodele prezentate în figura 16 conduce la concluzia că pentru n = 1000 cele mai bune valori medii ale erorilor sunt obţinute de metodele Wilson (5), BayesF şi ArcSC1 (5.01) iar cele mai mici deviaţii standard de metodele BayesF (0.37) urmat de Wilson, ArcSC1, Logit, LogitC şi Bayes cu obţin aceeaşi valoare, egală cu 0.39.

Din analiza rezultatelor execuţiei experimentului până în acest punct, rezultă că sistematic metoda AC se situează sub celelalte metode în ceea ce priveşte performanţele. Comparând acum metoda Bayes cu BayesF (metode care diferă doar prin alegerea valorilor pentru capete (X = 0 şi X = n) se observă că alegerea valorilor la capete este mai bună în cazul metodei BayesF.

În concluzie, din discuţia care urmează vor fi eliminate metodele AC şi Bayes.

Al doilea set de experimente a constat în calcularea valorilor erorilor medii pe intervale ale lui n şi anume n = 4..10, n = 11..30, n = 31..100, n = 101-200, n = 201..300. Pentru a avea o mai bună privire de ansamblu în ceea ce priveşte metodele rămase (Wilson, ArcSC1, Logit, LogitC, BayesF şi Jeffreys) s-au calculat mediile şi devialţiile standard ale erorilor pentru fiecare n. Se va folosi media şi deviaţia standard a erorilor produsă de fiecare metodă pentru un n dat ca indicator al calităţii metodei pentru acel n.

Secvenţele de program folosite sunt:

· pentru n = 4..10:

define("N_min",4);

define("N_max",11);

$c_i=array( "Wilson" , "ArcSC1" , "Logit" , "LogitC" , "BayesF" , "Jeffreys" );

est_ci_er(z,a,$c_i,"I","ci1","va");

· pentru n = 11..30 se modifică:

define("N_min",11);

define("N_max",31);

· pentru n = 31..100 se modifică:

define("N_min",31);

define("N_max",101);

· pentru n = 101..200 se modifică:

define("N_min",101);

define("N_max",201);

· pentru n = 201..300 se modifică:

define("N_min",201);

define("N_max",301);

Dacă se reprezintă grafic valorile obţinute prin scădere şi adunarea deviaţiei standard la media erorilor esperimentale (M-StDev, M+StDev) pentru 3 < n ≤ 100 se obţin graficele din figura 17.

O observaţie imediată este valoarea scăzută a variaţiei faţă de valoarea medie pentru metoda Logit (fapt care era oarecum de aşteptat, dată fiind expresia sa logaritmică), fapt care se remarcă din grafic, suprafaţa acoperită de varianţa faţă de medie fiind cea mai mică.

Mediind valorile obţinute pe intervale, se obţin rezultatele din tabelul 5. O concluzie se poate desprinde studiind valorile din tabelul 16: cel mai aproape de pragul impus de 5% şi în acelaşi timp cu deviaţia cea mai mică pentru n ≤ 10 este intervalul de confidenţă calculat prin metoda Wilson. În continuare, pentru 10 < n ≤ 100 cele mai bune performanţe se înregistrează cu intervalul de confidenţă calculat prin metoda LogitC.

Figura 17. M-StDev, M+StDev pentru ci1 în funcţie de n (când n variază de la 4 la 100)

Tabelul 16. Medii ale erorilor experimentale şi deviaţii standard pentru trei intervale

ale lui n (3 < n ≤ 100)

n | Wilson | ArcSC1 | Logit | LogitC | BayesF | Jeffreys
4-10 | 5.20 (2.26) | 2.36 (1.22) | 3.54 (2.02) | 4.90 (2.29) | 4.90 (2.29) | 5.69 (2.41)
11-30 | 5.04 (1.93) | 4.17 (1.74) | 3.43 (1.19) | 4.88 (1.66) | 4.88 (1.88) | 4.78 (1.58)
30-100 | 4.98 (1.20) | 4.76 (1.25) | 4.39 (1.03) | 5.07 (1.04) | 4.94 (1.18) | 4.92 (1.23)

Pentru intervalul 100 < n ≤ 200, reprezentarea grafică a substracţiei şi adiţiei deviaţiei standard la media erorilor experimentale este redată în figura 18. După cum se observă din figura 18, pentru n > 100, diferenţele între metodele de calcul a intervalului de confidenţă cu Wilson, ArcSC1, Logit, LogitC, BayesF şi Jeffreys ajung să nu mai fie semnificative. Totuşi, mici diferenţe se pot pune şi aici în evidenţă (vezi tabelul 17).

Analizând datele din intervalul n = 101 - 300 pe subintervale de 10 valori se obţin rezultatele din tabelul 17.

Figura 18. Substracţia şi adiţia deviaţie standard la valoarea mediei erorilor experimentale pentru ci1 când n variază de la 101 la 200

Analizând datele din tabelul 17 se observă că, constanţa performanţei obţinute de metoda BayesF este remarcabilă: doar cu două excepţii (şi acestea pe subintervale) valorile sale pentru medie şi deviaţia standard nu se situează printre primele 3 valori.

O altă remarcă deosebit de importantă este că întotdeauna valoarea mediei deviaţiei standard a erorilor prin metoda BayesF este între primele 3 ca performanţă. Metoda LogitC este foarte conservativă în ceea ce priveşte deviaţia standard, obţinând prima performanţă în 8 din 10 cazuri pe subintervalele lui 101 – 200. În ceea ce priveşte valoarea medie a mediei erorilor, este mai greu de stabilit un clasament, fiecare dintre metodele ArcSC1, LogitC, BayesF şi Jeffreys având câte cel puţin două apariţii cu cea mai apropiată valoare de pragul α = 5% impus. Totuşi, în medie pe întreg intervalul n = 101..300 prima se situează Jeffreys (4.991%) urmată la foarte mică distanţă de BayesF (4.989%).

Tabelul 17 Medii ale erorilor experiemntale şi deviaţii standard experimentale (paranteze)

pentru intervale ale lui n ( 100 < n ≤ 300)

n | Wilson | ArcSC1 | Logit | LogitC | BayesF | Jeffreys
101-110 | 4.96 (1.00) | 4.91(1.05) | 4.64 (0.90) | 5.10 (0.88) | 5.02 (0.99) | 5.04 (1.03)
111-120 | 4.93 (0.92) | 4.87 (0.99) | 4.62 (0.82) | 5.09 (0.83) | 4.97 (0.89) | 4.95 (0.95)
121-130 | 5.03 (0.93) | 5.01 (0.99) | 4.71 (0.87) | 5.10 (0.84) | 5.05 (0.88) | 5.02 (0.96)
131-140 | 4.94 (0.88) | 4.86 (0.91) | 4.62 (0.80) | 5.03 (0.80) | 4.96 (0.84) | 4.91 (0.91)
141-150 | 5.08 (0.85) | 4.99 (0.92) | 4.74 (0.83) | 5.14 (0.77) | 5.08 (0.84) | 5.06 (0.89)
151-160 | 4.96 (0.86) | 4.88 (0.90) | 4.64 (0.80) | 5.01 (0.79) | 4.95 (0.84) | 4.96 (0.87)
161-170 | 4.90 (0.79) | 4.95 (0.87) | 4.73 (0.76) | 5.09 (0.73) | 4.96 (0.77) | 4.97 (0.82)
171-180 | 4.98 (0.81) | 5.00 (0.87) | 4.77 (0.76) | 5.10 (0.74) | 5.01 (0.77) | 5.04 (0.82)
181-190 | 4.91 (0.78) | 4.89 (0.81) | 4.68 (0.70) | 5.03 (0.73) | 4.91 (0.75) | 4.94 (0.79)
191-200 | 4.97 (0.75) | 4.94 (0.80) | 4.78 (0.70) | 5.14 (0.69) | 4.98 (0.71) | 5.01 (0.77)
101-200 | 4.97 (0.86) | 4.93 (0.91) | 4.69 (0.79) | 5.08 (0.78) | 4.99 (0.83) | 4.99 (0.88)
201-300 | 4.97 (0.69) | 4.96 (0.73) | 4.80 (0.65) | 5.07 (0.66) | 4.97 (0.67) | 5.01 (0.71)

În al treilea set de experimente s-a calculat şi reprezentat harta de nivel a erorilor pentru fiecare metodă considerată în această secţiune.

În final este redată o metodă binomială (numită Binomial) care îmbunătăţeşte metodele BayesF şi Jeffreys (demonstraţie care este redată la finalul secţiunii). Metoda înlocuieşte constantele c1 şi c2 folosite în cazul metodelor BayesF şi Jeffreys cu o expresie de X şi n:

function Binomial($X,$n,$z,$a){

return BinomialC($X,$n,$z,$a,1-pow($X*($n-$X),0.5)/$n,1-pow($X*($n-$X),0.5)/$n);

}

Metoda Binomial este dată de relaţia matematică (vezi tabelul 15):

Programul de estimare a erorilor s-a modificat corespunzător alegerii lui n = 4 – 103 şi includerii tuturor metodelor astfel:

$c_i=array( "Wald" , "WaldC" , "Wilson" , "WilsonC" , "ArcS" , "ArcSC1" , "ArcSC2" , "ArcSC3" ,

"AC" , "CP" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" , "Binomial" );

define("N_min",4);
define("N_max",103);
est_ci_er(z,a,$c_i,"I","ci1","er");

Reprezentarea grafică a erorilor s-a realizat folosind programul descris la sfârşitul primului capitolului. Pe harta de nivel s-au reprezentat erorile de la 0% (Roşu) la 5% (Galben) şi 10% şi peste (Albastru) folosind 18 de nuanţe intermediare (figura 19). Valorile lui n (de la 4 la 103) formează axa verticală iar valorile lui X (de la 0 la n) formează axa orizontală.

Figura 19. Suprafeţe de nivel ale erorilor experimentale pentru ci1 la 4 < n < 103

O expresie calitativă a unei metode de calcul a intervalului de confidenţă poate fi deviaţia erorilor experimentale pentru fiecare proporţie faţă de valoarea impusă α = 5% pentru un volum de eşantion dat n.

Se poate construi astfel funcţia Var(M,n) := ∑0<k<n(Err(M,n,k)-5)2/(n-3), unde M este metoda folosită, care să exprime calitatea unei metode de calcul a intervalului de confidenţă.

Cea mai bună valoare a lui Var(M,n) pentru un n dat dă astfel cea mai bună metodă de calcul a intervalului de confidenţă pentru acel n.

Dacă se iau valorile lui n = 4..103 şi se numără apariţiile celor mai bune valori ale lui Var(M,n) pentru fiecare n şi fiecare dintre metodele Wilson, BayesF, Jeffreys, Logit, LogitC şi Binomial se obţine diagrama din figura 20.

Figura 20. Cele mai bune frecvenţe ale deviaţiilor erorilor experimentale faţă de valoarea impusă α = 5% pentru ci1 la n = 4..103

Analiza diagramei din figura 20 relevă o serie de aspecte.

Prima observaţie este că metoda originală Binomial îmbunătăţeşte net metodele BayesF şi Jeffreys chiar dacă la limită ea cade peste acestea (vezi funcţia Binomial):

,

O a doua observaţie este că metoda Binomial obţine net cele mai bune performanţe (cu 58 de apariţii, urmată de LogitC cu 27).

A treia observaţie (care nu rezidă din fig. 20 ci din datele experimentale generate) este că pentru n > 30 este aproape sistematic cea mai bună metodă, având 54 de apariţii (urmată de LogitC cu 13, celelalte neavând nici o apariţie). Mai mult, începând cu n = 67 şi până la n = 103 metoda Binomial produce totdeauna cea mai bună deviaţia standard.

Pentru a valida ipoteza emisă că pentru n ≥ 67 metoda Binomial are cea mai bună devia’ie standard, s-au calculat variaţiile faţă de 5 pentru următoarele 6 valori ale lui n. Rezultatele acestui experiment sunt redate în tabelul 18.

Tabelul 18. Cele mai bune deviaţii faţă de valoarea impusă pentru ci1 la n = 104..109

n | Binomial | LogitC | Jeffreys | BayesF
104 | 0.83 | 0.90 | 1.08 | 1.03
105 | 0.76 | 0.90 | 1.03 | 1.02
106 | 0.77 | 0.91 | 1.03 | 1.02
107 | 0.76 | 0.89 | 1.02 | 1.01
108 | 0.75 | 0.89 | 1.01 | 1.01
109 | 0.75 | 0.90 | 1.01 | 1.00

Într-adevăr, datele din tabelul 18 confirmă ipoteza emisă anterior că metoda Binomial produce cele mai mici variaţii ale erorilor faţă de valoarea impusă α = 5%. Notabil este şi faptul că variaţia erorilor metodei Binomial este mult inferioară variaţiilor produse de celelalte metode (vezi tabelul 18). Notă: nu se poate aplica nici un test statistic acestor valori (F, t, Anova), deoarece nu sunt îndeplinite ipotezele acestora (valorile nu reprezintă determinări experimentale ci reprezintă valori calculate matematic bazate pe funcţii exacte de calcul şi nu sunt astfel afectate de erori).

Eşantioane (X, n) aleatoare

Experimentul a fost rulat pentru toate metodele discutate. În figura 21 cu puncte sunt reprezentate frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)). Rezultatele experimentale pentru funcţia ci1 sunt redate în tabelele 19 – 22.

Figura 21. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, n

În tabelul 19 sunt prezentate metodele de calcul a intervalului de confidenţă ordonate după deviaţia erorilor experimentale faţă de nivelul de semnificaţie impus (Dev5), diferenţa absolută dintre media erorilor experimentale şi valoarea impusă (|5-M|) şi deviaţia standard a erorilor experimentale (StdDev).

După cum se poate observa din tabelul 19, Binomial este metoda care prezintă cea mai apropiată medie şi deviaţiei standard experimentală faţă de valoarea impusă α = 5%; cea mai mică deviaţiei standard experimentală aparţine metodei LogitC.

Tabelul 19. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | Binomial | 0.61 | Binomial | 0.03 | LogitC | 0.60
2 | LogitC | 0.62 | Jeffreys | 0.03 | Binomial | 0.61
3 | ArcSC1 | 0.62 | Bayes | 0.03 | ArcSC1 | 0.62
4 | Jeffreys | 0.65 | BayesF | 0.03 | Jeffreys | 0.65
5 | Bayes | 0.76 | Wilson | 0.06 | CP | 0.72
6 | BayesF | 0.76 | ArcSC1 | 0.08 | AC | 0.73
7 | Wilson | 0.76 | WaldC | 0.12 | Logit | 0.74
8 | AC | 0.76 | LogitC | 0.14 | ArcSC2 | 0.74
9 | Logit | 0.77 | AC | 0.22 | Bayes | 0.76
10 | WaldC | 1.09 | Logit | 0.23 | BayesF | 0.76
11 | CP | 1.16 | ArcS | 0.40 | Wilson | 0.76
12 | ArcSC3 | 1.17 | Wald | 0.72 | ArcSC3 | 0.76
13 | ArcSC2 | 1.18 | ArcSC3 | 0.89 | WilsonC | 0.84
14 | ArcS | 1.30 | CP | 0.90 | WaldC | 1.08
15 | WilsonC | 1.31 | ArcSC2 | 0.91 | ArcS | 1.23
16 | Wald | 1.84 | WilsonC | 1.01 | Wald | 1.69

În tabelul 20, metodele de calcul a intervalului de confidenţă sunt ordonate în funcţie de diferenţa absolută a mediei rezultate din interpolare faţă de nivelul de semnificaţie impus (|5-MInt|),

deviaţia rezultată din interpolarea gaussiană (DevInt), pătratul coeficientului de corelaţie rezultat din interpolare (r2Int), şi parametrul estimatorului statistic Fisher (FInt).

Metoda Agresti-Coull este metoda de calcul a intervalului de confidenţă care prezintă cea mai apropiată medie de interpolare faţă de valoarea impusă α = 5%, fiind urmată de metoda Logit; LogitC (strâns urmat de Binomial) este metoda care prezintă cea mai mică deviaţia standard de interpolare (vezi tabelul 20). Cea mai bună corelaţie între curba teoretică şi valorile experimentale este obţinută de metoda LogitC strâns urmată de metoda Binomial.

Tabelul 20. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | VarInt | Metoda | r2Int | FInt
1 | AC | 0.11 | LogitC | 0.82 | Wald | 0.62 | 31
2 | Logit | 0.13 | Binomial | 0.88 | WilsonC | 0.65 | 36
3 | WaldC | 0.14 | Jeffreys | 0.95 | ArcSC3 | 0.66 | 36
4 | LogitC | 0.20 | WaldC | 0.97 | CP | 0.67 | 38
5 | ArcSC1 | 0.22 | CP | 0.97 | ArcSC2 | 0.68 | 40
6 | Jeffreys | 0.22 | ArcS | 1.02 | WaldC | 0.69 | 42
7 | Bayes | 0.23 | ArcSC3 | 1.08 | Wilson | 0.71 | 47
8 | BayesF | 0.23 | ArcSC1 | 1.08 | ArcS | 0.71 | 47
9 | Wilson | 0.27 | ArcSC2 | 1.11 | AC | 0.71 | 47
10 | Binomial | 0.27 | Wald | 1.25 | Logit | 0.71 | 47
11 | ArcS | 0.38 | AC | 1.26 | Bayes | 0.71 | 47
12 | ArcSC3 | 0.47 | Logit | 1.27 | BayesF | 0.71 | 47
13 | ArcSC2 | 0.48 | Wilson | 1.27 | ArcSC1 | 0.72 | 50
14 | CP | 0.49 | Bayes | 1.29 | Jeffreys | 0.74 | 54
15 | Wald | 0.51 | BayesF | 1.29 | Binomial | 0.75 | 57
16 | WilsonC | 0.60 | WilsonC | 1.33 | LogitC | 0.76 | 59

În tabelul 21 metodele de calcul a intervalului de confidenţă sunt ordonate în funcţie de valoarea suprapunerii dintre curba de distribuţie binomială standard şi curba de inetrpolare (pNIG), suprapunerea dintre curba de distribuţie binomială standard şi curba de distribuţie a erorilor experimentale (pNMV) şi curba de distribuţie binomială standard şi curba de distribuţie a erorilor în jurul nivelului de semnificaţie impus (pN5V).

Tabelul 21. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | LogitC | 0.69 | CP | 0.56 | Binomial | 0.57
2 | Binomial | 0.72 | LogitC | 0.56 | LogitC | 0.58
3 | CP | 0.74 | ArcSC2 | 0.57 | ArcSC1 | 0.58
4 | Jeffreys | 0.75 | Binomial | 0.57 | Jeffreys | 0.60
5 | WaldC | 0.77 | ArcSC1 | 0.57 | Bayes | 0.66
6 | ArcS | 0.77 | ArcSC3 | 0.58 | BayesF | 0.66
7 | ArcSC3 | 0.78 | WilsonC | 0.59 | Wilson | 0.66
8 | ArcSC2 | 0.79 | Jeffreys | 0.60 | AC | 0.66
9 | ArcSC1 | 0.81 | AC | 0.64 | Logit | 0.67
10 | WilsonC | 0.82 | Logit | 0.64 | WaldC | 0.82
11 | Wald | 0.83 | Bayes | 0.66 | CP | 0.85
12 | Wilson | 0.88 | BayesF | 0.66 | ArcSC2 | 0.86
13 | Bayes | 0.88 | Wilson | 0.66 | ArcSC3 | 0.86
14 | BayesF | 0.88 | WaldC | 0.82 | ArcS | 0.90
15 | AC | 0.89 | Wald | 0.82 | WilsonC | 0.91
16 | Logit | 0.89 | ArcS | 0.84 | Wald | 0.93

Analizând tabelul 21 se observă că, metodele Logit şi Agresti-Coull, urmate de Bayes, BayesF şi Wilson sunt metodele de calcul a intervalului de confidenţă care prezintă cea mai bună acoperire între curba de interpolare şi curba de distribuţie binomială standard. Metoda ArcS este metoda care prezintă cea mai bună acoperire între curba de distribuţie în jurul mediei experimentale şi curba de distribuţie standard; metoda Wald obţine cea mai bună acoperire între curba de distribuţie a erorii în jurul mediei impuse (α = 5%) şi de curba de distribuţie binomială standard.

În tabelul 22 este prezentată ordonarea metodelor de calcul a intervalului de confidenţă în funcţie de procentul de suprapunere între curba de interpolare a lui Gauss şi curba lui Gauss a erorilor experimentale în jurul mediei experimentale (pIGMV), curba de interpolare a lui Gauss şi curba lui Gauss a erorilor experimentale în jurul mediei impuse (α = 5%) (pIG5V) şi între curba lui Gauss a erorilor esperimentale şi curba erorilor experimentale în jurul mediei impuse α = 5% (pMV5V).

Metoda WaldC este metoda care obţine cea mai bună acoperire între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale, urmată de metodele ArcS, Wald şi Binomial. Metoda WaldC este metoda care obţine cea mai bună acoperire între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5% (vezi tabelul 22), fiind urmată de ArcS, LogitC, ArcSC2 şi ArcSC3. Metodele Bayes şi BayesF sunt metodele la care se observă cea mai bună acoperire curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%.

Tabelul 22. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | WaldC | 0.95 | WaldC | 0.93 | Bayes | 0.99
2 | ArcS | 0.91 | ArcS | 0.84 | BayesF | 0.99
3 | Wald | 0.85 | LogitC | 0.83 | Binomial | 0.98
4 | Binomial | 0.79 | ArcSC2 | 0.83 | Jeffreys | 0.98
5 | Jeffreys | 0.79 | ArcSC3 | 0.83 | Wilson | 0.97
6 | LogitC | 0.77 | WilsonC | 0.82 | WaldC | 0.96
7 | CP | 0.77 | CP | 0.81 | ArcSC1 | 0.95
8 | ArcSC3 | 0.77 | Jeffreys | 0.80 | LogitC | 0.91
9 | ArcSC2 | 0.75 | Wald | 0.78 | AC | 0.88
10 | Wilson | 0.75 | Binomial | 0.78 | Logit | 0.88
11 | WilsonC | 0.75 | Logit | 0.76 | ArcS | 0.87
12 | Bayes | 0.73 | AC | 0.76 | Wald | 0.83
13 | BayesF | 0.73 | Wilson | 0.74 | ArcSC3 | 0.61
14 | AC | 0.72 | Bayes | 0.74 | WilsonC | 0.60
15 | Logit | 0.72 | BayesF | 0.74 | ArcSC2 | 0.60
16 | ArcSC1 | 0.71 | ArcSC1 | 0.73 | CP | 0.59

Concluzii

În urma execuţiei seturilor de experimente pentru cele 15 metode cel mai frecvent raportate în literatura de specialitate s-au propus cele mai bune metode de calcul a intervalului de confidenţă bazat pe valorile experimentale ale mediilor şi deviaţiile standard ale erorilor produse de acestea.

Analizând exclusiv cele 15 metode preluate din literatura de specialitate, aşa cum se relevă din studiul experimental, metoda Logit şi corecţia metoda Jeffreys sunt cele mai conservative în ceea ce priveşte deviaţia standard a erorilor în aproximarea intervalului de confidenţă impus de pragul α (în experiment s-a folosit α = 5%). Astfel, dacă se doreşte o metodă care să asigure o deviaţie standard cât mai mică în funcţie de n sau X, una dintre aceste două metode trebuie aleasă.

Mai mult, de notat că media erorilor se situează totdeauna sub pragul α pentru metoda Logit şi începând cu n ≈ 30 media erorilor pentru metoda LogitC se situează totdeauna peste pragul α.

Dacă criteriul deviaţie standard nu este singurul considerat şi se doreşte şi o cât mai bună apropiere de pragul impus al erorilor α (α = 5% în experiment), atunci metoda BayesF are câştig de cauză, cumulând cele mai bune performanţe în medie pe intervalul studiat, 4 ≤ n ≤ 300.

Cele mai bune trei metode preluate din literatura de specialitate şi testate în funcţie de n sunt prezentate sumar în tabelul 23.

Tabelul 23. Cele mai bune trei metode de calcul a intervalului de confidenţă

raportate în literatura de specialitate ordonate după performanţă

n | Metoda
4-10 | Wilson, LogitC, BayesF
11-30 | LogitC, BayesF, Wilson
31-100 | LogitC, BayesF, Wilson
101-300 | BayesF, LogitC, Wilson

Dacă se consideră metoda propusă Binomial, aceasta produce sistematic cele mai bune rezultate aşa cum rezultă şi din tabelul 18 şi din figura 20 pentru volume de eşantioane n ≥ 67.

În ceea ce priveşte eşantioanele aleatoare (X, n aleatoare în intervalul 4..1000) putem spune că:

· Binomial este metoda care obţine cea mai apropiată medie şi deviaţiei standard experimentală faţă de valoarea impusă α = 5%; cea mai mică deviaţiei standard experimentală aparţine metodei LogitC, urmată de Binomial;

· Metoda Agresti-Coull este metoda de calcul a intervalului de confidenţă care prezintă cea mai apropiată medie de interpolare faţă de valoarea impusă α = 5%, fiind urmată de metoda Logit;

· LogitC (strâns urmat de Binomial) este metoda care obţine cea mai mică deviaţia standard de interpolare;

· Cea mai bună corelaţie între curba teoretică şi valorile experimentale este obţinută de metoda LogitC strâns urmată de metoda Binomial;

· Metoda WaldC este metoda care obţine cea mai bună acoperire între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale, urmată de metodele ArcS, Wald şi Binomial;

· Metoda WaldC este metoda care obţine cea mai bună acoperire între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5% (vezi tabelul 22), fiind urmată de ArcS, LogitC, ArcSC2 şi ArcSC3.

· Metodele Bayes şi BayesF sunt metodele la care se observă cea mai bună acoperire curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%.

Pentru eşantioanele aleatoare (X, n aleatoare în intervalul 4..1000) putem spune că metoda originală Binomial obţine cele mai bune performanţe în estimarea intervalului de confidenţă pentru funcţia ci1.

Referinţe

[1] . Rice virtual Lab in Statistics. online cited 2005 August, 13 Available from: http://www.ruf.rice.edu/~lane/stat_sim/binom_demo.html

[2] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 2. Proportion-like Medical Key Parameters. Leonardo Electronic Journal of Practices and Technologies 2003;3:75-110.

[3] Rosner B. Hypothesis Testing: Categorical Data. In: Fundamentals of Biostatistics. Forth Edition. Duxbury Press. Belmont. 1995. p: 345-442.

[4] Newcombe RG. Two-sided confidence intervals for the single proportion; comparison of several methods. Statistics in Medicine. 1998;17:857–872.

[5] Pires MA. Confidence intervals for a binomial proportion: comparison of methods and software evaluation. online cited 2005 August, 11 Available from: http://www.math.ist.utl.pt/~apires/AP_COMPSTAT02.pdf

[6] Brown DL, Cai TT, DasGupta A. Interval estimasion for a binomial proportion. Statistical Science.2001;16:101-133

[7] Harte D. Non Asymptotic Binomial Confidence Intervals. online cited 2005 August, 16 Available from: http://www.statsresearch.co.nz/pdf/confint.pdf

[8] Agresti A. Dealing with discretness: making ‘exact’ confidence intervals for proportions, differences of proportions, and odds ratios more exact. Statistical Methods in Medical Research 2003;12:3-21.

[9] Blyth CR, Still HA. Binomial confidence intervals. J Amer Statist Assoc 1983;78:108-116.

[10] Casella G, Berger RL. Statistical Inference. Wadsworth&Brooks/Cole, Belmont, CA. 1990.

[11] Intervalle de confiance de Blyth et Still de niveau 95% pour une proportion p. online cited 2005 August, 16 Availafle from: http://www.mat.ulaval.ca/pages/belisle/STT-16569/Blyth-Still-04.pdf


Intervale de confidenţă pentru funcţia ci2

Funcţia ci2 are următoarea expresie:

Calcularea intervalelor de confidenţă pentru ci2 s-a realizat pe baza metodelor de calcul descrise în secţiunea anterioară şi prezentată în lucrarea [i] .

Calcularea intervalelor de confidenţă pentru metodele implementate

În figura 22 sunt reprezentate valorile intervalelor de confidenţă pentru X/(n-X) aşa cum rezultă din formulele de calcul pentru Wilson, Logit, LogitC, BayesF, Jeffreys şi Binomial.

Liniile de program corespunzătoare acestei alegeri sunt:

$c_i=array( "Wilson" , "Logit" , "LogitC" , "BayesF" , "Jeffreys" , "Binomial" );

define("z",1.96); define("a",0.05);

define("N_min",10);define("N_max",11); est_ci_er(z,a,$c_i,"R","ci2","ci");

Figura 22. Intervale inferioare de confidenţă ale funcţiei ci2 ( X/(n-X); (1 ≤ X ≤ n/2))

la n = 10 (logaritmul limitei inferioare în funcţie de X)

Dacă se variază n în domeniul 4 - 103 se obţin suprafeţe de nivel a valorii funcţiei X/(n-X) şi respectiv intervalelor sale de confidenţă. În figura 23 sunt redate suprafeţele de nivel pentru valoarea funcţiei şi a intervalelor de confidenţă calculate folosind o metodă binomială expusă la sfârşitul secţiunii anterioare rezervate proporţiilor. Cu culoarea roşu este reprezentată valoarea 0, cu galben valoarea 0.5 şi cu albastru valoarea 1. Valorile intermediare dintre acestea au fost reprezentate folosind 18 nuanţe intermediare (câte 9 pentru fiecare combinaţie de culori).

Figura 23. Suprafeţe de nivel pentru ci2 şi intervalele sale de confidenţă

(calculate printr-o metoda binomială)

Valorile superioare ale intervalului de confidenţă sunt imaginea în oglindă faţă de funcţia f(X) = X/(n-X) ale valorilor inferioare ale sale pe domeniul de valori 0..n. Pentru a putea alege dintre aceste metode una sau mai multe metode capabile de estimări cât mai performante, în continuare se vor analiza erorile de estimare a intervalului de confidenţă pentru fiecare metodă considerată, folosind ipoteza distribuţiei binomiale, ca metodă de apreciere atât sub aspect calitativ cât şi sub aspect cantitativ a metodelor.

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru acelaşi prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define("z",1.96); define("a",0.05); în codul sursă al programului implementat).

Primul set de experimente a constat în compararea metodelor în ceea ce priveşte erorile experimentale produse de acestea pentru valori reprezentative ale lui n din intervalul 10..1000 şi anume n = 10, n = 50, n = 100, n = 300 şi n = 1000. Rezultatele execuţiei experimentului au fost importate în Excel, unde s-au realizat diagrame de dependenţă a procentului de erori în funcţie de valoarea lui X pentru diferite valori ale lui n.

Pentru n = 10, eşecurile procentuale în funcţie de valoarea lui X ( 0 < X < n) pentru fiecare metodă sunt reprezentate în figura 24.

Figura 24. Procentul erorilor experimentale pentru ci2 la n = 10 în funcţie de X (0 < X < n)

Secvenţa de program care calculează aceste erori este:

$c_i=array("LogitC", "BayesF", "Wilson" , "Logit" , "Jeffreys" , "Binomial" );

define("N_min",10); define("N_max",11); est_ci_er(z,a,$c_i,"R","ci2","er");

Secvenţa de program pentru calculul erorilor la n = 50 devine:

$c_i=array("LogitC", "BayesF", "Wilson" , "Logit" , "Jeffreys" , "Binomial" );

define("N_min",50); define("N_max",51); est_ci_er(z,a,$c_i,"R","ci2","er");

şi rezultatele sunt redate în figura 25.

Figura 25. Procentul erorilor experimentale pentru ci2 la n = 50 în funcţie de X ( 0 < X < n)

În graficele reprezentate în figura 25 se observă că procentele de erori produse de metoda Logit sunt sistematic situate sub valoarea pragului impus α = 5%, având o medie a erorilor de 1.8%. Mai mult, mediile erorilor pentru Jeffreys şi respectiv pentru Binomial sunt de 3.8%, cu toate că deviaţiile standard ale metodei Binomial sunt cele mai mici.

Erorile produse la n = 100 sunt calculate cu secvenţa de program:

$c_i=array("LogitC", "BayesF", "Wilson" , "Logit" , "Jeffreys" , "Binomial" );

define("N_min",100);define("N_max",101); est_ci_er(z,a,$c_i,"R","ci2","er");

şi sunt redate în figura 26.

Analizând graficele din figura 26 se poate observa că estimarea erorilor intervalului de confidenţă cu Logit şi Jeffreys, pentru valori ale lui X apropiate de 0 şi respectiv 100 sunt semnificativ mai mici faţă de valoarea impusă de 5%. La valori extreme ale lui X celelalte metode de calcul a intervalului de confidenţă (Wilson, Logit, BayesF, Binomial) produc erori de estimare superioare valorii impuse de α = 5%.

Figura 26. Procentul erorilor experimentale pentru ci2 la n = 100 în funcţie de X ( 0 < X < n)

Procedând la calculul erorilor de estimare la n = 300 secvenţa de program devine:

$c_i=array( "Wilson" , "ArcSC1" , "AC" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" );

define("N_min",300);define("N_max",301); est_ci_er(z,a,$c_i,"R","ci2","er");

şi reprezentările grafice sunt redate în figura 27.

Analizând graficele din figura 27, nu se poate spune dacă există sau nu o diferenţă semnificativă în estimarea erorilor de calcul a intervalelor de confidenţă pentru metodele luate în studiu. Se poate însă observa oscilaţia sistematică a erorilor experimentale de estimare a intervalelor de confidenţă calculate prin metodele Binomial şi respectiv Jeffreys.

Figura 27. Procentul erorilor experimentale pentru ci2 la n = 300 în funcţie de X ( 0 < X < n)

Valorile mediei ale erorilor şi deviaţiile standard (paranteze) experimentale pentru valorile alese ale lui n sunt redate în tabelul 24.

Tabelul 24. Medii ale erorilor experiemntale şi deviaţii standard pentru n = 10, 50, 100, 300 şi 1000

n | LogitC | BayesF | Wilson | Binomial | Logit | Jeffreys
10 | 4.22 (2.45) | 4.22 (2.45) | 4.22 (2.45) | 3.84 (2.17) | 1.81 (0.90) | 3.84 (2.17)
50 | 4.94 (1.13) | 5.13 (1.31) | 5.13 (1.31) | 4.88 (1.12) | 4.35 (1.23) | 5.03 (1.47)
100 | 5.20 (0.81) | 5.05 (0.91) | 5.05 (0.98) | 4.96 (0.80) | 4.69 (0.93) | 4.96 (1.03)
300 | 5.03 (0.73) | 4.99 (0.75) | 4.98 (0.76) | 5.00 (0.65) | 4.85 (0.74) | 5.02 (0.79)
1000 | 5.01 (0.44) | 5.00 (0.43) | 4.98 (0.45) | 5.00 (0.37) | 4.92 (0.45) | 5.01 (0.46)

Medie erorilor experiemntale cea mai apropoată de valoaera expectată pentru n = 50 se obţine cu metoda Jeffreys (5.0) iar cea mai mică deviaţie standard cu metoda LogitC urmată de Binomial. Se poate observa însă faptul că metoda Binomial obţine cele mai bune performanţe (medica erorilor cea mai apropiată de valoarea impusă şi cea mai mică deviaţie standard) pentru 100 ≤ n ≤ 1000.

Al doilea set de experimente a constat în calcularea mediei şi deviaţiei standard a erorilor pe întreg intervalul 4..100 al lui n. În tabelul 25 sunt redate valorile acestui experiment. Se poate observa că cele mai bune performanţe sunt obţinute de metodele LogitC şi Binomial.

Tabelul 25. Medii ale erorilor experimentale şi deviaţii standard pentru n = 4..100

Metoda | Wilson | Logit | LogitC | BayesF | Jeffreys | Binomial
Media erorilor medii | 4.7 | 4.2 | 4.8 | 4.7 | 4.6 | 4.5
Deviaţia standard | 1.5 | 1.3 | 1.4 | 1.5 | 1.5 | 1.3

În al treilea set de experimente s-a calculat şi reprezentat harta de nivel a erorilor pentru fiecare metodă considerată în această secţiune. Programul de estimare a erorilor s-a modificat corespunzător alegerii lui n = 4 – 103 şi includerii tuturor metodelor astfel:

$c_i=array( "Wald" , "WaldC" , "Wilson" , "WilsonC" , "ArcS" , "ArcSC1" , "ArcSC2" , "ArcSC3" ,

"AC" , "CP" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" , "Binomial" );

define("N_min",4);define("N_max",103);est_ci_er(z,a,$c_i,"R","ci2","er");

Pe harta de nivel s-au reprezentat erorile de la 0% (Roşu) la Galben (5%) şi Albastru (10% şi peste) folosind 18 de nuanţe intermediare (figura 28). Valorile lui n (de la 4 la 103) formează axa verticală iar valorile lui X (de la 0 la n) formează axa orizontală.

Figura 28. Suprafeţe de nivel al erorilor experimentale pentru ci2 la 4 < n < 103

Folosind funcţia Var(M,n) := ∑0<k<n(Err(M,n,k)-5)2/(n-3), unde M este metoda folosită, ca expresie calitativă a unei metode de calcul a intervalului de confidenţă, pentru n = 4..103 se obţin rezultatele din figura 29 unde este reprezentat frecvenţa absolută a celor mai bune variaţii faţă de valoarea impusă a erorii.

Figura 29. Cele mai bune deviaţii faţă de valoarea impusă (α = 5%)

a erorilor experimentale pentru ci2 la n = 4..103

Analiza diagramei din figura 29 relevă o serie de aspecte. Prima observaţie este că metoda LogitC este metoda cu cele mai bune performanţe urmată de metoda originală Binomial, care îmbunătăţeşte net metodele BayesF şi Jeffreys chiar dacă la limită ea cade peste acestea (vezi funcţia Binomial):

,

O a doua observaţie este că obţine net cele mai bune performanţe dintre metodele binomiale (cu 35 de apariţii, urmată de Jeffreys cu 8 şi în urma lui LogitC cu 61).

A treia observaţie (care nu rezidă din figura 29) este că pentru n > 85 este aproape întotdeauna metoda cu cea mai bună variaţie.

Pentru a valida ipoteza emisă că pentru n ≥ 85 metoda Binomial are aproape întotdeauna cea mai bună variaţie, s-au calculat variaţiile faţă de 5 pentru 6 valori ale lui n. Rezultatele sunt prezentate în tabelul 26.

Tabelul 26. Cele mai bune deviaţii faţă de valoarea impusă (α = 5%) pentru ci2 la n = 104..109

n | Binomial | LogitC | Jeffreys | BayesF
104 | 0.89 | 0.88 | 1.09 | 1.03
105 | 0.82 | 0.88 | 1.04 | 1.02
106 | 0.83 | 0.88 | 1.04 | 1.02
107 | 0.82 | 0.87 | 1.03 | 1.01
108 | 0.81 | 0.86 | 1.02 | 1.01
109 | 0.81 | 0.88 | 1.01 | 1.00

Într-adevăr, datele din tabelul 26 confirmă ipoteza emisă anterior că metoda Binomial produce cele mai mici variaţii ale erorilor faţă de valoarea impusă α = 5%. Notabil este şi faptul că variaţia erorilor metodei Binomial este de cele mai multe ori mult inferioară variaţiilor produse de celelalte metode (vezi tabelul 26).

Eşantioane aleatoare

Pentru a urmării comportarea erorilor de estimare a intervalelor de confidenţă în calcularea intervalelor de confidenţă pentru proporţii s-au estimat erorile şi deviaţiile standard experimentale pentru valori ale lui X şi n aleatoare. Experimentul a fost rulat pentru toate metodele discutate. În figura 30 cu puncte sunt reprezentate frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)). Rezultatele experiemntului sunt redate în tabelele 27 - 30.

Figura 30. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi X, n aleatoare în intervalul 4..1000

În tabelul 27 sunt prezentate metodele de calcul a intervalului de confidenţă ordonate după deviaţia erorilor experimentale faţă de nivelul de semnificaţie impus (Dev5), diferenţa absolută dintre media erorilor experimentale şi valoarea impusă (|5-M|) şi deviaţia standard a erorilor experimentale (StdDev).

După cum se poate observa din tabelul 27, metoda ArcS obţine cea mai bună deviaţie standard experimentală faţă de valoarea impusă α = 5%, urmată de metodele ArcSC1, Binomial şi LogitC; metoda Clopper-Pearson obţine cea mai bună diferenţă a mediei experimentale faţă de media impusă de 5, iar deviaţia standard experimentală cea mai mică este obţinută de metoda LogitC şi Binomial.

Tabelul 27. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | ArcS | 0.55 | CP | 0.02 | LogitC | 0.60
2 | ArcSC1 | 0.55 | WilsonC | 0.05 | Binomial | 0.61
3 | Binomial | 0.56 | Bayes | 0.07 | ArcSC1 | 0.62
4 | LogitC | 0.63 | Logit | 0.08 | Jeffreys | 0.65
5 | Jeffreys | 0.64 | ArcSC3 | 0.08 | CP | 0.72
6 | Bayes | 0.69 | Wald | 0.08 | AC | 0.73
7 | BayesF | 0.73 | Wilson | 0.10 | Logit | 0.74
8 | Wilson | 0.75 | WaldC | 0.11 | ArcSC2 | 0.74
9 | Logit | 0.80 | AC | 0.30 | Bayes | 0.76
10 | AC | 0.86 | ArcS | 0.31 | BayesF | 0.76
11 | ArcSC2 | 0.96 | Jeffreys | 0.43 | Wilson | 0.76
12 | WilsonC | 1.06 | BayesF | 0.60 | ArcSC3 | 0.76
13 | WaldC | 1.08 | ArcSC2 | 0.72 | WilsonC | 0.83
14 | CP | 1.15 | Binomial | 0.82 | WaldC | 1.08
15 | ArcSC3 | 1.27 | ArcSC1 | 0.92 | ArcS | 1.23
16 | Wald | 1.93 | LogitC | 0.96 | Wald | 1.69

În tabelul 28, metodele de calcul a intervalului de confidenţă sunt ordonate în funcţie de diferenţa absolută a mediei rezultate din interpolare faţă de nivelul de semnificaţie impus (|5-MInt|),

deviaţia rezultată din interpolarea gaussiană (DevInt), pătratul coeficientului de corelaţie rezultat din interpolare (r2Int), şi parametrul estimatorului statistic Fisher (FInt).

Metoda Logit prezintă media de interpolare cea mai apropiată de valoarea impusă de α = 5%; Binomial este metoda care prezintă cea mai mică deviaţie standard de interpolare şi corelaţia cea mai bună între curba teoretică şi valorile experimentale (vezi tabelul 28).

Tabelul 28. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | Logit | 0.09 | Binomial | 0.72 | ArcSC3 | 0.64 | 35
2 | AC | 0.10 | ArcS | 0.79 | CP | 0.64 | 35
3 | BayesF | 0.13 | Jeffreys | 0.79 | WilsonC | 0.69 | 43
4 | Wilson | 0.14 | ArcSC1 | 0.83 | Wald | 0.69 | 43
5 | Bayes | 0.14 | WaldC | 0.84 | Logit | 0.71 | 47
6 | WaldC | 0.18 | ArcSC2 | 0.85 | Wilson | 0.72 | 48
7 | LogitC | 0.22 | LogitC | 0.85 | BayesF | 0.72 | 49
8 | Binomial | 0.25 | BayesF | 0.99 | AC | 0.72 | 50
9 | ArcSC1 | 0.28 | Bayes | 1.00 | Bayes | 0.72 | 50
10 | Jeffreys | 0.30 | AC | 1.03 | ArcSC2 | 0.73 | 51
11 | ArcSC2 | 0.33 | Wald | 1.03 | Jeffreys | 0.73 | 51
12 | ArcS | 0.35 | WilsonC | 1.04 | LogitC | 0.74 | 54
13 | WilsonC | 0.43 | Logit | 1.06 | WaldC | 0.74 | 55
14 | Wald | 0.45 | Wilson | 1.08 | ArcSC1 | 0.75 | 56
15 | ArcSC3 | 0.54 | CP | 1.17 | ArcS | 0.75 | 57
16 | CP | 0.54 | ArcSC3 | 1.21 | Binomial | 0.75 | 58

În tabelul 29 metodele de calcul a intervalului de confidenţă sunt ordonate în funcţie de valoarea suprapunerii dintre curba de distribuţie binomială standard şi curba de inetrpolare (pNIG), suprapunerea dintre curba de distribuţie binomială standard şi curba de distribuţie a erorilor experimentale (pNMV) şi curba de distribuţie binomială standard şi curba de distribuţie a erorilor în jurul nivelului de semnificaţie impus (pN5V).

Tabelul 29. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | Binomial | 0.63 | ArcS | 0.52 | ArcS | 0.53
2 | Jeffreys | 0.65 | ArcSC1 | 0.53 | ArcSC1 | 0.53
3 | ArcS | 0.66 | Binomial | 0.54 | Binomial | 0.54
4 | ArcSC1 | 0.69 | CP | 0.54 | LogitC | 0.58
5 | WaldC | 0.70 | WilsonC | 0.54 | Jeffreys | 0.59
6 | LogitC | 0.70 | ArcSC2 | 0.54 | Bayes | 0.62
7 | ArcSC2 | 0.71 | LogitC | 0.58 | BayesF | 0.65
8 | Wald | 0.77 | Jeffreys | 0.58 | Wilson | 0.65
9 | WilsonC | 0.77 | ArcSC3 | 0.59 | Logit | 0.68
10 | BayesF | 0.78 | Bayes | 0.62 | AC | 0.71
11 | Bayes | 0.78 | Logit | 0.63 | ArcSC2 | 0.77
12 | AC | 0.80 | BayesF | 0.64 | WilsonC | 0.81
13 | CP | 0.80 | Wilson | 0.65 | WaldC | 0.82
14 | Logit | 0.81 | AC | 0.67 | CP | 0.85
15 | ArcSC3 | 0.81 | WaldC | 0.69 | ArcSC3 | 0.89
16 | Wilson | 0.81 | Wald | 0.88 | Wald | 0.90

Analizând tabelul 29 se observă că, cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de interpolare este obţinută de metoda Wilson; metoda Wald obţine cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a eroii în jurul mediei experimentale, şi cea mai bună suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a erorii în jurul mediei impuse (α = 5%). Metoda Jeffreys prezintă cea mai mare suprapunere între curba de interpolare standard şi curba de distribuţie a erorii în jurul mediei experimentale, fiind urmată de metoda LogitC.

În tabelul 30 este prezentată ordonarea metodelor de calcul a intervalului de confidenţă în funcţie de procentul de suprapunere între curba de interpolare a lui Gauss şi curba lui Gauss a erorilor experimentale în jurul mediei experimentale (pIGMV), curba de interpolare a lui Gauss şi curba lui Gauss a erorilor experimentale în jurul mediei impuse (α = 5%) (pIG5V) şi între curba lui Gauss a erorilor esperimentale şi curba erorilor experimentale în jurul mediei impuse α = 5% (pMV5V).

Metoda Agresti-Coull este metoda care obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale, urmată de metodele Logit şi WaldC. Metoda ArcSC1 este metoda care obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%, urmată de metodele Bayes şi Binomial (vezi tabelul 30).

Tabelul 30. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | Jeffreys | 0.86 | AC | 0.90 | ArcSC1 | 0.99
2 | LogitC | 0.83 | WaldC | 0.86 | Binomial | 0.96
3 | BayesF | 0.82 | Logit | 0.86 | Bayes | 0.96
4 | WaldC | 0.81 | ArcSC2 | 0.85 | LogitC | 0.95
5 | Bayes | 0.80 | BayesF | 0.84 | Jeffreys | 0.95
6 | Wilson | 0.80 | WilsonC | 0.84 | Wilson | 0.95
7 | AC | 0.80 | ArcSC3 | 0.83 | ArcS | 0.94
8 | Binomial | 0.79 | Jeffreys | 0.82 | BayesF | 0.94
9 | ArcS | 0.77 | CP | 0.82 | Wald | 0.90
10 | ArcSC1 | 0.77 | LogitC | 0.82 | AC | 0.85
11 | ArcSC2 | 0.76 | Wilson | 0.82 | Logit | 0.83
12 | ArcSC3 | 0.76 | Binomial | 0.82 | WaldC | 0.75
13 | Logit | 0.76 | Bayes | 0.81 | ArcSC2 | 0.63
14 | WilsonC | 0.73 | ArcSC1 | 0.76 | ArcSC3 | 0.61
15 | Wald | 0.72 | ArcS | 0.74 | WilsonC | 0.60
16 | CP | 0.71 | Wald | 0.69 | CP | 0.57

Concluzii

Analizând metode de calcul a intervalului de confidenţă pentru funcţia ci2 (X/(n-X)), aşa cum se relevă din studiul experimental, metodele Logit (pentru n = 10) şi LogitC (pentru n = 50) sunt cele mai conservative în ceea ce priveşte deviaţiile standard ale erorilor în aproximarea intervalului de confidenţă impus de pragul α (în experiment s-a folosit α = 5%). Sistematic, pentru 100 ≤ n ≤ 1000, metoda Binomial devine cea mai conservativă în ceea ce priveşte deviaţiile standard ale erorilor în aproximarea intervalului de confidenţă. Astfel, dacă se doreşte o metodă care să asigure o variaţie cât mai mică în funcţie de n sau X, una dintre metodele menţionate trebuie aleasă.

Mai mult, de notat că media erorilor se situează totdeauna sub pragul α pentru metoda Logit. Pentru 50 ≤ n ≤ 1000, sistematic, metoda Binomial este cea mai bună metodă de calcul a intervalului de confidenţă, atât în ceea ce priveşte media erorilor de estimare cât şi apropierea erorilor experimentale de pragul α impus (α = 5%).

Cele mai bune trei metode în funcţie de n sunt prezentate sumar sunt:

· LogitC, BayesF, Wilson pentru n = 10;

· LogitC, Binomial, BayesF, Wilson pentru n = 50;

· Binomial, BayesF, Wilson pentru n = 100;

· Binomial, LogitC, BayesF pentru n = 300;

· Binomial, BayesF, LogitC pentru n = 1000.

În cazul eşantioanelor aleatorii (X, n aleatorii) putem spune că:

· Metoda ArcS obţine cea mai bună deviaţie standard faţă de valoarea impusă α = 5%, urmată de metodele ArcSC1, Binomial şi LogitC;

· Metoda Clopper-Pearson obţine cea mai bună diferenţă a mediei experimentale faţă de media impusă de α = 5%;

· Cea mai mică deviaţie standard experimentală este obţinută de metoda LogitC şi Binomial;

· Metoda Logit prezintă media de interpolare cea mai apropiată de valoarea impusă de α = 5%;

· Binomial este metoda care obţine cea mai mică deviaţia standard de interpolare şi corelaţia cea mai bună între curba teoretică şi valorile experimentale;

· Cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de interpolare este obţinută de metoda Wilson;

· Metoda Wald obţine cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a eroii în jurul mediei experimentale, şi cea mai bună suprapunere între curba de distribuţie binomială standard şi curba de distribiţie a erorii în jurul mediei impuse (α = 5%);

· Metoda Jeffreys obţine cea mai mare suprapunere între curba de interpolare standard şi curba de distribuţie a erorii în jurul mediei experimentale, fiind urmată de metoda LogitC;

· Metoda Agresti-Coull este metoda care obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale, urmată de metodele Logit şi WaldC.

· Metoda ArcSC1 este metoda care obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%, urmată de metodele Bayes şi Binomial

Alegerea metodei de calcul a intervalului de confidenţă pentru funcţia ci2 se face în funcţie de obiectivul dorit. Dacă dorim să obţinem o medie a erorilor experimentale cât mai apropiată de valoarea impusă de 5% metoda de calcul a intervalelor de confidenţă care îndeplineşte această condiţie este Clopper-Pearson. Dacă dorim un interval e confidenţă care să prezinte cea mai mică deviaţie standard atunci alegem metoda LogitC sau Binomial.

Referinţe

[i] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 3. Post and Pre Test Odds. Leonardo Journal of Sciences 2003;3:24-46.


Intervale de confidenţă pentru funcţia ci3

Funcţia ci3(X, n) = f(X) = X/(2X-n) prezintă un punct de variaţie asimptotică la ±∞ pentru n par şi X = n/2. Reprezentarea grafică a acestei funcţii pentru n = 20 este redată în figura 31, unde X s-a considerat variabilă continuă.

Figura 31. Reprezentarea dependenţei pentru variaţia continuă a lui X a funcţiei ci3 pentru n = 20

Calcularea intervalelor de confidenţă pentru funcţia ci3

Intervalele de confidenţă pentru funcţia ci3 (vezi [i] ) se bazează pe formulele şi funcţiile corespunzătoare acestora descrise în secţiunea destinată funcţiei ci1.

Dacă se variază n în domeniul 4 – 103 se obţin suprafeţe de nivel a valorii diferenţei dintre două proporţii şi respectiv intervalelor sale de confidenţă. În figura 32 sunt reprezentate suprafeţele de nivel pentru valoarea funcţiei şi a intervalelor de confidenţă.

În figura 32, cu culoarea roşu sunt reprezentate valorile mai mici sau egale cu -10, cu galben valoarea 0 şi cu albastru valorile mai mari sau egale cu 10. Valorile intermediare dintre acestea au fost reprezentate folosind 252 nuanţe intermediare. Valorile infinite sau pentru care funcţia nu este definită sunt marcate cu alb.

În figura 33 sunt reprezentate valorile intervalelor de confidenţă pentru funcţia ci3 (X/(2X-n)) la n = 20 aşa cum rezultă din formulele de calcul pentru Wilson, Logit, LogitC, BayesF, Jeffreys şi Binomial. Liniile de program corespunzătoare acestei alegeri sunt:

$c_i=array( "Wilson" , "Logit" , "LogitC" , "BayesF" , "Jeffreys" , "Binomial" );

define("N_min",20);define("N_max",21); est_ci_er(z,a,$c_i,"RD","ci3","ci");

Figura 32. Suprafeţe de nivel pentru valoarea funcţiei ci3 şi a intervalelor sale de confidenţă (calculate printr-o metoda binomială)

Figura 33. Intervalele inferioare de confidenţă ale funcţiei ci3 (15≤X≤19) la n = 20

Pentru a putea alege dintre aceste metode una sau mai multe metode capabile de estimări cât mai performante, în continuare se vor analiza erorile de estimare a intervalului de confidenţă pentru fiecare metodă considerată, folosind ipoteza distribuţiei binomiale, ca metodă de apreciere atât sub aspect calitativ cât şi sub aspect cantitativ a metodelor.

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru acelaşi prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define('z',1.96); define('a',0.05); în codul sursă al programului implementat).

Primul set de experimente a constat în compararea metodelor în ceea ce priveşte erorile experimentale produse de acestea pentru valori reprezentative ale lui n din intervalul 10..1000 şi anume n = 20, n = 50, n = 100, n = 300 şi n = 1000. Rezultatele execuţiei experimentului au fost importate în Excel, unde s-au realizat diagrame de dependenţă a procentului de erori în funcţie de valoarea lui X pentru diferite valori ale lui n. Pentru n = 20, eşecurile procentuale în funcţie de valoarea lui X ( 0 < X < n) pentru fiecare metodă sunt reprezentate în figura 34.

Figura 34. Procentul erorilor experimentale pentru ci3 la n = 20 în funcţie de X (0 < X < n)

Secvenţa de program care calculează aceste erorile pentru n = 20 este:

$c_i=array("LogitC", "BayesF", "Wilson" , "Logit" , "Jeffreys" , "Binomial" );

define("N_min",20);
define("N_max",21);
est_ci_er(z,a,$c_i,"RD","ci","er");

Pentru un volum al eşantionului egal cu 20 se poate observa din figura 34 că, sistematic metodele Logit, Jeffreys şi Binomial determină frecvenţe ale mediilor erorilor de estimare mai nici de 5%.

Secvenţa de program pentru calculul erorilor la n = 50 devine:

$c_i=array("Wilson" , "Logit" , "LogitC", "BayesF", "Jeffreys" , "Binomial" );

define("N_min",50);
define("N_max",51);
est_ci_er(z,a,$c_i,"RD","ci3","er");

şi rezultatele sunt redate în figura 35.

Figura 35. Procentul erorilor experimentale pentru ci3 la n = 50 în funcţie de X (0 < X < n)

În graficele reprezentate în figura 35 se observă că mediile procentelor erorilor produse de toate metodele (Wilson, Logit, LogitC, BayesF, Jeffreys şi Binomial) prezintă valoarea 0% pentru X = n/2±1. La extremităţi (pentru X aproape de 0 şi respectiv X aproape de n), metodele Wilson, LogitC şi BayesF produc erori peste 5%. La polul opus se găsesc metodele Logit, Jeffreys şi Binomial, care pentru valorile lui X expuse anterior produc erori de estimare mai mici de 5%.

Erorile produse la n = 100 sunt calculate cu secvenţa de program:

$c_i=array("Wilson" , "Logit" , "LogitC", "BayesF", "Jeffreys" , "Binomial" );

define("N_min",100);
define("N_max",101);
est_ci_er(z,a,$c_i,"RD","ci3","er");

şi sunt redate în figura 36.

Figura 36. Procentul erorilor experimentale pentru ci3 la n = 100 în funcţie de X (0 < X < n)

Procedând la calculul erorilor de estimare la n = 300 secvenţa de program devine:

$c_i=array("Wilson" , "Logit" , "LogitC", "BayesF", "Jeffreys" , "Binomial" );

define("N_min",300);define("N_max",301);est_ci_er(z,a,$c_i,"RD","ci3","er");

şi rezultatele sunt redate în figura 37.

Figura 37. Procentul erorilor experimentale pentru ci3 la n = 300 în funcţie de X (0 < X < n)

Valorile mediei erorilor şi deviaţiilor standard pentru valorile alese ale lui n sunt redate în tabelul 31.

Tabelul 31. Medii ale erorilor experimentale şi deviaţii standard experimentale (paranteze)

pentru ci3 la n = 4..1000

n | LogitC | BayesF | Wilson | Binomial | Logit | Jeffreys
20 | 2.15 (2.19) | 2.37 (2.10) | 2.37 (2.10) | 2.03 (1.13) | 1.52 (1.11) | 2.58 (1.24)
50 | 3.25 (2.19) | 3.44 (1.79) | 3.44 (1.79) | 3.19 (1.44) | 2.77 (1.37) | 3.43 (1.76)
100 | 3.95 (1.88) | 3.80 (1.83) | 3.80 (1.84) | 3.72 (1.63) | 3.44 (1.59) | 3.76 (1.80)
300 | 4.27 (1.64) | 4.18 (1.54) | 4.17 (1.54) | 4.19 (1.50) | 4.06 (1.49) | 4.22 (1.54)
1000 | 4.53 (1.37) | 4.50 (1.34) | 4.48 (1.34) | 4.49 (1.32) | 4.43 (1.33) | 4.51 (1.35)

Al doilea set de experimente a constat în calcularea mediei şi deviaţiei standard a erorilor pe întreg intervalul 4..103 al lui n. Rezultatele sunt redate în tabelul 32. De remarcat faptul că performanţele cele mai bune sunt obţinute de metodele Binomial şi Wilson dacă luăm în considerare deviaţia standard cea mai bună şi respectiv LogitC dacă luăm în considerare media cea mai bună.

Tabelul 32. Medii ale erorilor experiemntale şi deviaţiilor standard

experimentale pentru ci3 la 4 ≤ n < 104

Metoda | Wilson | Logit | LogitC | BayesF | Jeffreys | Binomial
Media | 3.5 | 3.1 | 3.6 | 3.5 | 3.5 | 3.3
Deviaţia standard | 2.96 | 3.27 | 3.24 | 3.00 | 2.93 | 2.89

În al treilea set de experimente s-a calculat şi reprezentat harta de nivel a erorilor pentru fiecare metodă considerată în această secţiune.

Programul de estimare a erorilor s-a modificat corespunzător alegerii lui n = 4 – 103 şi includerii tuturor metodelor astfel:

$c_i=array( "Wald" , "WaldC" , "Wilson" , "WilsonC" , "ArcS" , "ArcSC1" , "ArcSC2" , "ArcSC3" ,

"AC" , "CP" , "Logit" , "LogitC" , "Bayes" , "BayesF" , "Jeffreys" , "Binomial" );

define("N_min",4); define
("N_max",103);
est_ci_er(z,a,$c_i,"RD","ci3","er");

Pe harta de nivel s-au reprezentat erorile de la 0% (Roşu) la Galben (5%) şi Albastru (10% şi peste) folosind 18 de nuanţe intermediare. Valorile lui n (de la 4 la 103) formează axa verticală iar valorile lui X (de la 0 la n) formează axa orizontală (figura 38).

Figura 38. Suprafeţe de nivel a erorilor experimentale pentru ci3 la 4 < n < 103

Folosind funcţia Var(M,n) := ∑0<k<n(Err(M,n,k)-5)2/(n-3), unde M este metoda folosită, ca expresie calitativă a unei metode de calcul a intervalului de confidenţă, pentru n = 4..103 se obţin rezultatele din figura 39 unde este reprezentat numărul celor mai bune deviaţii standard faţă de valoarea impusă a erorii α = 5%:

Figura 39. Cele mai bune deviaţii ale erorilor experimentale faţă de valoarea impusă a erorilor

α = 5% pentru ci3 la n = 4..103

Analiza diagramei din figura 39 relevă o serie de aspecte.

Prima observaţie este că metoda originală Binomial îmbunătăţeşte net metodele Jeffreys şi BayesF chiar dacă la limită ea cade peste acestea (vezi funcţia Binomial):

,

O a doua observaţie este că obţine net cele mai bune performanţe dintre metodele binomiale (cu 70 de apariţii, urmată de Jeffreys cu 25 şi BayesF cu 7).

A treia observaţie (care nu rezidă din fig. 3.45) este că pentru n > 36 este aproape întotdeauna metoda cu cea mai bună deviaţie standard, având un singur eşec la n = 41 în favoarea metodei Jeffreys şi întotdeauna metoda cu cea mai bună deviaţie standard de la n = 42.

Pentru a valida ipoteza emisă că pentru n ≥ 36 metoda Binomial are aproape întotdeauna cea mai bună deviaţie standard, s-au calculat deviaţiile standard faţă de α = 5% pentru următoarele 6 valori ale lui n. Rezultatele sunt date în tabelul 33.

Tabelul 33. Cele mai bune deviaţii faţă de valoarea impusă pentru ci3 la n = 104..109

n | Binomial | LogitC | Jeffreys | BayesF
104 | 2.01 | 2.29 | 2.12 | 2.15
105 | 2.05 | 2.31 | 2.16 | 2.20
106 | 2.03 | 2.30 | 2.13 | 2.22
107 | 2.05 | 2.30 | 2.15 | 2.24
108 | 2.03 | 2.28 | 2.14 | 2.20
109 | 2.06 | 2.29 | 2.16 | 2.22

Într-adevăr, datele din tabelul 33 confirmă ipoteza emisă anterior că metoda Binomial produce cele mai mici deviaţii standard ale erorilor experimentale faţă de valoarea impusă α = 5%. Notabil este şi faptul că deviaţia standard a erorilor metodei Binomial este mult inferioară deviaţiei standard produse de celelalte metode (vezi tabelul 33).

Eşantioane aleatoare

Pentru a urmării comportarea erorilor de estimare a intervalelor de confidenţă în calcularea intervalelor de confidenţă pentru proporţii s-au estimat erorile şi variaţiile experimentale pentru valori ale lui X şi n aleatoare. Experimentul a fost rulat pentru toate metodele discutate. În figura 40 cu puncte sunt reprezentate frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)). Rezultatele experimentului sunt în tabelele 34 - 37.

Figura 40. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, n în intervalul 4..1000

După cum se poate observa din tabelul 34, metoda Binomial obţine cea mai bună deviaţie standard experimentală faţă de valoarea impusă α = 5%, urmată de metoda BayesF, Wilson şi respectiv Bayes. Metoda WaldC obţine cea mai mică diferenţă a mediei erorilor faţă de media impusă de α = 5%, urmată de metoda ArcS. Metoda care obţine cea mai mică deviaţie standard experimentală este metoda Clopper-Pearson urmată de WislonC.

Tabelul 34. Ordonare metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | Binomial | 1.48 | WaldC | 0.17 | CP | 1.22
2 | BayesF | 1.54 | ArcS | 0.40 | WilsonC | 1.26
3 | Wilson | 1.54 | Bayes | 0.50 | ArcSC3 | 1.27
4 | Bayes | 1.55 | Wilson | 0.54 | ArcSC2 | 1.28
5 | ArcSC1 | 1.56 | BayesF | 0.55 | Binomial | 1.36
6 | Logit | 1.57 | LogitC | 0.57 | Logit | 1.36
7 | Jeffreys | 1.57 | Binomial | 0.59 | AC | 1.36
8 | LogitC | 1.57 | Wald | 0.60 | ArcSC1 | 1.41
9 | AC | 1.61 | Jeffreys | 0.64 | Jeffreys | 1.44
10 | CP | 1.84 | ArcSC1 | 0.65 | BayesF | 1.44
11 | ArcSC2 | 1.88 | Logit | 0.78 | Wilson | 1.45
12 | ArcSC3 | 1.89 | AC | 0.84 | LogitC | 1.47
13 | WilsonC | 1.90 | ArcSC2 | 1.37 | Bayes | 1.47
14 | WaldC | 4.77 | CP | 1.37 | WaldC | 4.76
15 | ArcS | 5.00 | ArcSC3 | 1.39 | Wald | 4.98
16 | Wald | 5.02 | WilsonC | 1.41 | ArcS | 4.98

Logit este metoda care obţine cea mai mică deviaţie a mediei de interpolare faţă de valoarea impusă α = 5% iar WaldC urmată de Binomial sunt metodele care prezintă cele mai mici deviaţii standard de interpolare (vezi tabelul 35).

Tabelul 35. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | Logit | 0.02 | WaldC | 1.22 | ArcSC2 | 0.56 | 24
2 | LogitC | 0.04 | Binomial | 1.23 | Wald | 0.58 | 27
3 | AC | 0.06 | LogitC | 1.27 | Jeffreys | 0.60 | 28
4 | ArcSC1 | 0.10 | ArcSC1 | 1.32 | CP | 0.60 | 29
5 | Jeffreys | 0.10 | Jeffreys | 1.32 | ArcSC3 | 0.60 | 29
6 | BayesF | 0.12 | ArcS | 1.35 | Binomial | 0.60 | 29
7 | Bayes | 0.14 | Wald | 1.36 | LogitC | 0.61 | 29
8 | Binomial | 0.14 | AC | 1.46 | ArcS | 0.61 | 29
9 | Wilson | 0.15 | Logit | 1.46 | WaldC | 0.61 | 29
10 | Wald | 0.26 | Bayes | 1.46 | ArcSC1 | 0.61 | 29
11 | WaldC | 0.27 | BayesF | 1.46 | WilsonC | 0.61 | 30
12 | ArcS | 0.28 | ArcSC2 | 1.47 | Bayes | 0.64 | 34
13 | WilsonC | 0.63 | CP | 1.48 | BayesF | 0.65 | 35
14 | ArcSC2 | 0.63 | Wilson | 1.49 | Wilson | 0.65 | 35
15 | ArcSC3 | 0.63 | ArcSC3 | 1.51 | AC | 0.66 | 37
16 | CP | 0.65 | WilsonC | 1.52 | Logit | 0.66 | 38

Logit şi Agresti-Coull sunt metodele care obţin cele mai bune corelaţii între curbele teoretice şi valorile experimentale.

Metodele Logit, Bayes şi Agresti-Coull obţin cea mai mare suprapunere între curba de distribuţie standard şi curba de interpolare.

Tabelul 36. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | CP | 0.83 | Wald | 0.49 | Wald | 0.49
2 | ArcSC2 | 0.83 | ArcS | 0.50 | ArcS | 0.50
3 | ArcSC3 | 0.84 | WaldC | 0.51 | WaldC | 0.51
4 | WilsonC | 0.84 | CP | 0.61 | WilsonC | 0.91
5 | WaldC | 0.86 | WilsonC | 0.61 | ArcSC3 | 0.91
6 | Binomial | 0.88 | ArcSC3 | 0.62 | ArcSC2 | 0.92
7 | LogitC | 0.89 | ArcSC2 | 0.63 | CP | 0.93
8 | ArcS | 0.90 | AC | 0.77 | Binomial | 0.97
9 | Wald | 0.90 | Logit | 0.78 | Wilson | 0.99
10 | ArcSC1 | 0.91 | ArcSC1 | 0.82 | Bayes | 0.99
11 | Jeffreys | 0.91 | Jeffreys | 0.83 | BayesF | 0.99
12 | BayesF | 0.95 | Binomial | 0.83 | Jeffreys | 0.99
13 | Wilson | 0.95 | LogitC | 0.85 | ArcSC1 | 0.99
14 | AC | 0.96 | BayesF | 0.85 | AC | 0.99
15 | Bayes | 0.96 | Wilson | 0.85 | Logit | 1.00
16 | Logit | 0.96 | Bayes | 0.87 | LogitC | 1.00

Tabelul 37. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | Bayes | 0.83 | Logit | 0.97 | Bayes | 0.87
2 | BayesF | 0.82 | BayesF | 0.96 | Wilson | 0.85
3 | LogitC | 0.82 | Wilson | 0.96 | BayesF | 0.85
4 | Wilson | 0.82 | Bayes | 0.95 | LogitC | 0.85
5 | Jeffreys | 0.79 | AC | 0.95 | Binomial | 0.83
6 | Logit | 0.79 | ArcSC1 | 0.92 | Jeffreys | 0.83
7 | ArcSC2 | 0.78 | Jeffreys | 0.91 | ArcSC1 | 0.82
8 | ArcSC1 | 0.78 | Binomial | 0.90 | Logit | 0.78
9 | AC | 0.78 | LogitC | 0.90 | AC | 0.77
10 | CP | 0.78 | WilsonC | 0.83 | WaldC | 0.70
11 | Binomial | 0.78 | ArcSC3 | 0.83 | ArcS | 0.67
12 | ArcSC3 | 0.77 | CP | 0.82 | Wald | 0.66
13 | WilsonC | 0.77 | ArcSC2 | 0.82 | ArcSC2 | 0.64
14 | Wald | 0.45 | Wald | 0.44 | ArcSC3 | 0.63
15 | ArcS | 0.44 | ArcS | 0.44 | WilsonC | 0.62
16 | WaldC | 0.43 | WaldC | 0.42 | CP | 0.62

Bayes este metoda care obţine cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a erorii în jurul mediei experimentale.

Metoda Bayes obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale şi Logit metoda care obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale.

Cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5% este obţinută de metoda Bayes (vezi tabelul 37).

Concluzii

În urma execuţiei seturilor de experimente pentru cele 15 metode cel mai frecvent raportate în literatura de specialitate s-au propus cele mai bune metode de calcul a intervalului de confidenţă bazat pe valorile experimentale ale mediilor şi deviaţiilor standard ale erorilor produse de acestea.

Analizând exclusiv cele 15 metode preluate din literatura de specialitate, aşa cum se relevă din studiul experimental, metodele Logit şi Jeffreys sunt cele mai conservative în ceea ce priveşte deviaţiile standard ale erorilor în aproximarea intervalului de confidenţă impus de pragul α (în experiment s-a folosit α = 5%). Astfel, dacă se doreşte o metodă care să asigure o variaţie cât mai mică în funcţie de n sau X, una dintre aceste două metode trebuie aleasă.

Mai mult, de notat că media erorilor se situează totdeauna sub pragul α pentru toate metodele de calcul a intervalului de confidenţă, existând o tendinţă de creştere a mediilor erorilor odată cu creşterea volumului eşantionului.

Dacă criteriul de deviaţie standard nu este singurul considerat şi se doreşte şi o cât mai bună apropiere de pragul impus al erorilor α (α = 5% în experiment), atunci pentru 100 ≤ n ≤ 300 metoda LogitC prezintă cele mai bune valori, cumulând cele mai bune performanţe.

Trendul evoluţiei metodei LogitC dovedeşte că acest fapt se petrece şi pentru n > 300, un exemplu în acest sens fiind şi experimentul rulat pentru n = 1000 (în care are cea mai bună performanţă pentru media erorilor (4.53% urmată de BayesF cu 4.50%).

Prima performanţă în ce priveşte deviaţiile standard ale erorilor pentru n = 1000 este a metodei Logit (cu 1.33, urmată de un grup format de BayesF şi Wilson cu 1.34).

Dacă se consideră metoda propusă Binomial, aceasta produce sistematic cele mai bune rezultate aşa cum rezultă şi din tabelul 31 şi din figura 39.

Cele mai bune trei metode în funcţie de n sunt prezentate sumar în tabelul 38.

Tabelul 38. Cele mai bune trei metode raportate în literatură pentru ci3 ordonate după performanţă

n | Metoda
4-62 | Jeffreys, Wilson şi BayesF, LogitC
63-300 | Jeffreys, LogitC, Wilson şi BayesF
300-1000 | BayesF, Jeffreys, Wilson, LogitC

În cazul eşantioanelor aleatorii, alegerea celei mai bune metode de calcul a intervalului de confidenţă este mai dificilă. Cu toate acestea putem spune că:

· Metoda Binomial prezintă cea mai bună deviaţie standard experimentală faţă de valoarea impusă α = 5%, urmată de metoda BayesF, Wilson şi respectiv Bayes.

· Metoda WaldC prezintă cea mai mică diferenţă a mediei erorilor faţă de media impusă de α = 5%, urmată de metoda ArcS;

· Metoda care determină cea mai mică deviaţie standard experimentală este metoda Clopper-Pearson urmată de WislonC;

· Logit este metoda care prezintă cea mai mică deviaţie a mediei de interpolare faţă de valoarea impusă α = 5%;

· WaldC urmată de Binomial sunt metodele care prezintă cele mai mici deviaţii standard de interpolare;

· Logit şi Agresti-Coull sunt metodele care obţin cele mai bune corelaţii între curbele teoretice şi valorile experimentale.

· Metodele Logit şi Agresti-Coull sunt metodele care prezintă cea mai bună corelaţie între curba teoretică şi valorile experimentale;

· Bayes este metoda care determină cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a erorii în jurul mediei experimentale;

· Metodele Logit şi LogitC prezintă cea mai bună suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a erorii în jurul mediei impuse (α = 5%);

· Metoda Bayes determină cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale şi Logit metoda care determină cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale;

· Cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5% este obţinută de metoda Bayes.

[i] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 4. Post Test Probability. Leonardo Journal of Sciences 2003;3:47-70.


Intervale de confidenţă pentru funcţia ci5

Pentru două populaţii binomiale de volume m şi n şi variabile X şi Y se exprimă diferenţa Y/n – X/m prin funcţia ci5:

Metodele de calcul a intervalului de confidenţă folosite (vezi [i] ) sunt:

Metoda DWald este preluată din literatura de specialitate, în timp ce DAC, DAs, DAsC, DBinomial şi DBinomialC sunt metode originale adaptate pentru diferenţa dintre două proporţii.

Metoda DAC se bazează pe termenul de ajustare [image] introdus de Agresti şi Coull pentru expresia intervalului de confidenţă din cazul unidimensional (CI = CI(X,n)).

Metoda DAs foloseşte metoda ArcS din cazul unidimensional, adaptată la cazul bidimensional. Corecţia acestei metode, metoda DAsC foloseşte termenii de ajustare [image] şi respectiv [image], termeni de ajustare deduşi experimental.

Metodele DBinomial şi DBinomialC se bazează pe formulele distribuţiei unidimensională.

Funcţii PHP de calcul a intervalelor de confidenţă

Au fost implementate în PHP următoarele funcţii de calcul a intervalului de confidenţă:

function DWald($X,$m,$Y,$n,$z,$a){

$ad = $Y/$n-$X/$m;

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3),0.5);

$tXi = $ad-$t0; if($tXi<-1) $tXi=-1;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs );

}function EAC($X,$m,$Y,$n,$z,$a){

if($m==$X) return array( 0 , (float)"INF" );

if($Y==0) return array( 0 , (float)"INF" );

$ci = EWald($X+pow($z,2)/4/sqrt(2),$m+pow($z,2)/2/sqrt(2),

$Y+pow($z,2)/4/sqrt(2),$n+pow($z,2)/2/sqrt(2),$z,$a);

return array( $ci0 , $ci1 );}

function DAC($X,$m,$Y,$n,$z,$a){

return DWald($X+pow($z,2)/4/pow(2,0.5),$m+pow($z,2)/2/pow(2,0.5),

$Y+pow($z,2)/4/pow(2,0.5),$n+pow($z,2)/2/pow(2,0.5),$z,$a);}

function DAs($X,$m,$Y,$n,$z,$a){

$ad = $Y/$n-$X/$m;

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3)+asin(pow($ad,0.5))/($m*$n),0.5);

$tXi = $ad-$t0; if($tXi<-1) $tXi=-1;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs ); }

function DAsC($X,$m,$Y,$n,$z,$a){

$ad = $Y/$n-$X/$m;

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3)

+asin(pow($ad,0.5))/($m*$n)/2+0.25/pow($m,3)+0.25/pow($n,3),0.5);

$tXi = $ad-$t0; if($tXi<-1) $tXi=-1;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs ); }

function DBinomial($X,$m,$Y,$n,$z,$a){

return D("Binomial",$X,$m,$Y,$n,$z,pow($a/2,0.5),pow($a/2,0.5));}

function DBinomialC($X,$m,$Y,$n,$z,$a){ return

D("Binomial",$X,$m,$Y,$n,$z,pow($a/2,0.5)/(1-0.125/log($m)),pow($a/2,0.5)/(1-0.125/log($n)));}

Calcularea intervalelor de confidenţă pentru metodele implementate

Reprezentările grafice a intervalelor de confidenţă pentru fiecare metodă de calcul în parte s-a realizat folosind programul Slide cu o perspectivă de 80%, o înclinaţie de 45° şi o rotaţie de 30°. Pe axa X sunt valorile lui X, pe axa Y valorile lui Y iar pe axa Z valorile funcţiei, a limitei superioare şi inferioare a intervalului de confidenţă. Apar în roşu erorile cuprinse în intervalul -1 - -0.6, în verde erorile cuprinse în intervalul -0.6 - -0.2, în albastru erorile cuprinse în intervalul -0.2 - 0.2, în verde marin erorile din intervalul 0.2 - 0.6 şi in violet erorile cuprinse în intervalul 0.6 - 1.

Reprezentarea grafică a intervalelor de confidenţă şi a expresiei Y/n-X/m pentru m = n = 50

este redată în figurile 50 şi 51. Secvenţa de program este:

$c_i=array("DBinomialC","DAC");

define("N_min",50);
define("N_max",51);
est_ci2_er(z,a,$c_i,"ci5","ci");

Figura 50. Reprezentarea tridimensională a dependenţei ci5 şi intervalului său de confidenţă calculat cu metoda DBinomialC şi AC pentru 0 < X, Y < m = n = 50

Figura 51. Reprezentarea capetelor inferior şi superior ale intervalului de confidenţă în funcţie de valoarea funcţiei ci5 pentru 0 < X, Y < m = n = 50

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru un prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define('z',1.96); define('a',0.05); în codul sursă al programului).

Primul set de experimente a constat în compararea metodelor în ceea ce priveşte erorile experimentale produse de acestea pentru următoarele valori ale lui n: n = 5, n = 10, n = 20 şi n = 40.

Pentru n = 5, eşecurile procentuale în funcţie de X şi Y sunt redate în figura 52. Secvenţa de program care calculează erorile pentru n = 5 este:

$c_i=array("DWald","DAC","DAs","DAsC","DBinomial","DBinomialC");

define("N_min",5);
define("N_max",6);
est_ci2_er(z,a,$c_i,"ci5","ci");

Reprezentarea grafică a mediilor erorilor intervalelor de confidenţă pentru fiecare metodă de calcul în parte s-a realizat folosind programul Slide cu o perspectivă de 80%, o înclinaţie de 45° şi o rotaţie de 45°. Pe axa X sunt valorile lui X, pe axa Y valorile lui Y iar pe axa Z valorile erorilor experimentale de estimare. Apar în roşu erorile cuprinse în intervalul 0 - 2%, în verde erorile cuprinse în intervalul 2 - 4%, în albastru erorile cuprinse în intervalul 4 - 6%, în verde marin erorile din intervalul 6 - 8% şi in violet erorile cuprinse în intervalul 8 - 10%.

Figura 52. Erorile experimentale în estimarea intervalului de confidenţă pentru ci5 cu DWald, DAC, DAs, DAsC, DBinomial şi DBinomialC pentru 0 < X, Y < m = n = 5

Mediile erorilor de estimare a intervalelor de confidenţă şi deviaţiile standard ale acestora sunt prezentate în tabelul 49. Se poate observa astfel că, cea mai aproape medie de valoarea impusă de 5% este dată atât de metoda DAs cât şi de metoda DBinomialC, cu deosebirea că, metoda DBinomialC prezintă o deviaţie standard mai bună iar valoarea mediei este inferioară valorii impuse în timp ce valoarea medie a erorilor experimentale prin metoda DAs este superioară valorii impuse de 5%.

Tabelul 49. Valori medii şi deviaţii standard ale erorilor experimentale

în estimarea intervalului de confidenţă pentru ci5 la m = n = 5

Metoda | DWald | DAC | DAs | DAs | DBinomial | DBinomialC
Media | 12.32 | 6.53 | 5.30 | 7.65 | 2.87 | 3.70
Deviaţia standard | 4.13 | 1.99 | 2.30 | 2.37 | 1.36 | 1.69

Secvenţa de program care calculează erorile la n = 10 devine:

$c_i=array("DWald","DAC","DAs","DAsC","DBinomial","DBinomialC");

define("N_min",10);define("N_max",11); est_ci2_er(z,a,$c_i,"ci5","ci");

iar rezultatele sunt redate în figura 53.

Figura 53. Erorile experimentale în estimarea intervalului de confidenţă pentru ci5 cu DWald, DAC, DAs, DAsC, DBinomial şi DBinomialC pentru 0 < X, Y < m = n = 10

Metoda DAC permite estimarea cea mai apropiată de valoarea impusă de 5% a mediilor erorilor experimentale, urmată de metoda DAs, care spre deosebire de precedenta determină o frecvenţă a erorilor de estimare mai mare decât valoarea impusă de α = 5%. Cea mai bună deviaţie standard este obţinută de metodele binomiale (DBinomial şi respectiv DBinomialC).

Tabelul 50. Valori medii şi deviaţiile standard ale erorilor experimentale

în estimarea intervalului de confidenţă pentru ci5 la m = n = 10

Metoda | DWald | DAC | DAs | DAsC | DBinomial | DBinomialC
Media | 8.98 | 4.44 | 5.72 | 6.60 | 3.76 | 3.99
Deviaţia standard | 2.80 | 1.28 | 1.62 | 1.74 | 0.97 | 1.01

Erorile de estimare ale intervalelor de confidenţă pentru n = 20 sunt redate în figura 54 iar secvenţa de program care calculează aceste erori este:

$c_i=array("DWald","DAC","DAs","DAsC","DBinomial","DBinomialC");

define("N_min",20);
define("N_max",21);
est_ci2_er(z,a,$c_i,"ci5","ci");

Figura 54. Erorile experimentale în estimarea intervalului de confidenţă pentru ci5 cu DWald, DAC, DAs, DAsC, DBinomial şi DbinomialC pentru 0 < X, Y < m = n = 20

Mediile şi deviaţiile standard ale erorilor de estimare pentru n = 20 sunt redate în tabelul 51.

Tabelul 51. Valori medii şi deviaţii standard ale erorilor experimentale

în estimarea intervalului de confidenţă pentru ci5 la m = n = 20

Metoda | DWald | DAC | DAs | DAsC | DBinomial | DBinomialC
Media | 7.11 | 4.90 | 5.53 | 6.14 | 4.65 | 4.97
Deviaţia standard | 2.01 | 0.99 | 0.96 | 1.10 | 0.93 | 1.02

Secvenţa de program care calculează erorile la n = 40 devine:

$c_i=array("DWald","DAC","DAs","DAsC","DBinomial","DBinomialC");

define("N_min",40);
define("N_max",41);
est_ci2_er(z,a,$c_i,"ci5","ci");

şi rezultatele sunt redate în figura 55.

Figura 55. Erorile experimentale în estimarea intervalului de confidenţă pentru ci5 cu DWald, DAC, DAs, DAsC, Dbinomial şi DBinomialC pentru 0 < X, Y < m = n = 40

Valorile medii ale erorilor de estimare ale intervalelor de confidenţă şi deviaţiile standard ale acestora sunt redate în tabelul 52. Se poate observa că metoda DBinomial este metoda cu media erorilor cea mai apropiată de cea impusă (5%) iar metodele cu cele mai mai mici deviaţii standard sunt DAC şi respectiv DAs.

Tabelul 52. Valori medii şi deviaţii standard ale erorilor experimentale

în estimarea intervalului de confidenţă pentru m = n = 40

Metoda | DWald | DAC | DAs | DAsC | DBinomial | DBinomialC
Media | 6.06 | 4.88 | 5.30 | 5.62 | 5.04 | 5.29
Deviaţia standard | 1.22 | 0.58 | 0.58 | 0.68 | 0.88 | 0.94

Estimarea intervalelor de confidenţă pentru punctul central X = Y

Variaţia erorilor de estimare a intervalului de confidenţă în punctul central (X = Y) pentru m = n = 2,4..204 (n număr par) este redată în figura 56.

Figura 56. Variaţia erorii de estimare a intervalului de confidenţă pentru ci5

a punctului central X = Y la m = n (m şi n numere pare)

Se poate observa din graficele figurii 56 că cele mai mari erori în estimarea intervalului de confidenţă sunt date de metoda DWald. Această metodă ca şi metoda DAsC prezintă inclusiv valori ale erorilor de estimare mai mari de valoarea 8%. Mediile erorilor experimentale şi a deviaţiile standard ale acestora sunt redate în tabelul 53.

Tabelul 53. Valori medii şi deviaţii standard ale erorilor experimentale în estimarea intervalului de

confidenţă pentru ci5 la punctul central X = Y când m = n (m=n = 4,6..200)

Metoda | DWald | DAC | DAs | DAsC | DBinomial | DBinomialC
Media | 5.67 | 5.13 | 5.29 | 5.38 | 4.73 | 4.95
Deviaţia standard | 1.62 | 0.60 | 0.61 | 0.71 | 0.64 | 0.61

Reprezentarea grafică a dependenţa erorii medii şi a deviaţiilor faţă de valoarea impusă α = 5% pentru DWald, DAC, DAs, DAsC, DBinomial şi DBinomialC la valori ale lui n = 4..14 şi m = 4..14 şi X = Y este redată în figura 3.63.

Pentru graficele dependenţei erorii medii faţă de valoarea impusă (graficele din stânga), cu roşu s-a reprezentat valorile din intervalul 0 − 2%, cu verde valorile din intervalul 2 − 4%, cu albastru valorile din intervalul 4 − 6%, cu verde marin valorile din intervalul 6 − 8% iar cu violet valorile din intervalul 8 − 10%. Pentru graficele dependenţei variaţiei mediei deviaţiei standard a erorilor experimentale faţă de valoarea impusă (α = 5%) (graficele din dreapta), cu roşu s-a reprezentat valorile din intervalul 1 − 2%, cu verde valorile din intervalul 2 − 3%, cu albastru valorile din intervalul 3 − 4%, cu verde marin valorile din intervalul 4 − 5%, cu violet valorile din intervalul 5 − 6%, cu galben valorile din intervalul 5 − 6%, cu gri valorile din intervalul 5 − 6%, şi cu portocaliu valorile din intervalul 5 − 6%. Graficele au fost realizate cu o perspectivă de 80%, o înclinaţie de 30° şi o rotaţie de 45°.

Figura 57. Dependenţa erorii medii şi deviaţiile standard faţă de valoarea impusă α=5% pentru ci5 cu DWald, DAC, DAs şi DAsC, DBinomial şi DBinomialC la valori ale lui m=4..14 şi n=4..14

Mediile erorilor de estimare şi mediile deviaţiilor standard ale acestora pentru punctul central X = Y sunt redate în tabelul 54. Se poate observa că metoda DAC este metoda care permite o estimare cât mai aproape de valoarea impusă de 5% a mediei erorilor în timp ce metoda DBinomialC prezintă cea mai bună deviaţie standard.

Tabelul 54. Mediile erorilor şi ale deviaţiilor standard experimentale în estimarea intervalului de

confidenţă pentru ci5 când volumele eşantioanelor m şi n variază în domeniul 4..14

Metoda | DWald | DAC | DAs | DAsC | DBinomial | DBinomialC
Medii ale mediilor | 12.20 | 4.66 | 7.07 | 8.29 | 3.87 | 4.34
Medii ale deviaţiilor standard | 8.18 | 1.62 | 3.64 | 4.28 | 1.73 | 1.59

Eşantioane aleatoare

Experimentul de evaluare a intervalelor de confidenţă a continuat cu determinarea erorilor de estimare pentru valori ale lui X, m, Y, n aleatoare. Experimentul a fost rulat doar pentru metodele DWald, DWaldC, DAC, DAs şi DAsC (vezi figura 58). În figura 58 cu puncte sunt reprezentate frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)).

Figura 58. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, m, Y, n aleatorii în intervalul 4..1000

Nu au fost incluse în acest experiment metodele binomiale deoarece pentru rularea programelor de estimare a erorilor aveam nevoie de resurse de care nu am dispus. Rezultatele experimentului sunt prezentate în tabelele 55-58.

Metoda DAC este metoda de calcul a intervalului de confidenţă care obţine cea mai mică deviaţie standard experimentală faţă de valoarea impusă de α = 5%, cea mai mică deviaţiei standard experimentală (tabelul 55), şi cea mai apropiată medie experimentală faţă de valoarea impusă de α = 5% .

Tabelul 55. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | DAC | 0.32 | DAC | 0.05 | DAC | 0.32
2 | DAs | 0.87 | DAs | 0.23 | DAs | 0.84
3 | DAsC | 0.89 | DAsC | 0.27 | DWaldC | 0.84
4 | DWaldC | 0.90 | DWaldC | 0.30 | DAsC | 0.85
5 | DWald | 0.90 | DWald | 0.30 | DWald | 0.85

Metoda DAC obţine cea mai mică variaţie a mediei de interpolare faţă de pragul de eroare impus (α = 5%) în timp ce metoda DAWald obţine cea mai bună deviaţie standard de interpolare (vezi tabelul 56). Metoda DAC prezintă cea mai bună corelaţie între curba teoretică şi valorile experimentale.

Tabelul 56. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | DAC | 0.17 | DWald | 0.45 | DAs | 0.77 | 64
2 | DAs | 0.37 | DWaldC | 0.45 | DAsC | 0.78 | 66
3 | DWald | 0.45 | DAsC | 0.46 | DWald | 0.78 | 68
4 | DWaldC | 0.45 | DAs | 0.58 | DWaldC | 0.78 | 68
5 | DAsC | 0.45 | DAC | 0.59 | DAC | 0.79 | 71

Analizând tabelul 57 se observă că, metoda DAC obţine cea mai mică suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a eroii în jurul mediei experimentale şi respectiv cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a eroii în jurul mediei impuse (α = 5%). Cea mai mare suprapunere între curba de distribuţie binomială şi curba de interpolare este obţinută de metoda DAC.

Tabelul 57. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | DWald | 0.45 | DAC | 0.35 | DAC | 0.36
2 | DWaldC | 0.45 | DAs | 0.69 | DAs | 0.72
3 | DAsC | 0.46 | DWaldC | 0.70 | DAsC | 0.73
4 | DAs | 0.54 | DWald | 0.70 | DWald | 0.73
5 | DAC | 0.55 | DAsC | 0.70 | DWaldC | 0.73

Metoda DAs obţine cea mai mare suprapunere între curba de interpolare standard şi curba de distribuţie a erorii în jurul mediei experimentale şi respectiv între curba Gauss de interpolare şi respectiv între curba de interpolare standard şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5% . Metoda DAC obţine cea mai mare suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%.

Tabelul 58. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | DAs | 0.81 | DAs | 0.73 | DAC | 0.94
2 | DAsC | 0.71 | DAC | 0.67 | DAs | 0.89
3 | DWaldC | 0.70 | DAsC | 0.63 | DAsC | 0.87
4 | DWald | 0.70 | DWald | 0.61 | DWaldC | 0.86
5 | DAC | 0.67 | DWaldC | 0.61 | DWald | 0.73

Concluzii

Analizând cele 6 metode de calcul a intervalului de confidenţă implementate, aşa cum se observă din datele experimentale, metodele DBinomial şi respectiv DBinomialC sunt metodele cu cele mai bune aglomerări ale valorilor erorilor experimentale pentru m = n = 5, 10, 20 (pentru 20 doar metoda DBinomial prezintă deviaţia standard cea mai mică) pentru ca metodele DAC şi DAs să-şi revendice această poziţie la m = n = 40. Media erorilor se situează sistematic pentru metodele DWald, ADs şi DAsC peste valoarea de 5% impusă. De remarcat faptul că, media erorilor experimentale ale metodelor DBinomial şi DBinomialC sunt sub valoarea impusă de 5% la m = n = 5, 10, 20 pentru a depăşi valoarea impusă la m = n = 40. Metoda DAC porneşte de la o valoare a erorilor de estimare de 6.53% la m = n = 5 pentru ca începând cu m = n =10 valoarea medie a erorilor de estimare să fie sistematic sub valoarea impusă de 5% dar foarte aproape de aceasta.

Estimările cele mai bune al intervalului de confidenţă pentru punctul central X = Y sunt date de metodele DAC şi DBinomialC atât în ceea ce priveşte media erorilor de estimare cât şi în ceea ce priveşte cea mai bună apropiere a erorilor experimentale.

În ceea ce priveşte cea mai bună metodă de estimare a intervalului de confidenţă pentru X, m, Y, n aleatorii putem spune că:

· Metoda DAC este metoda de calcul a intervalului de confidenţă care obţine cea mai mică deviaţie standard experimentală faţă de valoarea impusă de α = 5%, cea mai mică deviaţiei standard experimentală, şi cea mai apropiată medie experimentală faţă de valoarea impusă de α = 5% ;

· Metoda DAC obţine cea mai mică variaţie a mediei de interpolare faţă de pragul de eroare impus (α = 5%) în timp ce metoda DAWald obţine cea mai bună deviaţie standard de interpolare;

· Metoda DAC prezintă cea mai bună corelaţie între curba teoretică şi valorile experimentale;

· Metoda DAC obţine cea mai mică suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a eroii în jurul mediei experimentale şi respectiv cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a eroii în jurul mediei impuse (α = 5%);

· Cea mai mare suprapunere între curba de distribuţie binomială şi curba de interpolare este obţinută de metoda DAC;

· Metoda DAs obţine cea mai mare suprapunere între curba de interpolare standard şi curba de distribuţie a erorii în jurul mediei experimentale şi respectiv între curba Gauss de interpolare şi respectiv între curba de interpolare standard şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%;

· Metoda DAC obţine cea mai mare suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%;

Putem spune că metoda DAC obţine cele mai bune performanţe în calcularea intervalului de confidenţă pentru ci5. Acesta nu exclude însă posilitatea ca metodele binomiale să se comporta mai bine în această situaţie, metode care nu au putut fi luate în studiu din cauza resurselor disponibile.

[i] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 6. Excess Risk. Leonardo Electronic Journal of Practices and Technologies 2004;4:1-20.


Intervale de confidenţă pentru funcţia ci6

Pentru două populaţii binomiale de volume m şi n şi variabile X şi Y se exprimă diferenţa absolută prin funcţia ci6:

Metodele de calcul a intervalului de confidenţă folosite (vezi [i] ) sunt:

Funcţiile PHP de calcul a intervalelor de confidenţă

Au fost implementate în PHP următoarele funcţii:

function ADWald($X,$m,$Y,$n,$z,$a){

$ad = abs($X/$m-$Y/$n);

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3),0.5);

$tXi = $ad-$t0; if($tXi<0) $tXi=0;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs );

}

function ADWaldC($X,$m,$Y,$n,$z,$a){

$ad = abs($X/$m-$Y/$n);

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3)+ 0.5/pow($m,3)

+0.5/pow($n,3),0.5);

$tXi = $ad-$t0; if($tXi<0) $tXi=0;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs );

}

function ADAC($X,$m,$Y,$n,$z,$a){

return ADWald($X+pow($z,2)/4/pow(2,0.5),$m+pow($z,2)/2/pow(2,0.5),$Y+pow($z,2)/4/pow(2,0.5),

$n+pow($z,2)/2/pow(2,0.5),$z,$a);

}

function ADAC1($X,$m,$Y,$n,$z,$a){

return ADWald($X+0.5*(1-2*sqrt($X*($m-$X)/pow($m,2))),$m+1*(1-2*sqrt($X*($m-$X)

/pow($m,2))),$Y+0.5*(1-2*sqrt($Y*($n-$Y)/pow($n,2))),$n+

+1*(1-2*sqrt($Y*($n-$Y) /pow($n,2))),$z,$a);

}

function ADAs0($X,$m,$Y,$n,$z,$a){

$ad = abs($X/$m-$Y/$n);

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3)+2*(1+2/pow($m*$n,0.5))

*asin(pow($ad,0.5))/PI/($m*$n),0.5);

$tXi = $ad-$t0; if($tXi<0) $tXi=0;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs );

}

function ADAs1($X,$m,$Y,$n,$z,$a){

$ad = abs($Y/$n-$X/$m);

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3)

+asin(pow($ad,0.5))/($m*$n),0.5);

$tXi = $ad-$t0; if($tXi<-1) $tXi=-1;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs );

}

function ADAs2($X,$m,$Y,$n,$z,$a){

$ad = abs($Y/$n-$X/$m);

$t0 = $z * pow($X*($m-$X)/pow($m,3)+$Y*($n-$Y)/pow($n,3)+asin(pow($ad,0.5))/($m*$n)/2+0.25/pow($m,3)+0.25/pow($n,3),0.5);

$tXi = $ad-$t0; if($tXi<-1) $tXi=-1;

$tXs = $ad+$t0; if($tXs>1) $tXs=1;

return array( $tXi , $tXs );

}

function ADJeffreys($X,$m,$Y,$n,$z,$a){

return AD(D("Jeffreys",$X,$m,$Y,$n,$z,pow($a/2,0.5),pow($a/2,0.5)));

}

function ADJeffreysC($X,$m,$Y,$n,$z,$a){

return AD(D("Jeffreys",$X,$m,$Y,$n,$z,pow($a/2,0.5)/(1-0.125/log($m)), pow($a/2,0.5)/(1-0.125/log($m))));

}

function ADBinomial($X,$m,$Y,$n,$z,$a){

return AD(D("Binomial",$X,$m,$Y,$n,$z,pow($a/2,0.5),pow($a/2,0.5)));

}

function ADBinomialC($X,$m,$Y,$n,$z,$a){

return AD(D("Binomial",$X,$m,$Y,$n,$z,pow($a/2,0.5)/(1-0.125/log($m)),pow($a/2,0.5)/

(1-0.125/log($m))));

}

Calcularea intervalelor de confidenţă pentru metodele implementate

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru acelaşi prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define("z",1.96); define("a",0.05); în codul sursă al programului implementat).

Reprezentările grafice tridimensionale din acest capitol a limitelor intervalelor de confidenţă şi respectiv a mediilor erorilor intervalelor de confidenţă pentru fiecare metodă de calcul în parte s-a realizat folosind programul Slide cu o perspectivă de 80%, o înclinaţie de 45° şi o rotaţie de 30°. Apar în roşu valorile cuprinse în intervalul 0 - 2%, în verde valorile cuprinse în intervalul 2 - 4%, în albastru valorile cuprinse în intervalul 4 - 6%, în verde marin valorile din intervalul 6 - 8% şi in violet valorile cuprinse în intervalul 8 - 10%.

Reprezentarea grafică a intervalelor de confidenţă şi a funcţiei ci6 pentru m = n = 50 este redată în figurile 59 şi 60. Secvenţa de program este:

$c_i=array("ADJeffreysC", "ADAC");

define("N_min",50);define("N_max",51);est_ci2_er(z,a,$c_i,"ci6","ci");

Figura 59. Reprezentarea tridimensională a dependenţei funcţiei ci6 şi intervalului de confidenţă calculat cu metoda ADJefreysC şi ADAC pentru 0 < X, Y < m = n = 50

Figura 60. Reprezentarea capetelor inferior şi superior ale intervalului de confidenţă

în funcţie de valoarea expresiei X(n-Y)/Y(m-X) pentru ADJeffreysC şi ADAC la

0 < X, Y < m = n = 50

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru un prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define("z",1.96); define("a",0.05); în codul sursă al programului).

Reprezentarea grafică a frecvenţei erorilor de calcul a intervalelor de confidenţă pentru n = 10 este redată în figura 61 iar secvenţa de program care permite calculul acestora este:

$c_i=array("ADAC","ADAC1","ADWald","ADAs0","ADAs1","ADAs2","ADJeffreys",

"ADJeffreyC","ADBinomial","ADBinomialC");

define("N_min",10);
define("N_max",11);
est_ci2_er(z,a,$c_i,"ci6","er");

Valorile medii ale erorilor experimentale şi a deviaţiile standard ale acestora pentru fiecare metodă în parte şi respectiv pentru un volum al eşantionului de 10 sunt redate în tabelul 59.

Tabelul 59. Erori medii experimentale şi deviaţii standard în estimarea

intervalului de confidenţă cu ci6 pentru m = n = 10

Metoda | ADAC | ADAC1 | ADWald | ADAs0 | ADAs1
Media (deviaţia standard) | 5 (1.36) | 4.63 (1.95) | 7.00 (3.60) | 4.24 (1.40) | 4.24 (1.40)
Metoda | ADAs2 | ADJeffreys | ADJeffreysC | ADBinomial | ADBinomialC
Media (deviaţia standard) | 5.13 (1.99) | 3.78 (1.95) | 4.29 (2.20) | 2.43 (1.58) | 2.53 (1.59)

Figura 61. Erorile experimentale în estimarea intervalului de confidenţă pentru ci6 cu ADAC, ADAC1, ADWald, ADAs0, ADAs1, ADAs2, ADJeffreys, ADJeffreysC, ADBinomial şi ADBinomialC pentru 0 < X, Y < m = n = 10

Pentru calcularea erorilor la n = 20 s-a folosit următoarea secvenţă de program:

$c_i=array("ADAC","ADAC1","ADWald","ADAs0","ADAs1","ADAs2","ADJeffreys",

"ADJeffreysC","ADBinomial","ADBinomialC");

define("N_min",20);
define("N_max",21);
est_ci2_er(z,a,$c_i,"ci6","er");

iar reprezentarea grafică a acestor erori este redată în figura 62. Mediilor erorilor şi a deviaţiilor standard ale acestora pentru fiecare metodă în parte sunt redate în tabelul 60.

Tabelul 60. Medii ale erorilor experimentale şi deviaţii standard pentru ci6 la m = n = 20

Metoda | ADAC | ADAC1 | ADWald | ADAs0 | ADAs1
Media (deviaţia standard) | 3.75 (1.38) | 4.35 (1.77) | 5.74 (2.60) | 4.71 (1.45) | 4.36 (1.44)
Metoda | ADAs2 | ADJeffreys | ADJeffreysC | ADBinomial | ADBinomialC
Media (deviaţia standard) | 4.95 (1.68) | 4.44 (1.72) | 4.72 (1.72) | 3.60 (1.61) | 3.87 (1.65)

Figura 62. Erorile experimentale în estimarea intervalului de confidenţă pentru ci6 cu ADAC, ADAC1, ADWald, ADAs0, ADAs1, ADAs2, ADJeffreys, ADJeffreysC, ADBinomial şi ADBinomialC la 0 < X, Y < m = n = 20

Reprezentarea grafică a frecvenţei erorilor de calcul a intervalelor de confidenţă pentru n = 30 este redată în figura 63 iar secvenţa de program care permite calculul acestora este:

$c_i=array("ADAC","ADAC1","ADWald","ADAs0","ADAs1","ADAs2","ADJeffreys",

"ADJeffreysC","ADBinomial","ADBinomialC");

define("N_min",30);
define("N_max",31);
est_ci2_er(z,a,$c_i,"ci6","er");

Mediile erorilor şi a deviaţiilor standard ale acestora sunt redate în tabelul 61.

Tabelul 61. Erori experiemntale medii şi deviaţii standard pentru ci6 la m = n = 30

Metoda | ADAC | ADAC1 | ADWald | ADAs0 | ADAs1
Medii (deviaţii) | 5.28 (2.04) | 4.42 (1.45) | 5.28 (2.04) | 3.84 (1.37) | 4.62 (1.40)
Metoda | ADAs2 | ADJeffreys | ADJeffreysC | ADBinomial | ADBinomialC
Medii (deviaţii) | 4.41 (1.37) | 4.74 (1.48) | 4.47 (1.73) | 4.84 (1.84) | 3.98 (1.63)

Figura 63 (continuare) Erorile experimentale în estimarea intervalului de confidenţă penrtu ci6 cu ADAC, ADAC1, ADWald, ADAs0, ADAs1, ADAs2, ADJeffreys, ADJeffreys, ADJeffreysC, ADBinomial şi ADBinomialC pentru 0 < X, Y < m = n = 30

Estimarea intervalelor de confidenţă pentru punctul central X = Y

Variaţia erorilor de estimare a intervalului de confidenţă în punctul central (X = Y) pentru m = n = 2,4..204 (m, n număr par) este redată în figura 64 iar valorile mediilor erorilor şi deviaţiile standard de estimare sunt redate în tabelul 62.

Tabelul 62. Medii ale erorilor experimentale şi deviaţii standard în estimarea intervalului de confidenţă pentru punctul central X = Y când m = n (m=n=2,4..200)

Metoda | ADAC | ADAC1 | ADWald | ADAs0 | ADAs1
Medii (deviaţii) | 5.14 (0.60) | 5.53 (1.07) | 5.67 (1.61) | 5.31 (0.60) | 5.29 (0.61)
Metoda | ADAs2 | ADJeffreys | ADJeffreysC | ADBinomial | ADBinomialC
Medii (deviaţii) | 5.38 (0.71) | 4.76 (0.65) | 4.98 (0.61) | 4.73 (0.64) | 4.95 (0.61)

Figura 64. Variaţia erorilor de estimare a intervalului de confidenţă pentru ci6 pentru punctul central X = Y pentru m = n (şi n par)

Pentru punctul central, cea mai bună metodă de estimare a intervalului de confidenţă atât din punct de vedere al mediei cât şi al variaţiei este dat de metoda ADBinomialC urmată de metoda ADAC.

Reprezentarea grafică a dependenţa erorii medii şi a deviaţiei faţă de valoarea impusă α = 5% pentru ADAC, ADAC1, ADAs0, ADAs1, ADAs2, ADJeffreys, ADJeffreysC, ADBinomial şi ADBinomialC la valori ale lui n = 4..14 şi m = 4..14 şi X = Y este redată în figura 65.

Figura 65. Dependenţa erorii medii şi a deviaţiei standard fată de valoarea impusă pentru ci6 la valori ale lui n = 4..14 şi m = 4..14 (ADAC, ADAC1, ADAs0, ADAs, ADAs2, ADJeffreys, ADJeffreysC, ADBinomial, ADBinomialC)

Pentru graficele dependenţei erorii medii faţă de valoarea impusă (graficele din stânga), cu roşu s-a reprezentat valorile din intervalul 0 − 2%, cu verde valorile din intervalul 2 − 4%, cu albastru valorile din intervalul 4 − 6%, cu verde marin valorile din intervalul 6 − 8% iar cu violet valorile din intervalul 8 − 10%. Pentru graficele dependenţei variaţiei mediilor deviaţiilor standard ale erorii faţă de valoarea impusă (graficele din dreapta), cu roşu s-a reprezentat valorile din intervalul 1 − 2%, cu verde valorile din intervalul 2 − 3%, cu albastru valorile din intervalul 3 − 4%, cu verde marin valorile din intervalul 4 − 5%, cu violet valorile din intervalul 5 − 6%, cu galben valorile din intervalul 5 − 6%, cu gri valorile din intervalul 5 − 6%, şi cu portocaliu valorile din intervalul 5 − 6%. Graficele au fost realizate cu o perspectivă de 80%, o înclinaţie de 30° şi o rotaţie de 45°.

După cum se observă atât în reprezentările grafice din figura 3.71 cât şi în datele din tabelul 63 rezultatele cele mai bune sunt obţinute de către metoda ADAs1.

Tabelul 63. Medii ale erorilor experimentale şi deviaţia faţă de valoarea impusă în estimarea

intervalului de confidenţă pentru ci6 când volumele eşantioanelor m şi n variază în domeniul 4..14

Metoda |  | ADAC | ADAC1 | ADAs0 | ADAs1
Media (deviaţia faţă de α = 5) |  | 2.79 (2.58) | 2.27 (2.58) | 5.43 (2.58) | 4.89 (2.41)
Metoda | ADAs2 | ADJeffreys | ADJeffreysC | ADBinomial | ADBinomialC
Media (deviaţia faţă de α = 5) | 5.95 (2.73) | 3.72 (2.34) | 4.18 (2.23) | 2.29 (3.19) | 2.61 (3.00)

Eşantioane aleatoare

Experimentul de evaluare a intervalelor de confidenţă a continuat cu determinarea erorilor de estimare pentru valori ale lui X, m, Y, n aleatoare, valori obţinute prin randomizare. Experimentul a fost rulat doar pentru metodele ADWald, ADWaldC, DAC, DAC1, ADAs0, ADAs1 şi ADAs3.

În figura 66 cu puncte sunt reprezentate frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)).

Figura 66. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, m, Y, n în intervalul 4..1000

Nu au fost incluse în acest experiment metodele binomiale deoarece pentru rularea programelor de estimare a erorilor aveam nevoie de resurse de care nu am dispus. Rezultatele experimentului sunt prezentate în tabelele 64 - 67.

Metoda ADAC este metoda de calcul a intervalului de confidenţă care obţine cea mai mică deviaţie standard experimentală faţă de valoarea impusă de α = 5%, urmată de metoda ADAC1 (tabelul 64). Metoda ADAC1 obţine cea mai apropiată medie de media expectată (α = 5%) şi cea mai mică deviaţie standard experimentală, urmată în ambele situaţii de metoda ADAC.

Tabelul 64. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | ADAC | 0.75 | ADAC1 | 0.12 | ADAC1 | 0.79
2 | ADAC1 | 0.79 | ADAC | 0.28 | ADAC | 0.80
3 | ADAs2 | 3.35 | ADAs1 | 0.31 | ADAs1 | 3.36
4 | ADAs1 | 3.35 | ADAs0 | 0.33 | ADAs0 | 3.37
5 | ADAs0 | 3.35 | ADAs2 | 0.34 | ADAs2 | 3.37
6 | ADWaldC | 3.37 | ADWaldC | 0.39 | ADWaldC | 3.39
7 | ADWald | 3.37 | ADWald | 0.39 | ADWald | 3.39

Metoda ADAC obţine cea mai apropiată medie de interpolare faţă de medial expectată (α = 5%) în timp ce metoda ADAs1 obţine cea mai bună deviaţie standard de interpolare. Metodele ADAC şi ADAC1 obţin cele mai bune corelaţii între curba teoretică şi valorile experimentale.

Tabelul 65. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | ADAC | 0.18 | ADWald | 0.72 | ADAs0 | 0.66 | 37
2 | ADAC1 | 0.37 | ADWaldC | 0.72 | ADAs2 | 0.66 | 37
3 | ADAs1 | 0.37 | ADAC1 | 0.80 | ADWald | 0.67 | 39
4 | ADAs0 | 0.42 | ADAC | 0.80 | ADWaldC | 0.67 | 39
5 | ADAs2 | 0.43 | ADAs2 | 0.83 | ADAs1 | 0.67 | 39
6 | ADWald | 0.48 | ADAs0 | 0.87 | ADAC | 0.70 | 45
7 | ADWaldC | 0.48 | ADAs1 | 0.95 | ADAC1 | 0.70 | 45

Analizând tabelul 66 se observă că, observăm că metodele ADWald şi ADWaldC obţin cele mai slabe acorperiri între curba de distribuţie binomială standard şi curba de interpolare.

Tabelul 66. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | ADWald | 0.61 | ADWald | 0.65 | ADWald | 0.65
2 | ADWaldC | 0.61 | ADWaldC | 0.65 | ADWaldC | 0.65
3 | ADAC1 | 0.67 | ADAC | 0.65 | ADAs0 | 0.65
4 | ADAC | 0.67 | ADAs2 | 0.65 | ADAs2 | 0.65
5 | ADAs2 | 0.68 | ADAs0 | 0.65 | ADAs1 | 0.65
6 | ADAs0 | 0.70 | ADAs1 | 0.65 | ADAC1 | 0.68
7 | ADAs1 | 0.74 | ADAC1 | 0.68 | ADAC | 0.68

Metodele ADAC1 obţine cea mai mare suprapunere între curba de distribuţie standard şi curba de distribuţie a erorii în jurul mediei experimentale şi această metodă împreună cu ADAC obţin cele mai mari suprapuneri între curba de distribuţie în jurul mediei impuse α = 5% şi curba de distribuţie binomială standard (vezi tabelul 66).

Metodele ADAC şi ADAC1 obţin cele mai mari suprapuneri între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale, între curba Gauss de interpolare şi curba Gauss de distribuţie în jurul mediei experimentale şi respectiv între curba Gauss de interpolare şi curba Gauss de distribuţie în jurul mediei impuse (α = 5%).

Tabelul 67. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | ADAC | 0.76 | ADAC | 0.91 | ADAC1 | 0.94
2 | ADAC1 | 0.76 | ADAC1 | 0.82 | ADAC | 0.85
3 | ADAs1 | 0.46 | ADAs1 | 0.46 | ADAs1 | 0.84
4 | ADAs0 | 0.43 | ADAs0 | 0.43 | ADAs0 | 0.84
5 | ADAs2 | 0.42 | ADAs2 | 0.41 | ADAs2 | 0.84
6 | ADWald | 0.37 | ADWald | 0.37 | ADWald | 0.83
7 | ADWaldC | 0.37 | ADWaldC | 0.37 | ADWaldC | 0.83

Concluzii

Analizând cele 10 metode de calcul a intervalului de confidenţă implementate, aşa cum se observă din datele experimentale, pentru valori ale lui m = n =10, 20 metoda ADAC este metoda cu cea mai bună aglomerare a valorilor erorilor experimentale, pentru ca la m = n =30 metodele ADAs0 şi ADAs2 să-şi revendice această poziţie. Media erorilor se situează pentru majoritatea metodelor de calcul sub pragul α impus excepţie făcând metoda ADWald (pentru m = n = 10, 20, 30). De remarcat însă faptul că media erorilor de estimare a intervalului de confidenţă cu ADWald scade pe măsură ce volumul eşantionului creşte (de la 7.00 pentru m = n = 10, la 5.74 pentru m = n = 20 şi respectiv 5.28 pentru m = n = 30).

Estimarea cea mai bună a intervalului de confidenţă pentru punctul central X = Y este dată de metoda IADAC în ceea ce priveşte media erorilor de estimare iar metoda ADJeffreysC metoda cu cea mai mică deviaţie standard experimentală.

În ceea ce priveşte cea mai bună metodă de estimare a intervalului de confidenţă pentru X, m, Y, n aleatorii putem spune că:

· Metoda ADAC este metoda de calcul a intervalului de confidenţă care obţine cea mai mică deviaţie standard experimentală faţă de valoarea impusă de α = 5%, urmată de metoda ADAC1;

· Metoda ADAC1 obţine cea mai apropiată medie experimentală faţă de media expectată (α = 5%) şi cea mai mică deviaţie standard experimentală, urmată în ambele situaţii de metoda ADAC;

· Metoda ADAC obţine cea mai apropiată medie de interpolare faţă de medial expectată (α = 5%);

· Metoda ADAs1 obţine cea mai bună deviaţie standard de interpolare;

· Metodele ADAC şi ADAC1 obţin cele mai bune corelaţii între curba teoretică şi valorile experimentale;

· Metodele ADWald şi ADWaldC obţin cele mai slabe acoperirii între curba de distribuţie binomială standard şi curba de interpolare;

· Metodele ADAC1 obţine cea mai mare suprapunere între curba de distribuţie standard şi curba de distribuţie a erorii în jurul mediei experimentale şi această metodă împreună cu ADAC obţin cele mai mari suprapuneri între curba de distribuţie în jurul mediei impuse α = 5% şi curba de distribuţie binomială standard;

· Metodele ADAC şi ADAC1 obţin cele mai mari suprapuneri între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale, între curba Gauss de interpolare şi curba Gauss de distribuţie în jurul mediei experimentale şi respectiv între curba Gauss de interpolare şi curba Gauss de distribuţie în jurul mediei impuse (α = 5%).

Cele mai bune performanţe în estimarea intervalului de confidenţă pentru funcţia ci6 sunt obţinute de metodele ADAC, ADAC1 şi respectiv ADJeffreysC. Aceasta însă nu poate exclude din discuţie metodele binomiale care s-ar putea comporta mai bine în această situaţie, metode care nu au putut fi luate în studiu din cauza resurselor disponibile.

[i] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 7. Absolute Risk Reduction and ARR-like Expressions. Leonardo Electronic Journal of Practices and Technologies 2004;5:1-25


Intervale de confidenţă pentru funcţia ci7

Fie două populaţii de volum m şi respectiv n cu variabilele X (pentru populaţia de volum m) şi Y (pentru populaţia de volum n). Aşa cum s-a definit, inversul diferenţei absolute a două proporţii este dat funcţia ci7, funcţie care are următoarea formulă:

Estimarea intervalului de confidenţă a inversului diferenţei absolute a două proporţii trebuie să ţină seama simultan de distribuţia de probabilitate a raportului X/m şi respectiv a raportului Y/n.

Mai exact, dacă X şi Y au o distribuţie binomială, nu rezultă că diferenţa absolută are şi ea o distribuţie binomială. Cele mai bune aproximaţii ale diferenţei absolute se realizează folosind distribuţia de normalitate.

Aşa cum se va vedea în continuare, 4 formule de calcul a intervalului de confidenţă au fost selectate şi studiate comparativ (vezi [i] ):

Funcţiile PHP de calcul a intervalelor de confidenţă

Au fost implementate 4 funcţii PHP pentru calculul acestor intervale de confidenţă:

function IADWald($X,$m,$Y,$n,$z,$a){

return IAD(ADWald($X,$m,$Y,$n,$z,$a));

}

function IADAC($X,$m,$Y,$n,$z,$a){

return IAD(ADAC($X,$m,$Y,$n,$z,$a));

}

function IADAS0($X,$m,$Y,$n,$z,$a){

return IAD(ADAS0($X,$m,$Y,$n,$z,$a));

}

function IADJeffreysC($X,$m,$Y,$n,$z,$a){

return IAD(ADJeffreysC($X,$m,$Y,$n,$z,$a));}

Calcularea intervalelor de confidenţă pentru metodele implementate

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru acelaşi prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define('z',1.96); define('a',0.05); în codul sursă al programului implementat).

Reprezentările grafice din acest capitol a limitelor intervalelor de confidenţă şi respectiv a mediilor erorilor intervalelor de confidenţă pentru fiecare metodă de calcul în parte s-a realizat folosind programul Slide cu o perspectivă de 80%, o înclinaţie de 25° şi o rotaţie de 60°. Apar în roşu valorile cuprinse în intervalul 0 - 2%, în verde valorile cuprinse în intervalul 2 - 4%, în albastru valorile cuprinse în intervalul 4 - 6%, în verde marin valorile din intervalul 6 - 8% şi in violet valorile cuprinse în intervalul 8 - 10%.

Reprezentarea grafică a intervalelor de confidenţă şi a expresiei 1/|Y/m-X/n| pentru m = n = 50 este redată în figurile 67 şi 68. Secvenţa de program este:

$c_i=array("IADWald","IADAC","IADAS0","IADJeffreysC");

define("N_min",50);
define("N_max",51);
est_ci2_er(z,a,$c_i,"ci7","ci");

Figura 67. Reprezentarea capetelor inferior şi superior a intervalului de confidenţă (scală logaritmică) în funcţie de valoarea funcţiei ci7 la 0 < X, Y < m = n = 50

Figura 68. Inversul diferenţei absolute, limita inferioară şi superioară a intervalului de confidenţă pentru ci7 cu metoda IADWald şi IADJeffreysC la n = 50

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru un prag de semnificaţie α = 5% (secvenţele define("z",1.96); define("a",0.05); în codul sursă al programului).

Pentru compararea metodelor, s-au ales eşantioane de volume m = n = 10, 20 şi 30.

Reprezentarea grafică a frecvenţei erorilor de calcul a intervalelor de confidenţă pentru n = 10 este redată în figura 69 iar secvenţa de program care permite calculul acestora este:

$c_i=array("IADWald","IADAC","IADAS0","IADJeffreysC");

define("N_min",9);
define("N_max",10);
est_ci2_er(z,a,$c_i,"ci7","er");

Figura 69. Reprezentarea tridimensională a procentului erorilor în estimarea intervalului de confidenţă a funcţiei ci7 cu IADWald, IADAC, IADAS0 şi IADJeffreysC la m = n = 10

Mediile eroilor experimentale şi deviaţiile standard asociate acestora sunt redate în tabelul 68. Se poate observa că, metoda IADAC prezintă cea mai bună deviaţie standard în timp ce metoda IADWald cea mai apropiată medie faţă de valoarea impusă de α = 5%.

Tabelul 68. Valori medii ale erorilor experimentale şi deviaţii standard ale acestora în

estimarea intervalului de confidenţă pentru ci7 la m = n = 10

Metoda | IADWald | IADAC | IADAS0 | IADJeffreysC
Media | 5.16 | 1.69 | 2.97 | 2.02
Deviaţia standard | 3.89 | 0.90 | 1.71 | 1.11

Reprezentarea grafică a frecvenţei erorilor de calcul a intervalelor de confidenţă pentru n = 20 este redată în figura 70 iar secvenţa de program care permite calculul acestora este:

$c_i=array("IADWald","IADAC","IADAS0","IADJeffreysC");

define("N_min",19); define("N_max",20); est_ci2_er(z,a,$c_i,"ci7","er");

Figura 70. Reprezentarea tridimensională a procentului erorilor în estimarea intervalului de confidenţă pentru ci7 cu IADWald, IADAC, IADAS0 şi IADJeffreysC la n = 20

Şi în cazul unui eşantion de volum 20, IADWald prezintă cea mai bună medie a erorilor de estimare şi IADAC cea mai bună deviaţie standard (tabelul 69).

Tabelul 69. Valori medii ale erorilor experimentale şi deviaţii standard ale acestora în

estimarea intervalului de confidenţă pentru ci7 la m = n = 20

Metoda | IADWald | IADAC | IADAS0 | IADJeffreysC
Media | 4.39 | 2.40 | 3.55 | 3.19
Deviaţia standard | 2.77 | 1.20 | 1.53 | 1.69

Secvenţa de program care permite calculul erorilor de estimare a intervalelor de confidenţă pentru n = 30 este:

$c_i=array("IADWald","IADAC","IADAS0","IADJeffreysC");

define("N_min",29);define("N_max",30); est_ci2_er(z,a,$c_i,"ci7","er");

iar reprezentarea grafică a acestora este redată în figura 71.

Figura 71. Reprezentarea tridimensională a procentului erorilor în estimarea intervalului de confidenţă pentru ci7 cu IADWald, IADAC, IADAS0 şi IADJeffreysC la n = 30

Metoda IADWald se menţine metoda cu cea mai bună medie a erorilor de estimare şi IADAC cea mai bună variaţie şi pentru un volum al eşantionului egal cu 30 (tabelul 70).

Tabelul 70. Valori medii ale erorilor experimentale şi deviaţii standard ale acestora

în estimarea intervalului de confidenţă cu ci7 pentru m = n = 30

Metoda | IADWald | IADAC | IADAS0 | IADJeffreysC
Media | 4.24 | 2.71 | 3.54 | 3.57
Deviaţia standard | 2.27 | 1.25 | 1.52 | 1.80

Estimarea intervalelor de confidenţă pentru X = 1/4/m şi Y = 3/4/n

Variaţia erorilor de estimare a intervalului de confidenţă pentru X = 1/4/m şi Y = 3/4/n la m = n = 2,4..204 (n număr par) este redată în figura 72 iar valorile mediilor erorilor şi variaţiilor de estimare sunt redate în tabelul 71.

Figura 72. Variaţia erorii de estimare a intervalului de confidenţă pentru X = 1/4/m şi Y = 3/4/n cu 2< X<154 şi 0<Y<52 şi m = n = 4,8..204

Pentru punctul central, cea mai bună metodă de estimare a intervalului de confidenţă atât din punct de vedere al mediei cât şi al deviaţiei standard este dat de metoda IADAS0.

Tabelul 71. Valori medii ale erorilor experimentale şi deviaţiilor standard a în estimarea intervalului

de confidenţă pentru 2< X<154 şi 0<Y<52 când m = n (m = n = 4,8..204)

Metoda | IADWald | IADAC | IADAS0 | IADJeffreysC
Media | 5.57 | 4.55 | 5.04 | 4.47
Deviaţia standard | 0.91 | 1.20 | 0.90 | 1.12

Reprezentarea grafică a dependenţa erorii medii şi deviaţiei faţă de valoarea impusă α = 5% pentru IADWald, IADAC, IADAS0, IADJeffreysC la valori ale lui n = 4..14 şi m = 4..14 şi X = Y este redată în figura 73. Sunt reprezentate cu roşu valorile cuprinse în intervalul 1 - 2%, în verde valorile cuprinse în intervalul 2 - 3%, în albastru valorile cuprinse în intervalul 3 - 4%, în verde marin valorile din intervalul 4 - 5% şi in violet valorile cuprinse în intervalul 5 - 6%.

Figura 73. Dependenţa deviaţiei faţă de valoarea impusă α = 5% pentru ci7 cu IADWald, IADAC, IADAS0, IADJeffreysC la valorile lui m = 4..14 şi n = 4..14

Deviaţiile faţă de valoarea impusă (α = 5%) a mediilor erorilor experimentale sunt redate în tabelul 72.

Tabelul 72. Medii ale deviaţiilor erorilor experimentale faţă de valoarea impusă în estimarea intervalului de confidenţă pentru ci7 când volumele eşantioanelor m şi n variază în domeniul 4..14

Metoda | IADWald | IADAC | IADAS0 | IADJeffreysC
Deviaţia standard | 4.43 | 3.41 | 2.30 | 2.67

Eşantioane aleatoare

Experimentul de evaluare a intervalelor de confidenţă a continuat cu determinarea erorilor de estimare pentru valori ale lui X, m, Y, n aleatoare.

Experimentul a fost rulat doar pentru metodele IADWald, IADAC şi respectiv IADAS0. Nu au fost incluse în acest experiment metodele binomiale deoarece pentru rularea programelor de estimare a erorilor aveam nevoie de resurse de care nu am dispus. Frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)) sunt reprezentate graphic în figura 74. Rezultatele experimentului sunt în tabelele 73-76.

Figura 74. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, m, Y, n în intervalul 4..1000

Metoda IADACI obţine cea mai mică deviaţie standard raportată la pragul de eroare impus (α = 5%), cea mai mare valoare a diferenţei fată de pragul de eroare impus (α = 5%) a mediei erorilor experimentale şi respectiv cea mai mică deviaţie standard experimentală (tabelul 73).

Tabelul 73. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | IADAC | 1.46 | IADWald | 0.24 | IADAC | 1.20
2 | IADAS0 | 1.79 | IADAS0 | 0.29 | IADAS0 | 1.77
3 | IADWald | 1.84 | IADAC | 0.84 | IADWald | 1.82

Metoda IADAS0 obţine cea mai mică valoare a deviaţiei mediei de interpolare faţă de pragul de eroare impus (α = 5%)(vezi tabelul 74). Metoda IADAC obţine cea mai mică deviaţiei standard de interpolare şi respectiv prezintă cea mai bună corelaţie între curba teoretică de interpolare şi valorile experimentale.

Tabelul 74. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | IADAS0 | 0.03 | IADAC | 1.57 | IADAS0 | 0.41 | 13
2 | IADAC | 0.11 | IADWald | 1.74 | IADWald | 0.45 | 15
3 | IADWald | 0.15 | IADAS0 | 2.02 | IADAC | 0.53 | 22

Analizând tabelul 75 se observă că, metoda IADAC obţine cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de interpolare şi respectiv între curba de distribuţie binomială standard şi curba de distribuţie a erorilor în jurul mediei impuse (α = 5%). Totodată metoda IADAC prezintă cea mai mică suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a erorilor în jurul mediei experimentale.

Tabelul 75. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | IADAS0 | 0.88 | IADAC | 0.74 | IADWald | 0.93
2 | IADWald | 0.94 | IADWald | 0.91 | IADAS0 | 0.94
3 | IADAC | 0.97 | IADAS0 | 0.92 | IADAC | 0.96

Metoda IADAS0 obţine cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale; metoda IADAC cea mai bună suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse (α = 5%) iar metoda IADWald obţine cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse (α = 5%).

Tabelul 76. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | IADAS0 | 0.92 | IADAC | 0.96 | IADWald | 0.94
2 | IADWald | 0.91 | IADWald | 0.96 | IADAS0 | 0.93
3 | IADAC | 0.77 | IADAS0 | 0.94 | IADAC | 0.74

Concluzii

Analizând metodele de calcul a intervalului de confidenţă pentru inversul diferenţei absolute dintre două proporţii se observă că, pentru m = n = 10, 20 şi 30 metoda IADWald obţine cele mai apropiate medii a erorilor de estimare experimentală faţă de valoarea impusă de α = 5% iar metoda IADAC metoda care constant obţine cea mai mică deviaţie standard (o împrăştiere mică a erorilor de estimare experimentale).

Estimarea cea mai bună a intervalului de confidenţă al expresiei Xn/Ym pentru X =1/4/m şi Y=3/4/n este dată de metoda IADAS0 atât în ceea ce priveşte media erorilor de estimare cât şi în ceea ce priveşte deviaţia standard.

În cazul cel mai frecvent întâlnit în practică, adică pentru X, m, Y, n aleatorii putem spune că:

· Metoda IADACI obţine cea mai mică deviaţie standard raportată la pragul de eroare impus (α = 5%), cea mai mare valoare a diferenţei fată de pragul de eroare impus (α = 5%) a mediei erorilor experimentale şi respectiv cea mai mică deviaţie standard experimentală;

· Metoda IADAS0 obţine cea mai mică valoare a deviaţiei mediei de interpolare faţă de pragul de eroare impus (α = 5%);

· Metoda IADAC obţine cea mai mică deviaţiei standard de interpolare şi respectiv prezintă cea mai bună corelaţie între curba teoretică de interpolare şi valorile experimentale;

· Metoda IADAC obţine cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de interpolare şi respectiv între curba de distribuţie binomială standard şi curba de distribuţie a erorilor în jurul mediei impuse (α = 5%);

· Metoda IADAC prezintă cea mai mică suprapunere între curba de distribuţie binomială standard şi curba de distribuţie a erorilor în jurul mediei experimentale;

· Metoda IADAS0 obţine cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale;

· Metoda IADAC cea mai bună suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse (α = 5%);

· Metoda IADWald obţine cea mai bună suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse (α = 5%).

Aproape sistematic metoda IADAC şi IADAS0 obţin cele mai bune performanţe în estimarea intervalului de confidenţă pentru ci7. Aceasta însă nu exclude posibilitatea ca metoda ADJeffreysC să obţină performanţe mai bune, metodă care nu a fost inclusă în experiment datorită resurselor limitate de calcul pe care le-am avut la dispoziţie.

[i] Bolboacă S, Achimaş Cadariu A. Binomial Distribution Sample Confidence Intervals Estimation 8. Number Needed to Treat/Harm. Leonardo Journal of Sciences 2004;5:1-17.


Intervale de confidenţă pentru funcţia ci8

Expresia matematică a funcţiei ci8 este:

Această expresie matematică corespunde la trei indicatori care pot fi calculaţi pe baza tabelului de contingenţă 2´2: raţia de probabilitate pozitivă, raţia de probabilitate negativă şi respectiv riscul relativ.

Formulele de calcul a intervalelor de confidenţă pentru raportul dintre două proporţii folosite în experiment (vezi [i] ) sunt:

Metoda RPWald este metoda de calcul a intervalului de confidenţă preluată din literatura de specialitate. Metoda RPAC se bazează pe modificările introduse de Agresti-Coull pentru cazul unidimensional (vezi intervalele de confidenţă pentru proporţii) şi transpuse la cazul bidimensional. Plecând de la metoda RPAC au fost create trei metode care folosesc diferiţi parametrii de corecţie. Metoda RPAC0 foloseşte [image] ca şi factor de corecţie pentru variabilele binomiale şi respectiv [image] pentru corecţia volumului eşantioanelor). Metoda RPAC1 este diferită faţă de precedenta prin folosirea prin folosirea în loc de Y a corecţiei cu (Y+1), în loc de X a corecţiei cu (X+1). Metoda RPAC2 foloseşte pentru corecţie (Y+2) şi restectiv (X+2).

Funcţii PHP implementate pentru calculul intervalelor de confidenţă

Calularea erorilor de estimare a metodelor de calcul a intervalelor de confidenţă, a deviaţiilor standard, a limitelor intervalelor şi a deviaţiilor faţă de pragul de semnificaţie impus (α = 5%) s-a realizat prin folosirea unui program PHP. Au fost implementate următoarele funcţii de calcul a intervalelor de confidenţă pentru funcţia ci8:

function RPWald($X,$m,$Y,$n,$z,$a){

if($Y){ $P = $X*$n/$Y/$m;

if($X){ $t = ($m-$X)/$X/$m + ($n-$Y)/$Y/$n;

return array ( $P * exp(-$z * sqrt($t)) , $P * exp($z * sqrt($t)));

} else return array ( 0, $n * pow($a/2,1/$m)/$Y );

}else{ return array ( $X/$m/pow($a/2,1/$n) , (float)"INF" ); }

}

function RPAC($X,$m,$Y,$n,$z,$a){

return RPWald($X+0.5/sqrt($m),$m+1/sqrt($m),$Y+0.5/sqrt($n),$n+1/sqrt($n),$z,$a);

}

function RPAC0($X,$m,$Y,$n,$z,$a){

return RPWald($X+sqrt(($Y)/$n)*sqrt(($X)/$m)/4,$m+sqrt(($Y)/$n)*sqrt(($X)/$m)/2,$Y+sqrt(($Y)/$n)*sqrt(($X)/$m)/4,$n+sqrt(($Y)/$n)*sqrt(($X)/$m)/2,$z,$a);

}

function RPAC1($X,$m,$Y,$n,$z,$a){

return RPWald($X+sqrt(($Y+1)/$n)*sqrt(($X+1)/$m)/4,$m+sqrt(($Y+1)/$n)*sqrt(($X+1)/$m)/2,$Y+sqrt(($Y+1)/$n)*sqrt(($X+1)/$m)/4,$n+sqrt(($Y+1)/$n)*sqrt(($X+1)/$m)/2,$z,$a);

}

function RPAC2($X,$m,$Y,$n,$z,$a){

return RPWald($X+sqrt(($Y+2)/$n)*sqrt(($X+2)/$m)/4,$m+sqrt(($Y+2)/$n)*sqrt(($X+2)/$m)/2,$Y+sqrt(($Y+2)/$n)*sqrt(($X+2)/$m)/4,$n+sqrt(($Y+2)/$n)*sqrt(($X+2)/$m)/2,$z,$a);

}

Calcularea intervalelor de confidenţă pentru metodele implementate

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru acelaşi prag de semnificaţie α = 5%, notat cu a în programele PHP (secvenţele define('z',1.96); define('a',0.05); în codul sursă al programului implementat).

Reprezentarea grafică a intervalelor de confidenţă şi a funcţiei ci8 pentru m = n = 30 este redată în figurile 75 şi 76. Secvenţa de program este:

$c_i=array("RPWald", "RPAC ");

define("N_min",30);
define("N_max",31);
est_ci2_er(z,a,$c_i,"ci8","ci");

Figura 75. Reprezentarea capetelor inferior şi superior ale intervalului de confidenţă (scară logaritmică) în funcţie de valoarea funcţiei ci8 pentru 0 < X, Y < m = n = 30

Reprezentarea grafică tridimensionale a funcţiei ci8 şi a limitelor intervalelor de confidenţă calculate cu funcţiile RPWald şi respectiv RPAC sunt redate în figura 76. şi respectiv a mediilor erorilor intervalelor de confidenţă pentru fiecare metodă de calcul în parte s-au realizat folosind programul Slide cu o perspectivă de 80%, o înclinaţie de 45° şi o rotaţie de 30°. Apar în roşu valorile cuprinse în intervalul 0 - 2%, în verde valorile cuprinse în intervalul 2 - 4%, în albastru valorile cuprinse în intervalul 4 - 6%, în verde marin valorile din intervalul 6 - 8% şi in violet valorile cuprinse în intervalul 8 - 10%.

Figura 76. Reprezentarea tridimensională a dependenţei funcţiei ci8 şi intervalului său de confidenţă calculat cu metoda RPWald şi RPAC pentru 0 < X, Y < m = n = 30

Experimentul de comparare a metodelor de calcul a intervalului de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru un prag de semnificaţie α = 5% (secvenţele define('z',1.96); define('a',0.05); în codul sursă al programului).

Secvenţa de program care calculează erorile la n = 30 devine:

$c_i=array("RPWald", "RPAC", "RPAC0", "RPAC1", "RPAC2");

define("N_min",30); define("N_max",31); est_ci2_er(z,a,$c_i,"ci8","er");

Reprezentarea grafică tridimensională a acestor erori este redată în figura 77 iar valorile experimentale în tabelul 77.

Figura 77. Erorile experimentale în estimarea intervalului de confidenţă cu RPWald, RPAC, RPAC0, RPAC1, şi RPAC2 pentru 0 < X, Y < m = n = 10

Tabelul 77. Valori medii ale erorilor experimentale şi deviaţiile standard în estimarea

intervalului de confidenţă pentru ci8 cu m = n = 30

Metoda | RPWald | RPAC | RPAC0 | RPAC1 | RPAC2
Media | 4.20 | 4.95 | 4.85 | 4.86 | 4.86
Deviaţia standard | 1.07 | 0.64 | 0.58 | 0.59 | 0.59

Pentru un volum al eşantionului egal cu 50 secvenţa programului de calcul a erorilor intervalelor de confidentă devine:

$c_i=array("RPWald", "RPAC", "RPAC0", "RPAC1", "RPAC2");

define("N_min",50);
define("N_max",51);
est_ci2_er(z,a,$c_i,"ci8","er");

iar rezultatele sunt reprezentate grafic în figura 78.

Figura 78. Erorile experimentale în estimarea intervalului de confidenţă pentru ci8 RPWald, RPAC, RPAC0, RPAC1 şi RPAC2 la 0 < X, Y < m = n = 50

Mediile şi deviaţiile standard ale erorilor de estimare, experimentale pentru m = n = 20 sunt redate în tabelul 78.

Tabelul 78. Valori medii ale erorilor experimentale şi deviaţii standard în

estimarea intervalului de confidenţă pentru ci8 la m = n = 50

Metoda | RPWald | RPAC | RPAC0 | RPAC1 | RPAC2
Media | 4.76 | 4.78 | 4.74 | 4.74 | 4.74
Deviaţia standard | 0.58 | 0.50 | 0.46 | 0.46 | 0.46

Reprezentarea grafică erorilor de estimare a intervalelor de confidenţă pentru m = n = 80 este redată în figura 79. Secvenţa de program devine:

$c_i=array("RPWald", "RPAC", "RPAC0", "RPAC1", "RPAC2");

define("N_min",80);
define("N_max",81);
est_ci2_er(z,a,$c_i,"RP","ci8","er");

iar rezultatele experimentale sunt redate în tabelul 79.

Tabelul 79. Valori medii ale erorilor experimentale şi deviaţii standard în

estimarea intervalului de confidenţă pentru ci8 la m = n = 80

Metoda | RPWald | RPAC | RPAC0 | RPAC1 | RPAC2
Media | 4.49 | 4.52 | 4.51 | 4.51 | 4.51
Deviaţia standard | 0.62 | 0.58 | 0.56 | 0.56 | 0.56

Figura 79. Erorile experimentale în estimarea intervalului de confidenţă pentru ci8 RPWald, RPAC, RPAC0, RPAC1, şi RPAC2 la 0 < X, Y < m = n = 80

Rezultatele erorilor de estimare a intervalelor de confidenţă pentru m = n = 100 sunt redate în tabelul 80. Secvenţa de program devine:

$c_i=array("RPWald", "RPAC", "RPAC0", "RPAC1", "RPAC2");

define("N_min",100);
define("N_max",101);
est_ci2_er(z,a,$c_i,"RP","ci8","er");

Tabelul 80. Valori medii şi deviaţii standard ale erorilor experimentale în

estimarea intervalului de confidenţă pentru ci8 la m = n = 100

Metoda | RPWald | RPAC | RPAC0 | RPAC1 | RPAC2
Media | 4.53 | 4.55 | 4.55 | 4.55 | 4.55
Deviaţia standard | 0.55 | 0.51 | 0.50 | 0.49 | 0.50

Estimarea intervalelor de confidenţă pentru punctul central X = Y

Variaţia erorilor de estimare a intervalului de confidenţă în punctul central (X = Y) pentru m = n = 2,6..404 (n număr par) este redată în figura 80 iar valorile mediilor erorilor şi variaţiilor de estimare sunt redate în tabelul 81.

Figura 80. Variaţia erorii de estimare a intervalului de confidenţă a punctului central X = Y pentru m = n (m şi numere pare) şi n = 2,6..400

Tabelul 81. Valori medii ale erorilor experimentale şi deviaţii standard în estimarea intervalului de

confidenţă pentru ci8 în punctul central X = Y când m = n şi n = 2,6..404

Metoda | RPWald | RPAC | RPAC0 | RPAC1 | RPAC2
Media | 4.83 | 4.64 | 4.82 | 4.63 | 4.62
Deviaţia standard | 1.54 | 0.83 | 1.55 | 0.83 | 0.83

Reprezentarea grafică tridimensională a variaţiei mediei deviaţiilor faţă de valoarea impusă α = 5% pentru RPWald, şi RPAC la valori ale lui n = 14..33 şi m = 14..33 şi X = Y este redată în figura 81. În figura 81 sunt reprezentate cu culoarea roşu valorile aparţinând intervalului 1-1.2, cu verde valorile din intervalul 1.2 – 1.4, cu albastru valorile din intervalul 1.4 – 1.6%, cu verde marin valorile din intervalul 1.6 –1.8% şi cu violet valorile din intervalul 1.8 – 2%. Reprezentarea grafică s-a realizat cu o perspectivă de 80%, un unghi de rotaţie de 25º şi un unghi de înclinaţie de 15º.

Figura 81. Dependenţa deviaţiilor faţă de valoarea impusă α = 5% pentru ci8 cu RPWald şi RPAC la valori ale lui n = 14..34 şi m = 14..34

Media deviaţiei standard experimentală pentru punctul central X = Y în estimarea erorilor cu metoda RPWald a fost de 2.60 iar pentru metoda RPAC de 1.68 (tabelul 82).

Tabelul 82. Deviaţiilor erorilor experimentale raportată la nivelul de semnificaţie impus în

estimarea intervalului de confidenţă pentru ci8 (m şi n variază în domeniul 14..34)

Metoda | RPAC | RPAC1 | RPAC0 | RPAC2 | RPWald
Deviaţia raportată la nivelul de semnificaţie impus | 1.50 | 1.50 | 1.50 | 1.50 | 1.65

Eşantioane aleatoare

Experimentul de evaluare a intervalelor de confidenţă a continuat cu determinarea erorilor de estimare pentru 200 de valori ale lui X, m, Y, n aleatoare în intervalul 4-1000.

Experimentul a fost rulat doar pentru toate metodele (RPWald, RPAC, RPAC0, RPAC1 şi RPAC2). Frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)) sunt redate în figura 82. Rezultatele experimentului sunt prezentate în tabelele 83 – 86.

Figura 82 . Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, m, Y, n intervalul 4..1000

Metoda RPAC2 obţine cea mai mică variaţie a deviaţie standard experimentală faţă de valoarea impusă (α = 5%). Cea mai apropiată medie experimentală a erorilor faţă de media expectată (α = 5%) a fost obţinută de metoda RPAC1 iar cea mai mică deviaţie standard experimentală de metoda RPAC2.

Tabelul 83. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | RPAC2 | 0.786 | RPAC1 | 0.028 | RPAC2 | 0.786
2 | RPAC1 | 0.834 | RPAC0 | 0.038 | RPAC1 | 0.836
3 | RPAC0 | 1.223 | RPAC | 0.041 | RPAC0 | 1.226
4 | RPAC | 1.261 | RPAC2 | 0.051 | RPAC | 1.264
5 | RPWald | 2.209 | RPWald | 0.150 | RPWald | 2.210

Metodele RPAC0 şi RPAC2 obţin cea mai mică deviaţie a medie de interpolare faţă de media impusă. Cea mai mică deviaţie standard de interpolare este obţinută de metoda RPAC2 strâns urmată de metodele RPAC0 şi RPAC1. Valoarea cea mai mare a pătratului coeficientului de corelaţie între curba teoretică şi valorile experimentale (tabelul 84) este obţinută de metoda RPWald strâns urmată de metoda RPAC2.

Tabelul 84. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | RPAC0 | 0.075 | RPAC2 | 0.652 | RPAC | 0.694 | 43
2 | RPAC2 | 0.075 | RPAC0 | 0.655 | RPAC0 | 0.708 | 46
3 | RPAC1 | 0.077 | RPAC1 | 0.655 | RPAC1 | 0.710 | 46
4 | RPWald | 0.084 | RPWald | 0.671 | RPAC2 | 0.713 | 47
5 | RPAC | 0.085 | RPAC | 0.714 | RPWald | 0.714 | 47

Analizând tabelul 85 se observă că, metoda RPAC obţine cele mai mari suprapuneri între curba de distribuţie binomială standard şi curba de interpolare (pNIG), între curba de distribuţie standard şi curba de distribuţie a erorii în jurul mediei experimentale (pNMV) şi respectiv în jurul mediei impuse (α = 5%)( pN5V).

Tabelul 85. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | RPAC2 | 0.675 | RPAC2 | 0.597 | RPAC2 | 0.675
2 | RPAC1 | 0.702 | RPAC0 | 0.598 | RPAC1 | 0.701
3 | RPWald | 0.836 | RPAC1 | 0.598 | RPWald | 0.838
4 | RPAC0 | 0.877 | RPWald | 0.608 | RPAC0 | 0.876
5 | RPAC | 0.892 | RPAC | 0.633 | RPAC | 0.891

Metoda RPAC2 obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale (pIGMV), RPAC0 cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse (α = 5%) (pIG5V) şi metoda RPAC2 cea mai mare suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei experimentale (pMV5V) (tabelul 86).

Tabelul 86 Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Method | pIGMV | Method | pIG5V | Method | pMV5V
1 | RPAC2 | 0.891 | RPAC0 | 0.988 | RPAC2 | 0.903
2 | RPAC1 | 0.873 | RPAC | 0.987 | RPAC1 | 0.878
3 | RPAC | 0.730 | RPAC1 | 0.987 | RPAC | 0.730
4 | RPAC0 | 0.706 | RPAC2 | 0.974 | RPAC0 | 0.706
5 | RPWald | 0.482 | RPWald | 0.951 | RPWald | 0.482

Concluzii

Analizând metode de calcul a intervalului de confidenţă pentru funcţia ci8 se observă comportamentul diferit al metodelor în funcţie de valoarea volumului eşantionului. Astfel, pentru m = n = 30 metoda RPAC obţine cea mai apropiată medie a erorilor de estimare experimentale de valoarea impusă (α = 5%)., iar metoda RPAC0 cea mai mică deviaţie standard a erorilor experimentale. Cu creşterea volumului eşantionului, atât media erorilor experimentale cât şi deviaţia standard scade dar metodele RPAC şi RPAC0 îşi menţin performanţele pentru volume de eşantioane egale cu 50 şi respectiv 80. La m=n=100 cea mai apropiată medie a erorilor experimentale de valoarea impusă este obţinută de RPAC, RPAC0, RPAC1, RPAC2 iar cea mai mică deviaţie standard de metoda RPAC1.

Estimarea cea mai performantă a intervalului de confidenţă al expresiei Xn/Ym pentru punctul central X = Y este dată de metoda RPWald dacă se ia în considerare media erorilor de estimare cât şi metodele RPAC, RPAC1, RPAC2 dacă se ia în considerare deviaţia standard.

În cazul cel mai frecvent întâlnit în practică, adică pentru X, m, Y, n aleatorii putem spune că:

· Metoda RPAC2 obţine cea mai mică variaţie a deviaţie standard experimentală faţă de valoarea impusă (α = 5%). Cea mai apropiată medie experimentală a erorilor faţă de media expectată (α = 5%) a fost obţinută de metoda RPAC1 iar cea mai mică deviaţie standard experimentală de metoda RPAC2;

· Metodele RPAC0 şi RPAC2 obţin cea mai mică deviaţie a medie de interpolare faţă de media impusă. Cea mai mică deviaţie standard de interpolare este obţinută de metoda RPAC2 strâns urmată de metodele RPAC0 şi RPAC1. Valoarea cea mai mare a pătratului coeficientului de corelaţie între curba teoretică şi valorile experimentale (tabelul 84) este obţinută de metoda RPWald strâns urmată de metoda RPAC2;

· metoda RPAC obţine cele mai mari suprapuneri între curba de distribuţie binomială standard şi curba de interpolare, între curba de distribuţie standard şi curba de distribuţie a erorii în jurul mediei experimentale şi respectiv în jurul mediei impuse (α = 5%);

· Metoda RPAC2 obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale,

· Metoda RPAC0 cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei impuse (α = 5%);

· Metoda RPAC2 cea mai mare suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei experimentale.

Pentru X, m, Y, n aleatorii metoda RPAC2 obţine performanţele cele mai bune în estimarea intervalului de confidenţă pentru funcţia ci8.

[i] Bolboacă S, Jäntschi L. Binomial Distribution Sample Confidence Interval Estimation for Positive and Negative Likelihood Ratio Medical Key Parameters. AMIA Symposion 2005, Washington DC October 22-26. AMIA Procceding


Intervale de confidenţă pentru funcţia ci9

Expresia funcţiei ci9 este:

Formulele de calcul a intervalelor de confidenţă pentru funcţia ci9 folosite în experiment (vezi [i] ) sunt:

Funcţiile PHP de calcul a intervalelor de confidenţă

Pentru calcularea intervalelor de confidenţă au fost implementate funcţiile:

function ARPAC($X,$m,$Y,$n,$z,$a){ return ARP("RPAC",$X,$m,$Y,$n,$z,$a);}

function ARPWald($X,$m,$Y,$n,$z,$a){ return ARP("RPWald",$X,$m,$Y,$n,$z,$a);}

function WaldC1($X,$m,$Y,$n,$z,$a){

if($Y){ $P = $X*$n/$Y/$m;

if($X){

$t = ($m-$X)/($X+pow(($m/$X+$X/$m)/$m,0.25))/$m + ($n-$Y)/

($Y+pow(($n/$Y+$Y/$n)/$n,0.25))/$n;

return array ( $P * exp(-$z * sqrt($t)) , $P * exp($z * sqrt($t)));

} else return array ( 0, $n * pow($a/2,1/$m)/$Y );

}else{ return array ( $X/$m/pow($a/2,1/$n) , (float)"INF" ); }

}

function ARPWaldC1($X,$m,$Y,$n,$z,$a){ return ARP("WaldC1",$X,$m,$Y,$n,$z,$a);}

function WaldC2($X,$m,$Y,$n,$z,$a){

if($Y){ $P = $X*$n/$Y/$m;

if($X){

$t = ($m-$X)/($X+pow(1-$X/$Y/$m,1/$n))/$m + ($n-$Y)/($Y+pow(1-$Y/$X/$n,1/$m))/$n;

return array ( $P * exp(-$z * sqrt($t)) , $P * exp($z * sqrt($t)));

} else return array ( 0, $n * pow($a/2,1/$m)/$Y );

}else{ return array ( $X/$m/pow($a/2,1/$n) , (float)"INF" ); }

}

function ARPWaldC2($X,$m,$Y,$n,$z,$a){

return ARP("WaldC2",$X,$m,$Y,$n,$z,$a);}

function WaldC3($X,$m,$Y,$n,$z,$a){

if($Y){ $P = $X*$n/$Y/$m;

if($X){

$t = ($m-$X)/($X+pow(1-$X/$Y/$m,1/$m))/$m + ($n-$Y)/($Y+pow(1-$Y/$X/$n,1/$n))/$n;

return array ( $P * exp(-$z * sqrt($t)) , $P * exp($z * sqrt($t)));

} else return array ( 0, $n * pow($a/2,1/$m)/$Y );

}else{ return array ( $X/$m/pow($a/2,1/$n) , (float)"INF" ); }

}

function ARPWaldC3($X,$m,$Y,$n,$z,$a){ return ARP("WaldC3",$X,$m,$Y,$n,$z,$a);}

Calcularea intervalelor de confidenţă pentru metodele implementate

Reprezentarea grafică a intervalelor de confidenţă şi a funcţiei ci9 pentru m = n = 50 este redată în figurile 83 şi 84. Secvenţa de program este:

$c_i=array("ARPWald"," ARPWaldC1");

define("N_min",50);
define("N_max",51);
est_ci2_er(z,a,$c_i,"ci9","ci");

Figura 83. Reprezentarea tridimensională a dependenţei funcţiei ci9 şi intervalului său de confidenţă calculat cu metoda ARPWald şi ARPWaldC1 pentru 0 < X, Y < m = n = 50

Figura 84. Reprezentarea capetelor inferior şi superior ale intervalului de confidenţă în funcţie de valoarea funcţiei ci9 la 0 < X, Y < m = n = 50

Calcularea erorilor de estimare ale intervalelor de confidenţă

Experimentele de evaluare a metodelor de calcul a intervalului de confidenţă s-au rulat pentru un prag de semnificaţie α = 5% (secvenţele define("z",1.96); define("a",0.05); în codul sursă al programului).

Pentru n = 10, eşecurile în funcţie de X şi Y sunt redate în figura85. Secvenţa de program care calculează erorile pentru n = 10 este:

$c_i=array("ARPWald"," ARPWaldC1"," ARPWaldC2"," ARPWaldC3");

define("N_min",10);define("N_max",11);est_ci2_er(z,a,$c_i,"ci9","er");

Figura 85. Erorile experimentale în estimarea intervalului de confidenţă pentru ci9 cu ARPWald, ARPWaldC1, ARPWaldC2, ARPWaldC3 la 0 < X, Y < m = n = 10

Mediile şi deviaţiile standard ale erorilor experimentale pentru m = n = 10 sunt prezentate în tabelul 87.

Tabelul 87. Media erorilor experimentale şi deviaţii standard în

estimarea intervalului de confidenţă pentru ci9 la m = n = 10

Metoda | ARPWald | ARPWaldC1 | ARPWaldC2 | ARPWaldC3
Media | 2.25 | 3.87 | 4.11 | 4.11
Deviaţia standard | 2.10 | 2.41 | 2.55 | 2.55

Secvenţa de program care calculează erorile de estimare pentru n = 20 este:

$c_i=array("ARPWald"," ARPWaldC1"," ARPWaldC2"," ARPWaldC3");

define("N_min",20);
define("N_max",21);
est_ci2_er(z,a,$c_i,"ci9","er");

iar reprezentarea grafică a acestora este redată în figura 86 iar valorile experimentale ale mediilor erorilor şi deviaţiilor standard asociate acestora sunt redate în tabelul 88.

Figura 86. Erorile experimentale în estimarea intervalului de confidenţă pentru ci9 cu ARPWald, ARPWaldC1, ARPWaldC2, ARPWaldC3 la 0 < X, Y < m = n = 20

Tabelul 88. Valori medii ale erorilor experimentale şi deviaţii standard

în estimarea intervalului de confidenţă pentru ci9 la m = n = 20

Metoda | ARPWald | ARPWaldC1 | ARPWaldC2 | ARPWaldC3
Media | 2.90 | 4.30 | 4.64 | 4.64
Deviaţia standard | 1.75 | 2.14 | 2.20 | 2.20

Reprezentarea grafică a erorilor de estimare ale intervalelor de confidenţă pentru n = 50 este redată în figura 87. Secvenţa de program care permite calcularea acestor erori este:

$c_i=array("ARPWald"," ARPWaldC1"," ARPWaldC2"," ARPWaldC3");

define("N_min",50);
define("N_max",51);
est_ci2_er(z,a,$c_i,"ci9","er");

Figura 87. Erorile experimentale în estimarea intervalului de confidenţă pentru ci9 cu ARPWald, ARPWaldC1, ARPWaldC2, ARPWaldC3 la 0 < X, Y < m = n = 50

Cele mai bune performanţe în acest caz sunt asigurate de metodele ARPWaldC2 şi ARPWaldC3 dacă ne interesează o medie cât mai apropiată de media impusă (tabelul 89).

Tabelul 98. Valori medii şi deviaţiile standard ale erorilor experimentale

în estimarea intervalului de confidenţă pentru ci9 la m = n = 50

Metoda | ARPWald | ARPWaldC1 | ARPWaldC2 | ARPWaldC3
Media | 3.64 | 4.51 | 4.83 | 4.83
Deviaţia standard | 1.32 | 1.61 | 1.69 | 1.69

Estimarea intervalelor de confidenţă pentru punctul central X = Y

Variaţia erorilor de estimare a intervalului de confidenţă în punctul central (X = Y) pentru m = n = 2,4..204 (n număr par) este redată în figura 88 iar valorile mediilor erorilor şi a mediilor deviaţiile standard sunt redate în tabelul 90.

Figura 88. Variaţia erorii de estimare a intervalului de confidenţă

a punctului central X = Y pentru m = n (m şi n par)

După cum se poate observa atât din reprezentarea grafică (figura 3.93) cât şi din tabelul 90, cea mai apropiată medie a erorilor experimentale faţă de valoarea impusă de 5% se obţine cu metoda ARPWaldC1 în timp ce metodele ARPWaldC2 şi respectiv ARPWaldC3 obţin cea mai bună medie a deviaţiilor standard a erorilor experimentale.

Tabelul 90. Valori medii ale erorilor experimentale şi deviaţii standard în estimarea intervalului

de confidenţă pentru ci9 în punctul central X = Y când m = n (m = n = 4,6..204)

Metoda | ARPWald | ARPWaldC1 | ARPWaldC2 | ARPWaldC3 | ARPAC
Media | 4.51 | 4.99 | 5.11 | 5.11 | 4.40
Deviaţia standard | 0.76 | 0.69 | 0.66 | 0.66 | 1.04

Reprezentarea grafică tridimensională a deviaţiilor faţă de valoarea impusă α = 5% pentru ARPWald, ARPWaldC1, ARPWaldC2 şi ARPWaldC3 la valori ale lui n = 4..25 şi m = 4..25 şi X = Y este redată în figura 89.

Figura 98. Dependenţa mediei deviaţiei faţă de valoarea impusă α = 5% pentru ci9 cu ARPWald, ARPWaldC1, ARPWaldC2, ARPWaldC3 la valori ale lui n = 4..25 şi m = 4..25

Metoda ARPWaldC1 obţine cea mai mică medie a deviaţie standard a erorilor de estimare faţă de valoarea impusă (α = 5%)( tabelul 91).

Tabelul 91. Medii ale deviaţiilor standard ale erorilor experimentale faţă de valoarea impusă (Dev5) pentru ci9 când volumele eşantioanelor m şi n variază în domeniul 4..25

Metoda | ARPWald | ARPWaldC1 | ARPWaldC2 | ARPWaldC3
Dev5 | 3.29 | 2.82 | 2.85 | 2.85

Eşantioane aleatoare

Experimentul de evaluare a intervalelor de confidenţă a continuat cu determinarea erorilor de estimare pentru valori ale lui X, m, Y, n aleatoare. Experimentul a fost rulat doar pentru toate metodele de calcul a intervalului de confidenţă implementate (ARPWald, ARPWaldC1, ARPWaldC2, ARPWaldC3 şi ARPAC). Frecvenţele erorilor experimentale pentru fiecare metodă de calcul specificată; cu verde frecvenţele erorilor de interpolare cu curba Gauss (dIG(er)); cu roşu curba Gauss a mediilor şi deviaţiilor standard ale erorilor experimentale (dMV(er)); cu albastru cuba Gauss a frecvenţei deviaţiei erorilor experimentale faţă de valoarea impusă a nivelului de semnificaţie (d5V(er)); cu negru curba Gauss a distribuţiei binomiale a frecvenţelor impuse ale erorilor (pN(er, 10)) sunt redate pentru fiecare metodă în parte în figura 90 iar rezultatele experimentului în tabelele 92 - 95.

Figura 90. Reprezentarea grafică a pN(er, 10), d5V(er), dMV(er), dIG(er) şi frecvenţa erorilor experimentale pentru metodele specificate şi valori aleatorii ale lui X, m, Y, în intervalul 4..1000

Metoda ARPAC obţine cea mai mică deviaţia standard experimentală faţă de valoarea impusă (α = 5%) (tabelul 92). Metoda ARPWald prezintă cea mai apropiată medie a erorilor experimentale de media expectată (α = 5%). Metoda ARPAC obţine cea mai mică deviaţia standard experimentală.

Tabelul 92. Ordonarea metodelor după Dev5, |5-M| şi StDev

Nr | Metoda | Dev5 | Metoda | |5-M| | Metoda | StDev
1 | ARPAC | 1.10 | ARPWald | 0.11 | ARPAC | 1.05
2 | ARPWaldC1 | 2.88 | ARPWaldC1 | 0.15 | ARPWaldC2 | 2.88
3 | ARPWaldC2 | 2.90 | ARPWaldC2 | 0.32 | ARPWaldC3 | 2.88
4 | ARPWaldC3 | 2.90 | ARPWaldC3 | 0.32 | ARPWaldC1 | 2.88
5 | ARPWald | 2.92 | ARPAC | 0.32 | ARPWald | 2.92

Metoda ARPWald obţine cea mai mică deviaţia a mediei de interpolare faţă de valoarea impusă (α = 5%) (tabelul 93), fiind urmată îndeaproape de metoda ARPAC. Metoda ARPWaldC1 obţine cea mai mică valoare de interpolare a deviaţiei standard şi cea mai mare corelaţie între curba teoretică şi valorile experimentale.

Tabelul 93. Ordonare metodelor după |5-MInt|, DevInt, r2Int, FInt

Nr | Metoda | |5-MInt| | Metoda | DevInt | Metoda | r2Int | FInt
1 | ARPWald | 0.05 | ARPWaldC1 | 0.75 | ARPWald | 0.65 | 35
2 | ARPAC | 0.06 | ARPWald | 0.81 | ARPAC | 0.65 | 36
3 | ARPWaldC1 | 0.22 | ARPAC | 0.84 | ARPWaldC2 | 0.68 | 40
4 | ARPWaldC2 | 0.44 | ARPWaldC2 | 0.85 | ARPWaldC3 | 0.68 | 40
5 | ARPWaldC3 | 0.44 | ARPWaldC3 | 0.85 | ARPWaldC1 | 0.71 | 48

Analizând tabelul 94 se observă că, cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de interpolare este obţinută metoda ARPWald, urmată de ARPAC (tabelul 3.86). Metoda ARPAC obţine cea mai mare suprapunere între curba de distribuţie standard şi curba de distribuţie a erorii în jurul mediei experimentale şi respectiv între curba de distribuţie binomială standard şi curba de dustribuţie a erorii în jurul mediei impuse (α = 5%).

Tabelul 94. Ordonare metodelor după pNIG, pNMV şi pN5V

Nr | Metoda | pNIG | Metoda | pNMV | Metoda | pN5V
1 | ARPWaldC1 | 0.65 | ARPWald | 0.71 | ARPWald | 0.71
2 | ARPWaldC2 | 0.69 | ARPWaldC2 | 0.71 | ARPWaldC2 | 0.71
3 | ARPWaldC3 | 0.69 | ARPWaldC3 | 0.71 | ARPWaldC3 | 0.71
4 | ARPAC | 0.70 | ARPWaldC1 | 0.72 | ARPWaldC1 | 0.72
5 | ARPWald | 0.99 | ARPAC | 0.79 | ARPAC | 0.83

Metoda ARPAC obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale şi între curba Gauss de interpolare în jurul mediei impuse (α = 5%). Metodele ARPWald şi ARPWaldC1 obţin cea mai mare suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5% (tabelul 95).

Tabelul 95. Ordonare metodelor după pIGMV, pIG5V şi pMV5V

Nr | Metoda | pIGMV | Metoda | pIG5V | Metoda | pMV5V
1 | ARPAC | 0.82 | ARPAC | 0.87 | ARPWald | 0.90
2 | ARPWaldC2 | 0.47 | ARPWaldC2 | 0.47 | ARPWaldC1 | 0.90
3 | ARPWaldC3 | 0.47 | ARPWaldC3 | 0.47 | ARPWaldC2 | 0.88
4 | ARPWald | 0.45 | ARPWald | 0.45 | ARPWaldC3 | 0.88
5 | ARPWaldC1 | 0.43 | ARPWaldC1 | 0.43 | ARPAC | 0.88

Concluzii

Analizând estimarea intervalului de confidenţă pentru expresia |1-Xn/Ym| pentru metodele prezentate în acest capitol se poate spune că pentru m = n la valori de 10, 20 şi respectiv 50, dacă căutăm o metodă a cărei erori de estimare să fie cât mai apropiate faţă de valoarea impusă de 5% cea mai bună alegere este ARPWaldC2 şi respectiv ARPWaldC3 (tabelul 3.79, 3.80 şi 3.81). Dacă însă dorim o metodă de calcul a intervalului de confidenţă cu o deviaţie standard cât mai mică cea mai potrivită metodă este ARPWald.

În estimarea erorilor punctului central, metoda cu media erorilor cea mai apropiată de valoarea impusă de 5% este ARPWaldC1 urmată de metodele ARPWaldC2 şi respectiv ARPWaldC3 (tabelul 3.82).

Pentru X, n, Y, m aleatorii în intervalul 4 – 1000 putem spune că:

· Metoda ARPAC obţine cea mai mică deviaţia standard experimentală faţă de valoarea impusă (α = 5%);

· Metoda ARPWald prezintă cea mai apropiată medie a erorilor experimentale de media expectată (α = 5%);

· Metoda ARPAC obţine cea mai mică deviaţia standard experimentală;

· Metoda ARPWald obţine cea mai mică deviaţia a mediei de interpolare faţă de valoarea impusă (α = 5%), fiind urmată îndeaproape de metoda ARPAC;

· Metoda ARPWaldC1 obţine cea mai mică valoare de interpolare a deviaţiei standard şi cea mai mare corelaţie între curba teoretică şi valorile experimentale;

· Cea mai mare suprapunere între curba de distribuţie binomială standard şi curba de interpolare este obţinută metoda ARPWald, urmată de ARPAC;

· Metoda ARPAC obţine cea mai mare suprapunere între curba de distribuţie standard şi curba de distribuţie a erorii în jurul mediei experimentale şi respectiv între curba de distribuţie binomială standard şi curba de distribuţie a erorii în jurul mediei impuse (α = 5%);

· Metoda ARPAC obţine cea mai mare suprapunere între curba Gauss de interpolare şi curba Gauss de distribuţie a erorii în jurul mediei experimentale şi între curba Gauss de interpolare în jurul mediei impuse (α = 5%);

· Metodele ARPWald şi ARPWaldC1 obţin cea mai mare suprapunere între curba Gauss de distribuţie a erorii în jurul mediei experimentale şi curba Gauss de distribuţie a erorii în jurul mediei impuse α = 5%;

Nu s-au constatat diferenţe semnificative între metodele ARPWaldC2 şi ARPWaldC3 în estimarea intervalului de confidenţă pentru funcţia ci9.

[i] Bolboacă S. Binomial Distribution Sample Confidence Intervals Estimation 10. Relative Risk Reduction and RRR-like Expressions. Leonardo Electronic Journal of Practices and Technologies 2005;6:60-75.


Calculul intervalelor de confidenta pentru proportii

Calculul intervalelor de confidenţă pentru proporţii

În toate studiile medicale este implicată utilizarea unui eşantion pentru aprecierea unei intervenţii medicale.
Aprecierea valorii obţinute în urma aplicării studiului se exprimă prin indicatori medicali. Cea mai mare parte a acestora sunt de forma X/n, unde X este valoarea de răspuns în urma aplicării intervenţiei, iar n este volumul eşantionului luat în studiu.
Uzual, valoarea obţinuta (X/n) trebuie însoţită de intervalul de confidenţă, care exprimă marja de eroare corespunzătoare observaţiei experimentale. În literatura de specialitate se întâlnesc numeroase formule de calcul pentru intervalul de confidenţă, fiecare dintre ele având la baza ipoteze statistice. Cea mai mare parte a acestora folosesc aproximaţia la normalitate a distribuţiei binomiale, care reprezintă de fapt distribuţia adevărata în cazul volumelor de eşantioane discrete. De remarcat este ca aproximaţia este din ce în ce mai inexacta, cu cât volumul eşantionului (n) este mai mic şi/sau valoarea măsurată X este foarte miăa (se apropie de 0) sau foarte mare (se apropie de n). Astfel s-a născut ideea de a implementa un algoritm, şi apoi un program de calcul pentru intervalul de confidenţă în impunerea strictă a distribuţiei binomiale. O remarcă se face necesară aici, şi anume că, calculul matematic care este necesar în aceasta ipoteză strictă depăşeşte posibilităţile de calcul cu creionul şi hârtia, fiind aproape imposibil de contabilizat toate posibilităţile ce rezultă din combinatorica distribuţiei binomiale, şi aceasta începând chiar de la n = 7. Mai mult, nici măcar cu ajutorul calculatorului nu se poate face acest lucru în timp real începând de la n = 30.
Astfel, singura posibilitate care rămâne, este obţinerea valorilor intervalului de confidenţă dintr-un calcul aproximativ. Însă şi aici, impunerea ca calculele să se facă folosind strict ipoteza distribuţiei binomiale trebuie să prevaleze.
Folosind un algoritm original de optimizare în 6 puncte (doua triangulaţii) au fost calculate aproximativ intervalele de confidenţă ale tuturor proporţiilor de la un volum al eşantionului n = 7 până la n = 506 (când deja aproximaţia normală este acceptabilă) iar compararea rezultatelor cu rezultatele obţinute de metodele clasice (cele care nu folosesc optimizarea intervalului) a dovedit o îmbunătăţire a performantelor acestora cu în medie 10%.
Mai multe detalii despre subiect se pot găsi în Binomial Distribution Sample Confidence Intervals Estimation 1. Sampling and Medical Key Parameters Calculation şi 2. Proportion-like Medical Key Parameters.
Valorile calculate ale intervalului de confidenţă pentru n de la 2 la 506 şi orice X (între 1 şi n-1), pentru un prag de semnificaţie de 95% se pot obţine folosind resursa online:
http://l.academicdirect.org/Statistics/confidence_intervals/
unde "?n=7&X=5" reprezintă cele doua valori pentru care se calculează intervalul de confidenţă, X - valoarea de răspuns în urma aplicării intervenţiei, n - volumul eşantionului; exemplul dat calculează intervalele de confidenţă pentru n = 7 si X = 5.


Dictionar

A

Acurateţea testului diagnostic

= proporţia de rezultate pozitive şi negative care sunt în concordanţă cu diagnosticul final raportat la totalul rezultatelor.

Analiza cost-beneficiu

= analiză economică care converteşte efectele unei intervenţii medicale în aceeaşi termeni monetari ca şi costurile şi îi compară.

Analiza cost-consecinţă

= evaluare economică care compara costurile şi consecinţele a doua sau mai multe intervenţii medicale, în care costurile şi consecinţele nu sunt agregate şi toate rezultatele sunt exprimate în unităţi naturale.

Analiza cost-eficienţă

= analiză economic care converteşte efectele unei intervenţii medicale în termeni de sănătate şi descrie costurile pentru un câştig adiţional de sănătate.

Analiza cost-utilitate

= analiză economică care converteşte efectele unei intervenţii în preferinţele personale ale pacientului (utilităţi) şi descrie care este costul unui câştig adiţional al calităţii vieţii pacientului.

Analiza deciziei medicale

= tehnică de abordare a luării deciziilor medicale în condiţii de incertitudine prin examinarea sistematică a tuturor informaţiilor relevante pentru o decizie. Se bazează pe estimări (din literatura de specialitate sau care aparţin experţilor) ale probabilităţilor că anumite evenimente şi rezultate vor apărea şi pe valorile rezultatelor care se obţin prin aplicarea fiecărei strategii. Un arbore decizional este o reprezentare grafică a drumurilor/căilor clinice alternative. Totalitatea evenimentelor posibile formează nodurile arborelui decizional iar căile prin care se ajunge la aceste evenimente sunt drumurile arborelui decizional.

Ani de viaţă ajustaţi în funcţie de calitate (QALY’s - Quality Adjusted Life Year)

= se calculează multiplicând numărul de ani de viata adăugaţi de o intervenţie cu o valoare standard care reflectă calitatea vieţii de-a lungul perioadei adăugate. Valoarea '0' reprezintă decesul iar valoarea '1' reprezintă starea de sănătate.

Anii de viaţă ajustaţi în funcţie de incapacitate (DALY’s – Disability Adjusted Life Years)

= o unitate a status-ului îngrijirilor de sănătate care ajustează speranţa de viaţă la o vârsta specifică cu pierderea de sănătate şi pierderea de ani de viaţă datorită incapacităţii date de prezenta bolii.

B

Baze de date

= colecţie electronică de informaţii. Într-un anumit fel, o bază de date e similară unui sistem de dosare, dar are importante avantaje: informaţiile pot fi revizuite şi actualizate uşor, iar informaţia poate fi găsită foarte repede. Bazele de date electronice cum sunt MEDLINE, EMBASE şi CDSR, pot fi distribuite pe disc, CD-ROM sau prin intermediul Internet-ului.

Bază de date bibliografică

= un index sau o sursă computerizată de referinţe sau citaţii care cuprinde articole de revistă şi alte rapoarte din literatura de specialitate.

Biblioteca Cochrane

= colecţie de baze de date, imprimate pe dischetă şi CD-ROM cu informaţii actualizate trimestrial, ce cuprinde Sintezele Sistematice ale Bazei de Date Cochrane, Registrul Trialurilor Controlate Cochrane, Baza de Date a Rezumatelor Sintezelor Sistematice ale Eficacităţiii, Baza de Date a Metodologiei sintezelor Cochrane şi informaţii despre Colaborarea Cochrane.

C

Calitatea vieţii legată de sănătate

= aspecte ale calităţii vieţii asociate stării de sănătatea. Exemple: supravieţuirea, capacitatea de a desfăşura activităţi fizice considerate normale cum ar fi mersul, conducerea unei maşini, desfăşurarea unei activităţi productive, capacitatea de auto-îngrijire şi de îngrijire a altora, absenţa depresiei, absenţa durerii, capacitatea de a vedea, auzi, vorbi, şi de a gândi.

Cercetarea serviciilor de sănătate

= integrarea epidemiologiei, sociologiei, economiei şi a altor ştiinţe în studierea serviciilor de sănătate. Se focalizează asupra relaţiei dintre 'nevoie – cerere – furnizare – utilizare' şi asupra rezultatelor serviciilor de sănătate. Scopul cercetării presupune o evaluare în termeni de structură, proces, rezultat intermediar şi final a unui serviciu de sănătate.

Comorbiditate

= afecţiune care însoţeşte diagnosticul principal şi care necesită tratament şi îngrijiri suplimentare pe lângă tratamentul afecţiunii pentru care pacientul a fost internat.

Complianţa

= o măsura a gradului în care pacienţii urmează un regim prescris de viaţă, alimentar, terapeutic, diagnostic.

Complicaţia unei boli

= este afecţiunea care apare pe parcursul episodului de boală, determinată de una din afecţiunile pre-existente sau de îngrijirile primite de pacient.

Consens

= formă de judecată în care un grup de experţi interacţionează în evaluarea unei intervenţii şi formularea de recomandări prin vot sau altă metodă de obţinere a consensului. Procesul poate fi formal sau informal - implicând tehnici cum ar fi tehnica grupului nominal şi/sau tehnica Delphi.

Creşterea beneficiului relativ

= creşterea proporţională a ratei evenimentului dorit la grupul caz faţă de grupul martor.

Creşterea beneficiului absolut

= diferenţa matematică absolută între rata evenimentului dorit la cazuri şi martori.

Creşterea relativă a riscului

= proporţia creşterii ratei de apariţie a unui eveniment nedorit la grupul caz faţă de grupul martor.

Creşterea absolută a riscului

= diferenţa matematică absolută între rata evenimentului nedorit la cazuri şi martori.

Criterii de includere în studiu

= condiţiile în care o entitate a populaţiei ţintă poate fi inclusă în eşantionul de studiu.

Criterii de excludere din studiu

= condiţiile în care o entitate nu aparţine eşantionului de studiu.

Colaborarea Cochrane

= organizaţie internaţională al cărui scop este de ajuta medicii să fie mai informaţi în luarea deciziilor privind sănătatea prin pregătirea, menţinerea şi asigurarea accesibilităţii la cercetări secundare (sinteze sistematice, meta-analize).

D

Diagnostic principal

= diagnosticul considerat ca fiind principalul responsabil de internarea în spital, stabilit după evaluarea pacientului, în momentul externării din spital.

Diagnostic secundar

= diagnosticul care fie co-există cu afecţiunea principală (diagnosticul principal) la momentul internării, fie apare în timpul episodului de boală.

Diseminarea informaţiei medicale

= orice proces prin care informaţia medicală este transmisă, accesibilă pentru o audienţă stabilită sau pentru un grup ţintă.

Drum clinic (cale clinică)

= un set multi-disciplinar de prescrieri zilnice folosite în îngrijirea unei categorii specifice de pacienţi (ex. din momentul pre-admiterii în spital până după). Adesea, scopul elaborării acestor drumuri clinice este de a îmbunătăţii calitatea îngrijirilor şi de a scădea costurile îngrijirilor medicale.

E

Eficacitate

= capacitatea de a determina efectul aşteptat în condiţii ideale (dovezi rezultate din studii desfăşurate in vitro, sau din studii randomizate desfăşurate în centre de vârf cum ar fi un spital universitar de elită).

Eficacitatea unui tratament

= proporţia de rezultate favorabile înregistrate la pacienţii care au urmat tratamentul.

Eficienţă

= capacitatea de a determina efectul aşteptat în condiţii normale şi uzuale. Se referă la dovezi rezultate din studii clinice.

Eficienţa unui tratament

= reprezintă proporţia de rezultate favorabile înregistrate la pacienţii cărora li s-a prescris acel tratament, fără a şti sau a se ţine cont dacă aceştia au respectat tratamentul sau nu.

Episod de îngrijiri de boală

= perioada de îngrijire a pacientului internat, cuprinsă între o internare şi o externare, caracterizată printr-un singur tip de îngrijire.

Eroare sistematică

= factor care poate surveni în conceperea, execuţia sau analiza unui studiu, conducând la o alterare a estimării rezultatelor (supra sau subestimarea acestora).

Eroare sistematică de confuzie

= reprezintă situaţia în care o măsură a unui efect al unei intervenţii sau expuneri e distorsionată din cauza asocierii expunerii la alţi factori care pot influenţa rezultatul studiului.

Eroare sistematică de informare sau observare

= eroare în culegerea datelor sau în modalitatea de măsurarea a rezultatelor.

Eroare sistematică de selecţie

= eroare în stabilirea criteriilor de includere a subiecţilor într-un grup sau altul.

Eşantion

= submulţime finită a populaţia ţintă.

Evaluare economică

= analiza comparativă a direcţiilor de acţiune în termeni de costuri şi consecinţe; = un set de metode formale cantitative folosite pentru a compara strategii alternative în legătură cu folosirea resurselor şi rezultatele aşteptate pentru fiecare acţiune.

Evaluarea tehnologiilor în îngrijirile de sănătate

= formă comprehensivă de cercetare strategică care explorează consecinţele directe şi indirecte, intenţionate şi neintenţionate pe termen scurt şi lung ale aplicării tehnologiei în îngrijirea pacienţilor; = evaluarea sistematică a proprietarilor, efectelor şi/sau altor impacturi ale tehnologiilor în îngrijirile de sănătate. Scopul principal este de a furniza informaţii obiective care să susţină luarea deciziei în îngrijirile de sănătate şi strategiile la nivel local, regional, naţional şi internaţional. Evaluarea tehnologiilor medicale este realizată de grupuri inter-disciplinare care folosesc metode analitice explicite.

Excesul de risc (risc atribuabil)

= partea din riscul absolut care este imputabilă expunerii la factorul de risc studiat. Măsoară specificitatea legăturii dintre factorul prognostic şi îmbolnăvire.

F

Factor de confuzie

= caracteristică sau factor care împiedică rezultatul dorit şi care este în acelaşi timp corelat cu factorii cauzali sau caracteristicile investigate. Dacă factorii de confuzie nu sunt controlaţi determină erori de estimare a impactului factorilor cauzali sau a caracteristicilor investigate.

Farmacoeconomie

= aplicarea metodelor de evaluare economică a programelor de sănătate pentru intervenţii care includ produse farmaceutice.

Fracţia etiologică a riscului la expuşi

= măsoară specificitatea legăturii dintre expunere şi patologia de interes.

G

Ghid de practică medicală

= sinteză creată pentru a ajuta practicienii în luarea unor decizii de sănătate cu privire la o condiţie clinică specifică; instrucţiuni sau principii reprezentând reguli de politică de sănătate curentă sau viitoare realizate pentru practicieni, cu scopul de a sprijini luarea deciziei în îngrijirea pacientului privind diagnosticul, terapia sau alte situaţii clinice. Ghidurile de practică pot fi elaborate de o agenţie guvernamentală aflată la orice nivel, instituţii, societăţi profesionale sau de reuni ale grupurilor de experţi. Ghidurile formează o bază de evaluare a tuturor aspectelor îngrijirilor de sănătate.

Grup de control

= un grup de pacienţi care serveşte ca bază de comparaţie pentru evaluarea efectelor unei intervenţii de interes asupra grupului de tratament. În funcţie de circumstanţele în care se desfăşoară studiul grupul de control nu va primi nici un tratament, va primi un tratament 'standard' sau placebo. Pentru a face comparaţia validă, grupul de control va fi cât se poate de similar cu grupul tratat.

H

Heterogenitate

= variabilitatea sau diferenţele dintre studii, referitor la estimarea efectelor. Se foloseşte la prezentarea rezultatelor meta-analizelor. Se face distincţie între heterogenitatea statistică (diferenţe între efectele raportate), heterogenitatea metodologică (diferenţe în construcţia studiului) şi heterogenitatea clinică (diferenţe între caracteristicile cheie ale participanţilor, intervenţiilor sau mărimilor rezultatului). Testele statistice de heterogenitate se folosesc pentru a evalua dacă variabilitatea observat în rezultatele studiului (mărimile efectului) e mai mare decât cea la care se ajunge din întâmplare.

I

Incidenţa

= rata de apariţie a cazurilor sau condiţiilor noi de boală într-o populaţie aflată la risc într-o perioadă dată de timp (de obicei un an).

Index Medicus

= catalogul Bibliotecii Naţionale Medicale a Statelor Unite ale Americii, un index periodic al literaturii medicale.

Interval de confidenţă/Interval de încredere

= intervalul în care ne aşteptăm ca valoarea adevărată (de ex. mărimea efectelor unei intervenţii) să fie falsă, cu un grad dat certitudine ales arbitrat de cercetător (de ex. 95% sau 99% ). Intervalul de confidenţă reprezint probabilitatea erorilor de randomizare, şi nu a erorilor sistematice. De exemplu, exista o probabilitate de 95% ca intervalul de încredere 95% calculat într-un studiu să includă valoarea reală a efectului tratamentului.

Ipoteza nulă

= în testarea unei ipoteze statistice, ipoteza nulă este cea care susţine că intervenţia nu are nici un efect (de ex. arată că nu există nici o deosebire între rezultatele obţinute de grupul de tratament şi cele din grupul control). Dacă testul statistic indică faptul ca valoarea p se afla la sau deasupra unei valori specificate α (ex. 0.01 sau 0.05, care reprezintă probabilitatea de a face o eroare pozitivă) atunci orice efect observat al tratamentului nu este semnificativ statistic iar ipoteza nulă nu poate fi respinsă. Dacă valoarea p este mai mică decât valoarea α specificată, atunci efectul tratamentului este statistic semnificativ iar ipoteza nulă va fi respinsă. Dacă intervalul de încredere (ex. de 95% sau 99%) include efect '0' al tratamentului, atunci ipoteza nulă nu poate fi respinsă.

L

Literatura 'gri'

= rapoarte de studii de cercetare care nu apar în baze de date publice - MEDLINE sau în alte baze de date electronice similare. De exemplu monografii produse de agenţii guvernamentale, lucrări prezentate la simpozioane, conferinţe, întâlniri anuale, ale unor societăţi/organizaţii, rapoarte întocmite de diferite companii (ca de ex. cele care produc şi distribuie tehnologii medicale) care sunt nepublicate. Metodele folosite în cercetarea literaturii de această natură includ verificarea referinţelor din indexul studiilor, verificarea registrelor care descriu studiile randomizate desfăşurate, contactarea cercetătorilor pentru obţinerea materialelor nepublicate, contactarea agenţiilor guvernamentale, asociaţiilor profesionale, sau a altor comisii relevante care au legătură cu studiile respective, căutarea în biblioteci a tezelor de doctorat, traducerea unor studii apărute în reviste în limbi care nu sunt de circulaţie internaţională.

M

Managementul bolii

= proces sistematic de control al îngrijirii pacientului care prezintă o boala acută sau cronică vis-a-vis de servicii extra-spitaliceşti, intraspitaliceşti şi servicii auxiliare. Scopul controlului include: reducerea episoadelor acute de boală, reducerea numărului spitalizărilor şi zilelor de spitalizare, reducerea variaţiilor de îngrijire, îmbunătăţirea rezultatelor îngrijirii şi reducerea costurilor. Managementul bolilor poate implica îmbunătăţirea continuă a calităţii sau alte modele de management. Poate include şi un proces de urmare a protocoalelor de practică, prin măsurarea rezultatelor, trimiterea rezultatelor înapoi la clinicieni şi revizuirea protocoalelor atunci când este nevoie.

Managementul calităţii totale

= aplicarea practicilor din managementul industrial cu scopul menţinerii şi îmbunătăţirii performanţei organizaţiilor. Eficacitatea şi succesul sunt determinate şi evaluate prin intermediul măsurătorilor cantitative aplicate în studiul calităţii.

Medicina bazată pe evidenţe

= utilizarea explicită şi judicioasă a celor mai actuale evidenţe în luarea deciziei privind îngrijirea individuală a pacientului. Practicarea medicinii bazata pe evidenţe presupune integrarea experienţei individuale a clinicianului cu cele mai bune evidenţe clinice rezultate din cercetarea sistematică clinică. Constă în procesul sistematic de căutare, evaluare şi utilizare a rezultatelor cercetărilor recente ca bază în luarea deciziilor clinice. Practica medicală bazată pe evidenţe se desfăşoară prin parcurgerea a patru etape: formularea întrebărilor clinice clare referitoare la o problema specifică unui pacient; căutarea unei evidenţe ştiinţifice relevante; evaluarea critică a validităţii şi utilităţii evidenţelor găsite; aplicarea evidenţelor valide şi relevante în practica curentă.

Medline

= bază de date electronică creată de Biblioteca Naţională de Medicină SUA. Cuprinde milioane de articole din jurnale selecţionate (în jur de 3.700). Anul de acoperire - din 1966 până în prezent.

MeSH

= descriptori utilizaţi de Biblioteca Naţională de Medicină SUA pentru indexarea de articole în baza de date MEDLINE. A fost conceput pentru a reduce problemele ce poate să apară, de exemplu, din diferenţele dintre ortografierea britanică şi americană. Sistemul MeSH are o structură de arbore în care descriptorii unor subiecte largi sunt ramuri într-o serie de termeni ai subiectelor îngustate progresiv.

Meta-analiza datelor medicale

= metodă sistematică care utilizează tehnici statistice de combinare a rezultatelor provenite din cercetări primare diferite pentru a obţine un estimator cantitativ unic care să caracterizeze toate studiile incluse în meta-analiză. = procedură statistică prin intermediul căreia se realizează integrarea rezultatelor mai multor studii independente, studii care sunt considerate 'compatibile'.

N

Numărul necesar a fi tratat

= este o modalitate numerică de a exprima probabilitatea beneficiului unui tratament, definit ca reciproca reducerii absolute a riscului.

Numărul necesar pentru a dăuna

= numărul total de pacienţi care primind tratamentul experimental vor determina pentru un pacient apariţia unui eveniment nedorit în comparaţie cu pacienţii din grupul martor .

O

Omogenitatea în sintezele sistematice

= gradul în care rezultatele studiilor incluse într-o sinteză sistematică sunt similare. Omogenitatea clinică înseamnă că participanţii, intervenţiile şi/sau mărimile rezultatului sunt similare. Studiile sunt considerate omogene statistic dacă rezultatele lor nu variază mai mult decât ne-am aştepta prin jocul întâmplării.

P

p

= probabilitatea de semnificaţie a testului statistic (nivelul cel mai mic la care ipoteza nulă poate fi respinsă). În testarea ipotezei statistice, p reprezintă probabilitatea ca o diferenţă observată între rezultatele obţinute în grupurile de intervenţie şi control să se datoreze numai întâmplării (şansei) dacă ipoteza nulă este adevarată.

Populaţia ţintă

= mulţime de elemente care au anumite caracteristici comune.

Practica medicală bazată pe evidenţe/Medicina bazată pe evidenţe

= utilizarea conştientă, explicită şi judicioasă a celor mai bune evidenţe în luarea deciziei cu privire la îngrijirea pacientului. Practica medicală bazată pe evidenţe înseamnă integrarea experienţei clinice individuale cu cele mai recente şi mai bune evidenţe rezultate din cercetările medicale.

Precizia

= gradul în care o măsurătoare (ex. media estimată a efectului unui tratament) derivă dintr-un set de observaţii care au variaţii mici (ex. au magnitudini apropiate). O măsurătoare precisă nu prezintă în mod necesar şi acurateţe.

Precizia rezultatelor unui studiu

= se referă la lărgimea intervalelor de încredere şi la puterea testelor aplicate.

Prevalenţa

= numărul de persoane dintr-o populaţie cu o boală specifică sau o condiţie/stare de boală, la un anumit moment. Uzual se exprimă ca raportul dintre numărul persoanelor afectate şi populaţia totală.

Prezentarea de caz

= raport concis, obiectiv al caracteristicilor (clinice, paraclinice şi/sau terapeutice) unui subiect sau eveniment medical.

Probabilitatea pre-test (prevalenţa bolii)

= proporţia de pacienţi cu boala de interes din totalul pacienţilor la risc pentru patologia respectivă.

Procedură medicală

= o intervenţie medicală sau chirurgicală, efectuată asupra pacientului, cu scop diagnostic sau terapeutic.

Prospectiv

= se referă la factori medicali, sociali şi de mediu consideraţi din momentul începeri studiului şi până în momentul în care studiul se termină.

Protocol clinic

= plan precise şi detaliate întocmite pentru studiul problemelor medicale sau biomedicale şi/sau terapeutice.

R

Randomizare

= extragere aleatoare din populaţia ţintă a elementelor eşantionului;
= tehnica de distribuire a pacienţilor în grupurile test şi de control care se bazează pe alocare la întâmplare. Se foloseşte pentru reducerea erorilor datorate modului de selecţie a participanţilor în studiile clinice.

Rata evenimentului de control

= proporţia pacienţilor din grupul de control care prezintă evenimentul de interes.

Rata evenimentului experimental

= proporţia pacienţilor din grupul caz care prezintă evenimentul de interes.

Rata falşilor pozitivi şi Rata falşilor negativi

= indicatori utilizaţi pentru aprecierea valorii diagnostice a unui test, derivaţi din sensibilitate şi specificitate.

Rata şansei

= riscul de a dezvolta boala în funcţie de expunere.

Raţia de probabilitate

= probabilitatea cu care un anumit rezultate al testului diagnostic (pozitiv sau negativ) apare la un pacient cu boala de interes în comparaţie cu probabilitatea cu care acelaşi rezultat apare la un pacient indemn la boala de interes.

Reducerea absolută a riscului

= diferenţa dintre rata evenimentului experimental şi rata evenimentului de control.

Reducerea relativă a riscului

= reducerea procentuală a evenimentelor din grupul caz în comparaţie cu grupul martor.

Reproductibilitatea

= capacitatea unei observaţii de a obţine acelaşi rezultat la repetarea intervenţie medicale (diagnostice sau terapeutice) în aceiaşi populaţie.

Retrospectiv

= se refera la factori medicali, sociali şi de mediu consideraţi existenţi înainte de începerea studiului.

Revizuirea literaturii

= rezumarea şi interpretarea constatărilor din cercetare raportate şi/sau publicate în literatura de specialitate. Poate include revizuiri calitative nestructurate efectuate de autori unici sau proceduri cantitative şi sistematice cum ar fi sinteza sistematică şi meta-analiza.

Riscul absolut pentru grupul caz

= riscul de apariţie al evenimentului stabilit la pacienţii din grupul caz.

Riscul absolut pentru grupul martor

= riscul de apariţie al evenimentului stabilit la pacienţii din grupul martor.

Riscul individual al celor expuşi

= proporţia de bolnavi din subiecţii expuşi factorului de risc; = probabilitatea ca un subiect să fie bolnav dacă este expus factorului de risc.

Riscul individual al celor neexpuşi

= proporţia de bolnavi din totalul subiecţilor neexpuşi factorului de risc. Probabilitatea ca un subiect să fie bolnav fără să fie expus factorului de risc.

Riscul relativ

= măsoară forţa asocierii dintre expunere şi patologia de interes – subiectul expus la factorul studiat are de Χ ori mai multe şanse de a face boala definită prin criteriul principal de evaluare faţă de subiectul neexpus.

S

Sănătatea

= starea de bine completă din punct de vedere fizic, mintal şi social şi nu numai absenţa bolii sau a infirmităţii (definiţia Organizaţie Mondiale a Sănătăţii).

Semnificaţia clinică

= concluzia că o intervenţie are un efect practic asupra pacienţilor. Semnificaţia statistică nu înseamnă implicit semnificaţie clinică. De exemplu, într-un studiu efectuat pe un număr mare de pacienţi, evidenţierea unei diferenţe mici între rezultatele observate în grupul de tratament şi cele obţinute în grupul de control poate avea semnificaţie statistică şi să nu aibă semnificaţie clinică. Într-un studiu care implică un număr mic de pacienţi se poate găsi o diferenţa clinică importantă dar care să nu fie semnificativă statistic.

Semnificaţie statistică

= concluzia stabilită în urma aplicării unui test statistic, că o intervenţie (diagnostică sau terapeutică) are un efect real, concluzie bazată pe diferenţa observată între rezultatele obţinute în grupul celor trataţi şi cele obţinute în grupul de control, grupuri care sunt suficient de mari astfel încât diferenţele să nu fie datorate întâmplării. Semnificaţia statistică indică probabilitatea ca diferenţele observate să apară datorită şansei dacă ipoteza nulă este adevărată; nu furnizează informaţii despre magnitudinea efectului unui tratament. Semnificaţia statistica este necesară dar nu suficientă în stabilirea semnificaţiei clinice.

Sensibilitate

= caracteristica de operare a unui test diagnostic care măsoară abilitatea testului de a detecta boala de interes atunci când este real prezentă. Se calculează ca şi proporţia de subiecţi cu test pozitiv din totalitatea celor bolnavi.

Serie de cazuri

= raport obiectiv al caracteristicilor clinice, paraclinice şi/sau terapeutice ale unui grup de subiecţi care prezintă o caracteristică comună. Studiu necontrolat (prospectiv sau retrospectiv) a unei serii de pacienţi care primesc o intervenţie particulară şi sunt urmăriţi pentru a observa rezultatele care apar.

Siguranţa

= capacitatea de a nu determina un efect advers atunci când se aplică o intervenţie diagnostică sau terapeutică în conformitate cu metodologia acesteia. = judecata de acceptare a unui risc (o apreciere a probabilităţii unui rezultat nefavorabil şi severitatea acestuia) asociat cu utilizarea unei tehnologii într-o situaţie dată (ex. pentru un pacient cu o problema particulară de sănătate, de către un clinician cu instruire corespunzătoare sau în condiţiile unui anumit tratament).

Sinteza sistematică

= sumarizare a literaturii medicale de specialitate care foloseşte metode explicite de căutare a celor mai valide şi importante evidenţe pentru o problemă clinică dată, evaluarea evidenţelor găsite şi care foloseşte metode statistice adecvate pentru prezentarea rezultatelor; = o evaluare critică care se desfăşoară folosind metode sistematice elaborate pentru minimizarea erorilor şi pentru combinarea rezultatelor evidenţelor existente cu privire la un subiect specific.

Specificitatea

= caracteristica de operare a unui test diagnostic care măsoară capacitatea testului de a exclude prezenta bolii când în mod real aceasta nu este prezentă. Este proporţia de subiecţi negativi din totalitatea celor indemni de boală, reprezentând capacitatea testului de a identifica subiecţii indemni de boală.

Starea de sănătate

= nivelul sănătăţii individului, grupului sau populaţiei rezultat în urma unei evaluări subiective realizată de un cercetător sau obţinută prin măsurători obiective.

Studiu caz-martor

= studiu retrospectiv în care se verifică dacă există o legătură dintre un factor de risc şi o patologie de interes, patologia de interes fiind cel mai frecvent o patologie rară.

Studii clinice randomizate

= studiile care implică un grup test şi un grup de control, o înrolare simultană a pacienţilor în cele două grupuri şi o monitorizare a rezultatelor obţinute atât în grupul test cât şi în grupul de control; tratamentul care va fi administrat fiecărui pacient în parte este atribuit aleator (fiecare pacient din studiu are aceeaşi şansă de a primi tratamentul activ ca şi de a privi tratamentul placebo).

Studiu de caz

= un studiu necontrolat observaţional (prospectiv sau retrospectiv) care implică o intervenţie şi rezultatul intervenţiei la un singur pacient (se cunosc şi sub denumirea de rapoarte unice de caz).

Studiu de cohorta

= studiu observaţional în care un grup definit de oameni (cohorta) e urmărit în timp, iar rezultatele sunt comparate în subseturi ale cohortei, care au fost sau nu expuse la un factor de interes. Cohortele pot fi asamblate în prezent şi urmărite în viitor (studiu de cohortă prospectiv) sau identificate din dosare realizate în trecut şi urmărite până în prezent (studiu de cohortă retrospectiv).

Studii experimentale

= studii prospective care necesită o rigoare specială a alcătuirii grupelor de subiecţi care vor fi comparaţi prin intervenţia cercetătorului asupra derulării fenomenului biologic. Este singura metodă care permite stabilirea unei relaţii cauză-efect.

Studiu încrucişat

= studiu clinic în care pacienţii primesc secvenţial tratamentul atribuit atât grupului test cât şi tratamentul specific grupului de control iar după o perioadă se inversează ordinea de administrare a tratamentului. În acest tip de studiu, fiecare pacient este propriul lui martor iar randomizarea se face numai pentru a stabili ordinea în care vor primi tratamentul.

Subiecte medicale evaluate critic

= procesul de evaluare şi interpretare a unei evidenţelor considerând în mod sistematic validitatea, relevanţa şi aplicabilitatea ei în practica curentă.

Studiul observaţional

= studiu care se desfăşoară prin observarea prospectivă sau retrospectivă a pacienţilor şi în care cercetătorul nu intervine în desfăşurarea naturală a procesului biologic ci doar observă desfăşurarea acestuia. Nu furnizează o relaţie cauză-efect; permite doar o prezumţie a implicării unui factor în producerea unui fenomen.

Studiul orb

= se foloseşte în trialurile clinice unde se doreşte menţinerea secretului privind alocarea în grupul de control sau de tratament faţă de pacienţi şi/sau cercetători. Această tehnică elimină posibilitatea ca răspunsul pacientului la tratament/intervenţie sau comportamentul cercetătorului să se modifice în funcţie de alocare şi să afecteze rezultatele studiului. Metoda nu poate fi practicată întotdeauna (ex. când se compară un tratament medicamentos cu unul chirurgical) dar trebuie folosită ori de câte ori este. Un studiu 'simplu orb' este acela în care pacientul nu ştie cărui grup îi aparţine (test sau martor); un studiu 'dublu orb' este acela în care nici pacienţii şi nici cercetătorii nu cunosc cărui grup au fost alocate persoanele din studiu.

Studiul prospectiv

= studiul în care cercetătorii planifică şi conduc studiul în grupuri selecţionate de pacienţi. În acest tip de studiu, cercetătorii nu cunosc care vor fi rezultatele în momentul în care încep studiul.

Studiul retrospectiv

= studiul în care cercetătorii selecţionează grupuri de pacienţi care au fost deja trataţi. Aceste studii sunt predispuse la erori a rezultatelor datorită selecţiei participanţilor deoarece cercetătorii pot selecta grupuri de pacienţi cu rezultate cunoscute.

Studiul transversal

= studiul observaţional prospectiv sau retrospectiv în care se alege un grup (uneori prin randomizare) dintr-o populaţie şi se determină expunerea la intervenţia studiată a celor din grup.

Ş

Şansa post-test

= produsul dintre probabilitatea pre-test şi raţia de probabilitate.

T

Tehnica Delphi

= metodă de sintetizare a informaţiilor provenite din cercetări primare sau secundare care nu pot fi luate în considerare în cazul realizării meta-analizelor, care se bazează pe opinii ale experţilor din domeniu. Este un proces care decurge în mai multe etape: colectarea tuturor recomandărilor, evaluarea tuturor recomandărilor de către fiecare expert prin atribuirea unui scor de oportunitate, sumarizarea scorurilor de oportunitate şi reevaluarea de către fiecare expert cu atribuirea unui nou scor de oportunitate în lumina răspunsurilor grupului, sumarizarea ultimelor scoruri şi evaluarea gradului consensual. Dacă se obţine un scor acceptabil procesul se încheie. Dacă scorul obţinut nu este satisfăcător se repetă etapa a treia de evaluare până la obţinerea unui consens în realizarea recomandărilor.

Tehnica grupului nominal

= se bazează pe realizarea unei întâlniri structurate în scopul obţinerii informaţiilor relevante pentru subiectul ghidului de practică medicală de la un grup de experţi în domeniu, grup format din 9 - 12 experţi. Metoda are la bază două etape în timpul cărora experţii punctează, discută şi ulterior reevaluează recomandările.

Test diagnostic standard

= metoda, procedura sau măsura care e acceptată ca fiind cea mai valabilă şi la care trebuie să se raporteze noile intervenţii. Se foloseşte în studiile diagnostice pentru aprecierea acurateţei unui nou test diagnostic.

Test statistic

= formulă matematică care se foloseşte pentru a stabili dacă diferenţa observată între rezultatele obţinute în grupul tratat şi cele obţinute în grupul de control este suficient de mare pentru a concluziona că sunt statistic semnificative. Testele statistice determină o valoare care este însoţită de valoarea p. Există mai multe tipuri de teste statistice: F, t, Z, chi-pătrat, ANOVA, etc. Alegerea testului statistic depinde de tipul studiul şi respectiv de modalitatea de distribuţie a datelor în populaţia de studiu.

Trial clinic

= studiul experimental riguros, în care expunerea (de cele mai multe ori la un factor terapeutic) este alocat subiecţilor prin randomizare.

U

Utilitate

= caracteristică a rezultatelor unui studiu medical în ceea ce priveşte pertinenţa ştiinţifică, prioritatea în domeniu şi respectiv eficienţa pentru pacienţi.

V

Validitatea unui studiu

= calitatea metodologică a unui studiu apreciind gradul în care construcţia, realizarea şi desfăşurarea sa a reuşit să prevină erorile sistematice; gradul în care o măsură reflectă cu acurateţe conceptul pe care intenţionează să îl măsoare.

Validitate externă

= gradul în care rezultatele obţinute în urma unei investigaţii desfăşurate în circumstanţe speciale pot fi generalizate altor circumstanţe.

Validitatea internă

= gradul în care rezultatele unui studiu reprezintă cu acurateţe relaţia cauzală dintre o intervenţie şi un rezultat în circumstanţele particulare ale studiului respectiv.

Valoarea predictivă negativă

= caracteristică de operare a testului diagnostic; este proporţia celor cu adevărat indemni de boală din totalitatea celor cu test negativ. Variază cu prevalenţa bolii în populaţia inclusă în studiu (populaţia de interes). Reprezintă capacitatea de a prezice unui subiect cu test negativ riscul de a fi indem la boală.

Valoarea predictivă pozitivă

= caracteristică de operare a testului diagnostic; este proporţia de subiecţi cu adevărat bolnavi din totalitatea celor cu test pozitiv. Variază cu prevalenţa bolii în populaţia inclusă în studiu (populaţia de interes). Reprezintă capacitatea de a prezice unui subiect cu test pozitiv riscul de a fi bolnav.

Volumul eşantionului

= numărul de pacienţi incluşi într-un studiu medicale. În general un eşantion mare scade probabilitatea de apariţie a erorilor şi creşte puterea studiului. De asemenea eşantioanele mari scad efectul variaţiilor întâmplătoare.


Dictionar

A

Acurateţea testului diagnostic

= proporţia de rezultate pozitive şi negative care sunt în concordanţă cu diagnosticul final raportat la totalul rezultatelor.

Analiza cost-beneficiu

= analiză economică care converteşte efectele unei intervenţii medicale în aceeaşi termeni monetari ca şi costurile şi îi compară.

Analiza cost-consecinţă

= evaluare economică care compara costurile şi consecinţele a doua sau mai multe alternative, în care costurile şi consecinţele nu sunt agregate şi toate rezultatele sunt exprimate în unităţi naturale.

Analiza cost-eficienţă

= analiză economic care converteşte efectele unei intervenţii medicale în termeni de sănătate şi descrie costurile pentru un câştig adiţional de sănătate.

Analiza cost-utilitate

= analiză economică care converteşte efectele unei intervenţii în preferinţele personale ale pacientului (utilităţi) şi descrie care este costul unui câştig adiţional al calităţii vieţii pacientului.

Analiza deciziei medicale

= tehnică de abordare a luării deciziilor medicale în condiţii de incertitudine prin examinarea sistematică a tuturor informaţiilor relevante pentru o decizie. Se bazează pe estimări (disponibile din literatura sau care aparţin experţilor) ale probabilităţilor ca anumite evenimente şi rezultate vor apărea şi pe valorile rezultatelor care se obţin prin aplicarea fiecărei strategii. Un arbore decizional este o reprezentare grafica a drumurilor / cailor clinice alternative Totalitatea evenimentelor posibile formează nodurile arborelui decizional iar căile prin care se ajunge la aceste evenimente sunt drumurile arborelui decizional.

Ani de viaţă ajustaţi în funcţie de calitate (QALY’s - Quality Adjusted Life Year)

= se calculează multiplicând numărul de ani de viata adăugaţi de o intervenţie cu o valoare standard care reflectă calitatea vieţii de-a lungul perioadei adăugate. Valoarea ‘0’ reprezintă decesul iar valoarea ‘1’ reprezintă starea de sănătate.

Anii de viaţă ajustaţi în funcţie de incapacitate (DALY’s – Disability Adjusted Life Years)

= o unitate a statusului îngrijirilor de sănătate care ajustează speranţa de viata la o vârsta specifică cu pierderea de sănătate şi pierderea de ani de viaţă datorită incapacităţii date de prezenta bolii.

B

Baze de date

= colecţie de informaţii ţinute, în mod normal, pe computer. Într-un anumit fel, o bază de date e similar unui sistem de dosare, dar are importante avantaje: informaţiile pot fi revizuite şi actualizate uşor, iar informaţia poate fi găsită foarte repede. Bazele de date electronice cum sunt MEDLINE, EMBASE si CDSR, pot fi distribuite pe disc, CD-ROM sau cu ajutorul Internet-ului.

Bază de date bibliografică

= un index sau o sursă computerizată de referinţe sau citaţii care cuprinde articole de revista şi alte rapoarte din literatură.

Biblioteca Cochrane

= colecţie de baze de date, imprimate pe dischetă şi CD-ROM cu informaţii actualizate trimestrial, ce cuprinde Sintezele Sistematice ale Bazei de Date Cochrane, Registrul Trialurilor Controlate Cochrane, Baza de Date a Rezumatelor Sintezelor Sistematice ale Eficacităţiii, Baza de Date a Metodologiei sintezelor Cochrane şi informaţii despre Colaborarea Cochrane.

C

Calitatea vieţii legată de sănătate

= aspecte ale calităţii vieţii legate/asociate cu starea de sănătatea sau cu îngrijirea sănătăţii. Exemple: supravieţuirea, capacitatea de a desfăşura activităţi fizice considerate normale cum ar fi mersul, conducerea unei maşini, desfăşurarea unei activităţi productive, capacitatea de auto-îngrijire şi de îngrijire a altora, absenţa depresiei, absenţa durerii, capacitatea de a vedea, auzi, vorbi, şi de a gândi.

Cercetarea serviciilor de sănătate

= integrarea epidemiologiei, sociologiei, economiei şi a altor ştiinţe în studierea serviciilor de sănătate. Se focalizează asupra relaţiei dintre nevoie – cerere – furnizare - utilizare şi asupra rezultatelor serviciilor de sănătate. Scopul cercetării presupune o evaluare în termeni de structură, proces, rezultat intermediar şi final a unui serviciu de sănătate.

Comorbiditate

= afecţiune care însoţeşte diagnosticul principal şi care necesită tratament şi îngrijiri suplimentare pe lângă tratamentul afecţiunii pentru care pacientul sa internat.

Complianţa

= o măsura a gradului în care pacienţii urmează un regim de viaţă, alimentar, terapeutic, diagnostic.

Complicaţia unei boli

= este afecţiunea care apare pe parcursul episodului de boală, determinată de una din afecţiunile pre-existente sau de îngrijirile primite de pacient.

Consens

= formă de judecată în care un grup de experţi interacţionează în evaluarea unei intervenţii şi formularea de recomandări prin vot sau altă metodă de obţinere a consensului. Procesul poate fi formal sau informal - implicând tehnici cum ar fi tehnica grupului nominal şi/sau tehnica Delphi.

Creşterea beneficiului relativ

= creşterea proporţională a ratei evenimentului dorit la grupul caz faţă de grupul martor.

Creşterea beneficiului absolut

= diferenţa matematică absolută între rata evenimentului dorit la cazuri şi martori.

Creşterea riscului relativ

= proporţia creşterii ratei de apariţie a unui eveniment nedorit la grupul caz faţă de grupul martor.

Creşterea riscului absolut

= diferenţa matematică absolută între rata evenimentului nedorit la cazuri şi martori.

Criterii de includere în studiu

= condiţiile în care o entitate este un element al populaţiei ţintă poate fi inclus în eşantionul de studiu.

Criterii de excludere din studiu

= condiţiile în care o entitate nu aparţine eşantionului de studiu.

Colaborarea Cochrane

= organizaţie internaţională al cărui scop este de ajuta oamenii să fie mai informaţi în luarea deciziilor privind sănătatea prin pregătirea, menţinerea şi asigurarea accesibilităţii sintezelor sistematice.

D

Diagnostic principal

= diagnosticul considerat ca fiind principalul responsabil de internarea în spital, stabilit după evaluarea pacientului, în momentul externării din spital.

Diagnostic secundar

= diagnosticul care fie coexistă cu afecţiunea principală (diagnosticul principal) la momentul internării, fie apare în timpul episodului de boală.

Diseminarea informaţiei medicale

= orice proces prin care informaţia medicală este transmisă, accesibilă pentru o audienţă stabilită sau pentru un grup ţintă.

Drum clinic (cale clinică)

= un set multidisciplinar de prescrieri zilnice folosite în îngrijirea unei categorii specifice de pacienţi (ex. din momentul pre-admiterii în spital până după). Adesea, scopul elaborării acestor drumuri clinice este de a îmbunătăţii calitatea îngrijirilor şi de a scădea costurile îngrijirilor medicale.

E

Eficacitate

= capacitatea de a determina efectul aşteptat în condiţii ideale (dovezi rezultate din studii desfăşurate in vitro, sau din studii randomizate desfăşurate în centre de vârf cum ar fi un spital universitar de elita).

Eficacitatea unui tratament

= proporţia de rezultate favorabile înregistrate la pacienţii care au urmat tratamentul.

Eficienţă

= capacitatea de a determina efectul aşteptat în condiţii normale şi uzuale. Se referă la dovezi rezultate din studii clinice.

Eficienţa unui tratament

= reprezintă proporţia de rezultate favorabile înregistrate la pacienţii cărora li s-a prescris acel tratament, fără a şti sau a se ţine cont dacă aceştia au respectat tratamentul sau nu.

Episod de îngrijiri de boală

= perioada de îngrijire a pacientului internat, cuprinsă între o internare şi o externare, caracterizată printr-un singur tip de îngrijire.

Eroare sistematică

= factor care poate surveni în conceperea, execuţia sau analiza unui studiu, conducând la o alterare a estimării rezultatelor (supra sau subestimarea acestora).

Eroare sistematică de confuzie

= reprezintă situaţia în care o măsură a unui efect al unei intervenţii sau expuneri e distorsionată din cauza asocierii expunerii cu alţi factori care pot influenţa rezultatul studiului.

Eroare sistematică de informare sau observare

= eroare în culegerea datelor sau în modalitatea de măsurarea a rezultatelor.

Eroare sistematică de selecţie

= eroare în stabilirea criteriilor de incluziune a subiecţilor într-un grup sau altul.

Eşantion

= submulţime finită din populaţia ţintă.

Evaluare economică

= analiza comparativă a direcţiilor de acţiune în termeni de costuri şi consecinţe;

= un set de metode formale cantitative folosite pentru a compara strategii alternative în legătură cu folosirea resurselor şi rezultatele aşteptate pentru fiecare acţiune.

Evaluarea tehnologiilor în îngrijirile de sănătate

= formă comprehensivă de cercetare strategică care explorează consecinţele directe şi indirecte, intenţionate şi neintenţionate pe termen scurt şi lung ale aplicării tehnologiei în îngrijirea pacienţilor;

= evaluarea sistematică a proprietarilor, efectelor şi/sau altor impacte ale tehnologiilor în îngrijirile de sănătate. Scopul principal este de a furniza informaţii obiective care să susţină luarea deciziei în îngrijirile de sănătate şi strategiile la nivel local, regional, naţional şi internaţional. Evaluarea tehnologiilor medicale este realizata de grupuri interdisciplinare care folosesc metode analitice explicite.

Excesul de risc (risc atribuabil)

= partea din riscul absolut care este imputabilă expunerii la factorul de risc studiat. Măsoară specificitatea legăturii între factorul prognostic şi îmbolnăvire sau partea din riscul absolut care este imputabilă expunerii la factorul de risc studiat.

F

Factor de confuzie

= caracteristică sau factor care împiedică rezultatul dorit şi care este în acelaşi timp corelat cu factori cauzali sau caracteristici investigate. Dacă factorii de confuzie nu sunt controlaţi determină erori de estimare a impactului factorilor cauzali sau a caracteristicilor investigate.

Farmacoeconomie

= aplicarea metodelor de evaluare economică a programelor de sănătate pentru intervenţii care includ produse farmaceutice.

Fracţia etiologică a riscului la expuşi

= măsoară specificitatea legăturii dintre expunere şi patologia de interes

G

Ghid de practică medicală

= sinteză creată pentru a ajuta practicienii şi pacienţi în luarea unor decizii de sănătate cu privire la o condiţie clinică specifică; instrucţiuni sau principii reprezentând reguli de politică de sănătate curentă sau viitoare realizate pentru practicieni, cu scopul de a sprijini luarea deciziei în îngrijirea pacientului privind diagnosticul, terapia sau alte situaţii clinice. Ghidurile de practica pot fi elaborate de o agenţie guvernamentală aflată la orice nivel, instituţii, societăţi profesionale, comitete de conducere sau prin reunirea grupurilor de experţi. Ghidurile formează o bază de evaluare a tuturor aspectelor îngrijirilor de sănătate.

Grup de control

= un grup de pacienţi care serveşte ca bază de comparaţie pentru evaluarea efectelor unei intervenţii de interes asupra grupului de tratament. În funcţie de circumstanţele în care se desfăşoară studiul grupul de control nu va primi nici un tratament, va primi un tratament “uzual”/obişnuit sau “standard” sau un placebo. Pentru a face comparaţia validă, grupul de control va fi cât se poate de similar cu grupul tratat.

H

Heterogenitate

= variabilitatea sau diferenţele dintre studii, referitor la estimarea efectelor. Se foloseşte la prezentarea rezultatelor meta-analizelor. Se face distincţie între heterogenitatea statistică (diferenţe între efectele raportate), heterogenitatea metodologică (diferenţe în construcţia studiului) şi heterogenitatea clinică (diferenţe între caracteristicile-cheie ale participanţilor, intervenţiilor sau mărimilor rezultatului). Testele statistice de heterogenitate se folosesc pentru a evalua dacă variabilitatea observat în rezultatele studiului (mărimile efectului) e mai mare decât cea la care se ajunge din întâmplare

I

Incidenţa

= rata de apariţie a cazurilor sau condiţiilor noi de boală într-o populaţie aflată la risc într-o perioadă dată de timp (de obicei un an).

Index Medicus

= catalogul Bibliotecii Naţionale Medicale a Statelor Unite ale Americii şi un index periodic al literaturii medicale

Interval de încredere/Interval de confidenţă

= intervalul în care ne aşteptăm ca valoarea adevărată (de ex. mărimea efectelor unei intervenţii) să fie falsă, cu un grad dat certitudine ales arbitrat de cercetător (de ex. 95% sau 99% ). Intervalul de confidenţă reprezint probabilitatea erorilor de randomizare, şi nu a erorilor sistematice. De exemplu, exista o probabilitate de 95% ca intervalul de încredere 95% calculat într-un studiu să includă valoarea reală a efectului tratamentului.

Ipoteza nulă

= în testarea unei ipoteze statistice, ipoteza care spune că intervenţia nu are nici un efect ex. arată că nu există nici o deosebire între rezultatele obţinute de grupul de tratament şi cele din grupul control. Dacă testul statistic indică faptul ca valoarea p se afla la sau deasupra unei valori specificate α (ex. 0.01 sau 0.05, care reprezintă probabilitatea de a face eroare pozitivă) atunci orice efect observat al tratamentului nu este semnificativ statistic iar ipoteza nulă nu poate fi respinsă. Dacă valoarea p este mai mică decât valoarea α specificată, atunci efectul tratamentului este statistic semnificativ iar ipoteza nulă va fi respinsă. Dacă intervalul de încredere (ex. de 95% sau 99%) include efect “0” al tratamentului , atunci ipoteza nulă nu poate fi respinsă.

L

Literatura “gri”

= rapoarte de studii de cercetare care nu apar în baze de date publice - MEDLINE sau în alte baze de date electronice similare. De exemplu monografii produse de agenţii guvernamentale, lucrări prezentate la simpozioane, conferinţe, întâlniri anuale, ale unor societăţi/organizaţii, rapoarte întocmite de diferite companii (ca de ex. cele care produc şi distribuie tehnologii medicale) care sunt nepublicate. Metodele folosite în cercetarea literaturii de această natură includ verificarea referinţelor din indexul studiilor, verificarea registrelor care descriu studiile randomizate desfăşurate, contactarea cercetătorilor pentru obţinerea materialelor nepublicate, contactarea guvernanţilor, asociaţiilor profesionale, sau a altor comisii relevante care au legătură cu studiile respective, căutarea în biblioteci a tezelor de doctorat, traducerea unor studii apărute în reviste în limbi care nu sunt de circulaţie internaţională.

M

Managementul bolii

= proces sistematic de control al îngrijirii pacientului care prezintă o boala acută sau cronică vis-a-vis de servicii extraspitaliceşti, intraspitaliceşti şi servicii auxiliare. Scopul controlului include: reducerea episoadelor acute de boală, reducerea spitalizărilor, reducerea variaţiilor de îngrijire, îmbunătăţirea rezultatelor îngrijirii şi reducerea costurilor. Managementul bolilor poate implica îmbunătăţirea continuă a calităţii sau alte modele de management. Poate include şi un proces ciclic de urmare a protocoalelor de practică, prin măsurarea rezultatelor, trimiterea rezultatelor înapoi la clinicieni şi revizuirea protocoalelor atunci când este nevoie.

Managementul calităţii totale

= aplicarea practicilor din managementul industrial cu scopul menţinerii şi îmbunătăţirii performanţei organizaţiilor. Eficacitatea şi succesul sunt determinate şi evaluate prin intermediul măsurătorilor cantitative aplicate în studiul calităţii.

Medicina bazata pe evidenţe

= utilizarea explicită, judicioasă, atentă a celor mai bune evidenţe curente în luarea deciziei privind îngrijirea individuală a pacientului. Practica medicinii bazata pe evidenţe presupune integrarea experienţei individuale a clinicianului cu cele mai bune evidenţe clinice externe rezultate din cercetarea sistematica. Constă în procesul sistematic de căutare, evaluare şi utilizare a descoperirilor cercetărilor recente ca bază pentru luarea deciziilor clinice. Practica medicală bazată pe evidenţe se desfăşoară prin parcurgerea a patru etape: formularea unei întrebări clare referitoare la o problema a pacientului; căutarea unei evidenţe ştiinţifice relevante; evaluarea critică a evidenţelor găsite din punct de vedere al validităţii şi utilităţii; implementarea în practica clinică a aspectelor utile găsite. Termenul a fost creat de un grup de cercetători de la McMaster Medical School, Canada în anii ’80 pentru a denumi strategia clinică de învăţare pe care o dezvoltă de peste 10 ani.

Medline

= bază de date electronică creată de Biblioteca Naţională de Medicină SUA. Ea cuprinde milioane de articole din jurnale selecţionate (în jur de 3.700). Anul de acoperire - din 1966 până în prezent.

MeSH

= termen utilizat de Biblioteca National a Medicinei SUA pentru a identifica articole în cuprinsul medical de pe MEDLINE. A fost conceput pentru a reduce problemele ce poate să apară, de exemplu, din diferenţele dintre ortografierea britanică şi americană. Sistemul MeSH are o structură de trunchi în care termenii unor subiecte largi sunt ramuri într-o serie de termeni ai subiectelor îngustate progresiv.

Meta-analiza datelor medicale

= metodă sistematică care utilizează tehnici statistice de combinare a rezultatelor provenite din studii diferite pentru a obţine un estimator cantitativ unic care să caracterizeze toate studiile incluse în meta-analiză.

= procedură statistică prin intermediul căreia se realizează integrarea rezultatelor mai multor studii independente, studii care sunt considerate "compatibile".

N

Numărul necesar a fi tratat

= este o modalitate numerică de a exprima probabilitatea beneficiului unui tratament, definit ca reciproca reducerii absolute a riscului.

Numărul necesar pentru a dăuna

= numărul total de pacienţi care primind tratamentul experimental vor determina pentru un pacient apariţia unui eveniment nedorit în comparaţie cu pacienţii din grupul martor .

O

Omogenitatea în sintezele sistematice

= gradul în care rezultatele studiilor incluse într-o sinteză sistematică sunt similare. Omogenitatea clinică înseamnă că participanţii, intervenţiile şi/sau mărimile rezultatului sunt similare. Studiile sunt considerate omogene statistic dacă rezultatele lor nu variază mai mult decât ne-am aştepta prin jocul întâmplării.

P

p

= probabilitatea de semnificaţie a testului statistic (nivelul cel mai mic la care ipoteza nulă poate fi respinsă). În testarea ipotezei,p reprezintă probabilitatea ca o diferenţă observată între rezultatele obţinute în grupurile de intervenţie şi control să se datoreze numai întâmplării (şansei) dacă ipoteza nulă este adevarată.

Populaţia ţintă

= mulţime de elemente care au anumite caractere comune.

Practica medicală bazată pe evidenţe/Medicina bazată pe evidenţe

= utilizarea conştientă, explicită şi judicioasă a celor mai bune evidenţe în luarea deciziei cu privire la îngrijirea pacientului. Practica medicală bazată pe evidenţe înseamnă integrarea experienţei clinice individuale cu cele mai recente şi mai bune evidenţe rezultate din cercetările medicale.

Precizia

= gradul în care o măsurătoare (ex. media estimată a efectului unui tratament) derivă dintr-un set de observaţii care au variaţii mici (ex. au magnitudini apropiate). O măsurătoare precisă nu prezintă în mod necesar şi acurateţe.

Precizia rezultatelor unui studiu

= se referă la lărgimea intervalelor de încredere şi la puterea testelor aplicate.

Prevalenţa

= numărul de persoane dintr-o populaţie cu o boală specifică sau o condiţie/stare de boală, la un anumit moment. Uzual se exprimă ca raport al numărului persoanelor afectate şi populaţia totală.

Prezentarea de caz

= raport concis, obiectiv al caracteristicilor clinice, paraclinice şi/sau terapeutice a unui subiect sau eveniment medical

Probabilitatea pre-test (prevalenţa bolii)

= proporţia de pacienţi cu boala de interes din totalul pacienţilor la risc pentru patologia respectivă.

Procedură medicală

= o intervenţie medicală sau chirurgicală, efectuată asupra pacientului, cu scop diagnostic sau terapeutic.

Prospectiv

= se refera la factori medicali, sociali şi de mediu consideraţi din momentul începeri studiului şi până în momentul în care studiul se termină.

Protocoale clinic

= planuri precise şi detaliate întocmite pentru studiul problemelor medicale sau biomedicale şi/sau terapeutice.

R

Randomizare

= extragere aleatoare din populaţia ţintă a elementelor eşantionului;

= tehnica de distribuire a pacienţilor în grupurile test şi de control care se bazează numai pe alocare la întâmplare. Se foloseşte pentru reducerea erorilor datorata modului de selecţie a participanţilor în studiile clinice.

Rata evenimentului de control

= proporţia pacienţilor din grupul de control care prezintă evenimentul de interes.

Rata evenimentului experimental

= proporţia pacienţilor din grupul caz care prezintă evenimentul de interes.

Rata falşilor pozitivi şi Rata falşilor negativi

= indicatori utilizaţi pentru aprecierea valorii diagnostice a unui test derivaţi din sensibilitate şi specificitate.

Rata şansei

= riscul de a dezvolta boala în funcţie de expunere.

Raţia de probabilitate

= probabilitatea cu care un anumit rezultate al testului diagnostic (pozitiv sau negativ) apare la un pacient cu boala de interes în comparaţie cu probabilitatea cu care acelaşi rezultat apare la un pacient indemn la boala de interes.

Reducerea riscului absolut

= diferenţa dintre rata evenimentului la grupul experimental şi rata evenimentului la grupul de control.

Reducerea riscului relativ

= reducerea procentuală a evenimentelor gin grupul caz în comparaţie cu grupul martor.

Reproductibilitate

= capacitatea unei observaţii care se repetă în aceiaşi populaţie să determine acelaşi rezultat. De asemenea, abilitatea unei singure observaţii să distingă constant indivizii din populaţie.

Retrospectiv

= se refera la factori medicali, sociali şi de mediu consideraţi existenţi înainte de începerea studiului.

Revizuirea literaturii

= rezumarea şi interpretarea constatărilor din cercetare raportate şi/sau publicate în literatura de specialitate. Poate include revizuiri calitative nestructurate efectuate de autori unici sau proceduri cantitative şi sistematice cum ar fi sinteza sistematică şi meta-analiza.

Riscul absolut pentru grupul caz

= riscul de apariţie al evenimentului stabilit la pacienţii din grupul caz.

Riscul absolut pentru grupul martor

= riscul de apariţie al evenimentului stabilit la grupul martor.

Riscul individual al celor expuşi

= proporţia de bolnavi din subiecţii expuşi factorului de risc. Probabilitatea ca un subiect să fie bolnav dacă este expus factorului de risc.

Riscul individual al celor neexpuşi

= proporţia de bolnavi din totalul subiecţilor neexpuşi factorului de risc. Probabilitatea ca un subiect să fie bolnav fără să fie expus factorului de risc.

Riscul relativ

= măsoară forţa asocierii dintre expunere şi patologia de interes – subiectul expus la factorul studiat are de Χ ori mai multe şanse de a face boala definită prin criteriul principal de evaluare faţă de subiectul neexpus.

S

Sănătatea

= starea de bine completă din punct de vedere fizic, mintal şi social şi nu numai absenţa bolii sau a infirmităţii (definiţia Organizaţie Mondiale a Sănătăţii).

Semnificaţia clinică

= concluzia că o intervenţie are un efect practic asupra pacienţilor. Semnificaţia statistică nu înseamnă implicit semnificaţie clinică. De exemplu, într-un studiu efectuat pe un număr mare de pacienţi, evidenţierea unei diferenţe mici între rezultatele observate în grupul de tratament şi cele obţinute în grupul de control poate avea semnificaţie statistică dar fără semnificaţie din punct de vedere clinic. Într-un studiu care implică un număr mic de pacienţi se poate găsi o diferenţa clinică importantă dar care să nu fie semnificativă statistic.

Semnificaţie statistică

= concluzia stabilită în urma aplicării unui test statistic, că o intervenţie are un efect real, concluzie bazată pe diferenţa observată între rezultatele obţinute în grupul tratat şi cele obţinute în grupul de control, grupuri care sunt suficient de mari astfel încât diferenţele să nu fie datorate întâmplării. Semnificaţia statistică indică probabilitatea ca diferenţele observate să apară datorită şansei dacă ipoteza nulă este adevărată; nu furnizează informaţii despre magnitudinea efectului unui tratament. Semnificaţia statistica este necesară dar nu suficientă în stabilirea semnificaţiei clinice.

Sensibilitate

= caracteristica de operare a unui test diagnostic care măsoară abilitatea testului de a detecta boala (sau condiţia) atunci când este real prezentă. Se calculează ca şi proporţia de subiecţi cu test pozitiv din totalitatea celor bolnavi.

Serie de cazuri

= rapoarte obiective al caracteristicilor clinice, paraclinice şi/sau terapeutice ale unui grup de subiecţi care prezintă o caracteristică comună. Studiu necontrolat (prospectiv sau retrospectiv) a unei serii de pacienţi care primesc o intervenţie particulară şi sunt urmăriţi pentru a observa rezultatele care apar.

Siguranţa

= capacitatea de a nu determina o daună atunci când se aplică o intervenţie în mod corect (aşa cum a fost proiectată să fie aplicată). Judecata de acceptare a unui risc (o apreciere a probabilităţii unui rezultat nefavorabil şi severitatea acestuia) asociat cu utilizarea unei tehnologii într-o situaţie dată (ex. pentru un pacient cu o problema particulară de sănătate, de către un clinician cu instruire corespunzătoare sau în condiţiile unui anumit tratament).

Sinteza sistematică

= sumarizare a literaturii medicale de specialitate care foloseşte metode explicite de căutare a celor mai valide şi importante evideneţe pentru o problemă clinică dată, evaluarea evidenţelor găsite şi care foloseşte metode statistice adecvate pentru prezentarea rezultatelor;

= o evaluare critică care se desfăşoară folosind metode sistematice elaborate pentru minimizarea erorilor şi pentru a combina evidenţele existente cu privire la un subiect specific.

Specificitatea

= caracteristica de operare a unui test diagnostic care măsoară capacitatea testului de a exclude prezenta bolii când In mod real nu este prezentă. Este proporţia de subiecţi negativi din totalitatea celor indemni de boală, reprezentând capacitatea testului de a identifica subiecţii indemni de boală.

Starea de sănătate

= nivelul sănătăţii individului, grupului sau populaţiei rezultat în urma unei evaluări subiective realizată de individ sau obţinută prin măsurători obiective.

Studiul caz-martor

= studiu retrospectiv în care se verifică dacă există o legătură dintre un factor de risc şi o patologie de interes.

Studii clinice randomizate

= studiile care implică un grup test şi un grup de control, o înrolare simultană şi o monitorizare a rezultatelor obţinute atât în grupul test cât şi în grupul de control şi în care tratamentele care vor fi administrate sunt selecţionate printr-un proces randomizare.

Studiul de caz

= un studiu necontrolat observaţional (prospectiv sau retrospectiv) care implică o intervenţie şi rezultatul intervenţiei la un singur pacient (se cunosc şi sub denumirea de rapoarte unice de caz).

Studiul de cohorta

= studiu observaţional în care un grup definit de oameni (cohorta) e urmărit în timp, iar rezultatele sunt comparate în subseturi ale cohortei, care au fost sau nu expuse la un factor de interes. Cohortele pot fi asamblate în prezent şi urmărite în viitor (studiu de cohortă prospectiv) sau identificate din dosare realizate în trecut şi urmărite până în prezent (studiu de cohortă retrospectiv).

Studii experimentale

= studii prospective care necesită o rigoare specială a alcătuirii grupelor de subiecţi care vor fi comparaţi prin intervenţia cercetătorului asupra derulării fenomenului biologic. Este singura metodă care permite stabilirea unei relaţii cauză-efect.

Studiul încrucişat

= studiu clinic în care pacienţii primesc secvenţial tratamentul atribuit atât grupului test cât şi tratamentul specific grupului de control iar după o perioadă se inversează ordinea de administrare a tratamentului. În acest tip de studiu, pacienţii sunt şi test şi propriul control iar randomizarea se face numai pentru a stabili ordinea în care vor primi tratamentul.

Subiecte medicale evaluate critic

= procesul de evaluare şi interpretare a unei evidenţelor considerând în mod sistematic validitatea, relevanţa şi aplicabilitatea ei în practica curentă.

Studiul observaţional

= studiu care se desfăşoară prin observarea prospectivă sau retrospectivă a pacienţilor şi în care cercetătorul nu intervine în desfăşurarea naturală a procesului biologic ci doar observă desfăşurarea acestuia. Nu furnizează o relaţie cauză-efect; permite doar o prezumţie a implicării unui factor în producerea unui fenomen.

Studiu orb

= se foloseşte în studiile clinice (clinical trial) unde se doreşte menţinerea secretului privind alocarea în grupul de control sau de tratament faţă de pacienţi şi/sau investigatori. Această tehnică elimină posibilitatea ca răspunsul pacientului la tratament/intervenţie sau comportamentul investigatorului să se modifice în funcţie de alocare şi să afecteze rezultatele studiului. Metoda nu poate fi practicată totdeauna (ex. când se compara un tratament medicamentos cu unul chirurgical) dar trebuie folosită ori de câte ori este. Un studiu “simplu orb” este acela în care pacientul nu ştie cărui grup îi aparţine (test sau de control); un studiu “dublu orb” este acela în care nici pacienţii şi nici investigatorii nu cunosc cărui grup au fost alocate persoanele din studiu.

Studiul prospectiv

= studiul în care investigatorii planifică şi conduc intervenţia în grupuri selecţionate de pacienţi. În acest tip de studiu, investigatorii nu cunosc care vor fi rezultatele în momentul în care încep studiul.

Studiul retrospectiv

= studiul în care investigatorii selecţionează grupuri de pacienţi care au fost deja trataţi. Aceste studii sunt predispuse la erori a rezultatelor datorită selecţiei participanţilor deoarece investigatorii pot selecta grupuri de pacienţi cu rezultate cunoscute.

Studiul transversal

= studiul observaţional prospectiv sau retrospectiv în care se alege un grup (uneori prin randomizare) dintr-o populaţie şi se determină expunerea la intervenţia studiată a celor din grup.

Ş

Şansa post-test

= produsul dintre probabilitatea pre-test şi raţia de probabilitate.

T

Tehnica Delphi

= metodă de sintetizare a informaţiilor provenite din cercetări primare sau secundare care nu pot fi luate în considerare în cazul realizării meta-analizelor care se bazează pe opinii ale experţilor din domeniu. Este un proces care decurge în mai multe etape: colectarea tuturor recomandărilor, evaluarea tuturor recomandărilor de către fiecare expert prin atribuirea unui scor de oportunitate, sumarizarea scorurilor de oportunitate şi reevaluarea de către fiecare expert cu atribuirea unui nou scor de oportunitate în lumina răspunsurilor grupului, sumarizarea ultimelor scoruri şi evaluarea gradului consensual. Dacă se obţine un scor acceptabil procesul se încheie. Dacă scorul obţinut nu este satisfăcător se repetă etapa a treia de evaluare până la obţinerea unui consens în realizarea recomandărilor.

Tehnica grupului nominal

= se bazează pe realizarea unei întâlniri structurate în scopul obţinerii informaţiilor relevante pentru subiectul ghidului de practică medicală de la un grup de experţi în domeniu, grup format din 9 - 12 experţi. Metoda are la bază două etape în timpul cărora experţii punctează, discută şi ulterior reevaluează recomandările.

Test diagnostic standard

= metoda, procedura sau măsura care e acceptată ca fiind cea mai valabilă la care trebuie să se raporteze noile intervenţii. Se foloseşte în studiile diagnostice pentru aprecierea acurateţei unui nou test diagnostic.

Test statistic

= formulă matematică care se foloseşte pentru a stabili dacă diferenţa observată între rezultatele obţinute în grupul tratat şi cele obţinute în grupul de control este suficient de mare pentru a concluziona că sunt statistic semnificative. Testele statistice determină o valoare care se asociază cu valoarea lui p. Există mai multe tipuri de teste statistice: F, t, Z, chi-patrat, ANOVA, etc. Alegerea testului statistic depinde de tipul studiul şi respectiv de modalitatea de distribuţie a datelor.

Trial clinic

= studiul experimental riguros, în care expunerea (de cele mai multe ori la un factor terapeutic) este alocat subiecţilor prin randomizare.

U

Utilitate

= caracteristicile rezultatelor unui studiu medical în ceea ce priveşte pertinenţa ştiinţifică, prioritatea în domeniu şi respectiv a eficienţei pentru pacienţi.

V

Validitatea unui studiu

= calitatea metodologică a unui studiu apreciind gradul în care construcţia, realizarea şi desfăşurarea sa a reuşit să prevină erorile sistematice; gradul în care o măsură reflectă cu acurateţe conceptul pe care intenţionează să îl măsoare.

Validitate externă

= gradul în care rezultatele obţinute în urma unei investigaţii desfăşurate în circumstanţe speciale pot fi generalizate altor circumstanţe.

Validitatea internă

= gradul în care rezultatele unui studiu reprezintă cu acurateţe relaţia cauzală dintre o intervenţie şi un rezultat în circumstanţele particulare ale studiului respectiv.

Valoarea predictivă negativă

= caracteristică de operare a testului diagnostic; este proporţia celor cu adevărat indemni de boală din totalitatea celor cu test negativ. Variază cu prevalenţa bolii în populaţia inclusă în studiu (populaţia de interes). Reprezintă capacitatea de a prezice unui subiect cu test negativ riscul de a fi indem la boală.

Valoarea predictivă pozitivă

= caracteristică de operare a testului diagnostic; este proporţia de subiecţi cu adevărat bolnavi din totalitatea celor cu test pozitiv. Variază cu prevalenţa bolii în populaţia inclusă în studiu (populaţia de interes). Reprezintă capacitatea de a prezice unui subiect cu test pozitiv riscul de a fi bolnav.

Volumul eşantionului

= numărul de pacienţi incluşi într-un studiu medicale. În general un eşantion mare scade probabilitatea de apariţie a erorilor şi creşte puterea studiului. De asemenea eşantioanele mari scad efectul variaţiilor întâmplătoare.